Eliminating Free Edges

Moderator: GiD Team

mohjee
Posts: 3
Joined: Mon Nov 11, 2019 11:06 pm

Eliminating Free Edges

Postby mohjee » Tue Nov 12, 2019 5:57 pm

Hi,

I am learning how to create meshes of simple shapes.
I currently have meshed the surfaces of a trapezoid, but when I look at the edges, I see extra elements that have an node that doesn't get used in another element. Is there any way to remove "free edges" (circled in red).
Snapshot.png
Snapshot.png (169.11 KiB) Viewed 107 times

I've tried creating an unstructured and structured mesh, but it seems to be only so much. I've gone through and changed the import/export tolerance to barely below the part thickness but that also still leaves remaining free edges. My goal originally was to have a random (unstructured) mesh, but seems like there aren't any complete automatic way to do the above.

I am used to working in Femap, and there is a tool that does the above, but can't find any procedure other than having to manually move nodes in GiD.

I appreciate all the help I can get. Thanks!
User avatar
escolano
Posts: 1593
Joined: Thu Sep 18, 2014 3:31 pm

Re: Eliminating Free Edges

Postby escolano » Wed Nov 13, 2019 12:36 pm

It seems that your geometric model doesn't has a volume, but only surfaces,
and these surfaces are not sharing the lines and probably also the points.

You must do collapse, with a tolerance, as you pointed (entities close than this tolerance must be joined)
The automatic tolerance value is usually good, set a user value only when needed.
In Utilities->Preferences... verify that your Import tolerance is "Automatic" (if you set an "User value" must use a appropriated value, not too big)

When importing, if "Automatic collapse after import" checkbox is set, then the collapse of the whole model is done.

In any case, it is possible to do after a collapse, of the whole model, or only of a selection of entities.
Geometry->Edit->Collapse

In your case try
Geometry->Edit->Collapse->Model, with automatic tolerance
and generate again the mesh

If you don't have the expected result, attach a zip of the model
mohjee
Posts: 3
Joined: Mon Nov 11, 2019 11:06 pm

Re: Eliminating Free Edges

Postby mohjee » Wed Nov 13, 2019 2:55 pm

escolano wrote:It seems that your geometric model doesn't has a volume, but only surfaces,
and these surfaces are not sharing the lines and probably also the points.


There was a volume, but I deleted that because I didn't want the interior material to be meshed.
Does it matter if the volume is deleted? Since I did the following and it still meshed the volume:
1.Unstructured mesh>assign size to surface>> 0.006mm
2.Select element type>>triangle
3.Generate mesh


The shape should be sealed and watertight.

I do have automatic collapse checked on the import window dialog. But checked the import tolerance Automatic.

Not sure what I am doing differently now then previously, but the mesh seems to be aligning perfectly now.
User avatar
escolano
Posts: 1593
Joined: Thu Sep 18, 2014 3:31 pm

Re: Eliminating Free Edges

Postby escolano » Wed Nov 13, 2019 8:25 pm

Instead of do
1.Unstructured mesh>assign size to surface>> 0.006mm
2.Select element type>>triangle
3.Generate mesh

you can simply do
1.Generate mesh, with general mesh size=0.006 units
(by default surface mesh is triangles, and the general size is used when there is not any specific assigned entity size)
mohjee
Posts: 3
Joined: Mon Nov 11, 2019 11:06 pm

Re: Eliminating Free Edges

Postby mohjee » Wed Nov 13, 2019 8:41 pm

escolano wrote:you can simply do
1.Generate mesh, with general mesh size=0.006 units
(by default surface mesh is triangles, and the general size is used when there is not any specific assigned entity size)

This would mesh the interior material as well correct? I only need a surface mesh to be made.
User avatar
escolano
Posts: 1593
Joined: Thu Sep 18, 2014 3:31 pm

Re: Eliminating Free Edges

Postby escolano » Mon Nov 18, 2019 4:18 pm

if do you have a volume off course the volume is meshed.
If you don't want volumes simple delete them if they exists.

Return to “Mesh”

Who is online

Users browsing this forum: No registered users and 0 guests