Page 1 of 1

number of contour elements in unstructured surfaces

Posted: Tue Jun 04, 2019 7:06 pm
by parduino
Hi

GiD indicates the number of contour elements in unstructured surfaces must be even.
In versions (before 14) when an unstructured surface was assigned uneven number of surface segments GiD was smart to try with an even number of segments. This simplified possible user errors when assigning number of segments on lines.
Is this something not allowed anymore in version 14 (or consider a bug) ?? Is there a preference that must be checked??
Thanks

Re: number of contour elements in unstructured surfaces

Posted: Wed Jun 05, 2019 6:11 pm
by escolano
In case of unstructured triangles there is no restriction of the number of divisions even/uneven

In case of unstructured quadrilaterals the sum of divisions of its boundary must be always even (it is not a specific GiD limitation, it is topologically impossible have quadrilaterals with uneven amount of boundary edges)
Some particular line could have uneven divisions, but the boundary loop must have a even amount.

Meshing with unstructured quadrilaterals, if do you manually assign a number of divisions to lines, it is better to use a even number.
GiD automatically try to set a number of divisions feasible.

Maybe in your case it is an error of some GiD version, please, attach your example as a zip to this forum.

Re: number of contour elements in unstructured surfaces

Posted: Wed Jun 05, 2019 6:49 pm
by parduino
Hi Attached a case that meshes well in version 13 but has problems when meshing in ver14.
There is no doubt the problem is with a unstructure surface with uneven number of division in the boundaries (and quad elements). Our problem is that GiD does not indicate which surface has this problem, and in version 13 GiD resolved the problem authomatically (I imagine by making sure the # of divisions was even). Any suggestion helps.

Re: number of contour elements in unstructured surfaces

Posted: Wed Jun 12, 2019 4:54 pm
by parduino
Hi,

Just checking if you had a time to look into this case. Meshing with GiD14 fails and a message appears in the command line indicating there are a few surfaces with uneven number of divisions on the boundaries but do not indicate which surfaces. The attached .gid files shows the problem.
Thanks

parduino wrote:Hi Attached a case that meshes well in version 13 but has problems when meshing in ver14.
There is no doubt the problem is with a unstructure surface with uneven number of division in the boundaries (and quad elements). Our problem is that GiD does not indicate which surface has this problem, and in version 13 GiD resolved the problem authomatically (I imagine by making sure the # of divisions was even). Any suggestion helps.

Re: number of contour elements in unstructured surfaces

Posted: Wed Jun 12, 2019 5:06 pm
by escolano
We already didn't had time to debug your case

we have only time to confirm that we are able to repeat the problem.
we will study it and provide some solution (be able to mesh it or provide better information to allow the user locate and avoid it)

Re: number of contour elements in unstructured surfaces

Posted: Thu Jun 27, 2019 10:14 am
by abelcs
Hello,
we have finally been able to reproduce this behavior, and we have solved the problem. The next developer version (14.1.4d) will be released with this bug fixed.
Thanks so much for notifying us the bug.

ABEL