Strange surfaces with flat render

Moderator: GiD Team

JFlock_BE
Posts: 6
Joined: Thu Jul 11, 2019 6:57 am

Strange surfaces with flat render

Postby JFlock_BE » Wed Apr 29, 2020 2:27 pm

Hello,

I have a strange representation of surfaces when using flat/smooth render for my model.
This is a model for the structural analysis of an awning.
In attachments, there is a print screen with normal render ( normal-render.png)
And a print screen with flat render (flat-render.png)

After rebuilding surfaces from boundary, everything come back as expected (flat-render-after-rebuild.png)

Why do I have this strange representation before rebuilding surface?
For creating the model, I have drawn lines and then I have created surfaces with the tool “Create NURBS surface”. Did I do something wrong?

* I also wanted to attach the .gid folder in the post but it doesn't work .... how can I forward it to you ?



Thanks for your time.
Attachments
normal-render.png
normal-render.png (54.36 KiB) Viewed 2093 times
flat-render-after-rebuild.png
flat-render-after-rebuild.png (35.69 KiB) Viewed 2093 times
flat-render.png
flat-render.png (40.74 KiB) Viewed 2093 times
User avatar
escolano
Posts: 1649
Joined: Thu Sep 18, 2014 3:31 pm

Re: Strange surfaces with flat render

Postby escolano » Mon May 04, 2020 8:40 pm

This could be because the orientation of some render normals or the surface definition is incoherent.

How has this model created?
e.g. interactively using which commands?, or imported from which format?
please, attach a zip with the original format, and/or the GiD model.
and what is the exact GiD version used?
JFlock_BE
Posts: 6
Joined: Thu Jul 11, 2019 6:57 am

Re: Strange surfaces with flat render

Postby JFlock_BE » Tue May 05, 2020 8:47 am

Hi,

The model was created using classical Gid commands ("create line" and "create NURBS surface" from the "Geometry & view bar " toolbar).

I have attached a zip with the .gid folder.

We use the 14.0 version.


Thank you in advance for your support.
Attachments
Model.zip
zip with .gid model
(38.03 KiB) Downloaded 44 times
User avatar
escolano
Posts: 1649
Joined: Thu Sep 18, 2014 3:31 pm

Re: Strange surfaces with flat render

Postby escolano » Tue May 05, 2020 7:46 pm

I recommend you to download the last available versions, current official nowadys is 14.0.4.
Maybe this bug has been fixed some versions ago.

http://www.gidhome.com/download/official-versions

or also can have fixed bugs and also new features in developer versions:
http://www.gidhome.com/download/developer-versions

The same password is valid for all 14.x versions

Return to “Advanced visualization”

Who is online

Users browsing this forum: No registered users and 2 guests