Failed to connect to server?

Moderator: GiD Team

Posts: 3
Joined: Thu Mar 11, 2021 10:27 am

Failed to connect to server?

Postby PeytonBirch » Thu Mar 11, 2021 10:33 am


I just downloaded GID 13 and I would like to download Kratos through GID. Unfortunately, the connection to the server failed.
I found a similar topic on this forum: viewtopic.php?t=614 providing this solution:

"You can fix the problem for example with some of this ways:
- a) avoiding this 'check for upgrades' connection. To do it edit the file
scripts\ConfigureProgram.tcl and change
set ::GidPriv(ShowCheckNewVersion) 1
set ::GidPriv(ShowCheckNewVersion) 0

or you can also allow the connection changing your firewall configuration"

But the line set ::GidPriv(ShowCheckNewVersion) 0 isn't in the file scripts\ConfigureProgram anymore.
I tried the second solution allowing every inbound and outbound rules for gid.exe but still doesn't work.
Do you have a new solution? I am wondering which service or program GID is using when it tries to connect to the server (which might still be blocked by firewall).
Thank you for any assistance,
User avatar
Posts: 1705
Joined: Thu Sep 18, 2014 3:31 pm

Re: Failed to connect to server?

Postby escolano » Fri Mar 12, 2021 4:08 pm

Why download GiD 13?

Current versions of Kratos will require a more modern GiD version. Download current GiD 15.
and the problem of download probably won't happen using GiD 15 because it is using https instead ftp protocol, that is problematic nowadays.

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest