Page 1 of 1

GiD 14 Not Starting

Posted: Tue Jul 03, 2018 2:41 pm
by luccacondratiuk
I'm Getting this Error in Terminal:

Code: Select all

Configuring GiD for GLX Rendering
/usr/local/gid14.0-x64/gid.exe: symbol lookup error: /usr/lib64/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var


I'm Using:
-Arch Linux x64 - 4.17.3-1-ARCH
- KDE 5.47 Plasma 5.13.2

Re: GiD 14 Not Starting

Posted: Wed Jul 04, 2018 3:50 pm
by miguel
Hi,
I've repacked GiD 14 with libfontconfig inside.
Can you download it from https://web.cimne.upc.edu/groups/gid/gid14-repack/gid14.0-linux-x64.tar.gz and give it try?
Please tell us how it works.
If you prefer you can also download the installer from here https://web.cimne.upc.edu/groups/gid/gid14-repack/gid14.0-linux-x64-Install

Thanks fro your patience,
Best,
the GiD team

Re: GiD 14 Not Starting

Posted: Thu Jul 05, 2018 2:33 am
by luccacondratiuk
miguel wrote:Hi,
I've repacked GiD 14 with libfontconfig inside.
Can you download it from https://web.cimne.upc.edu/groups/gid/gid14-repack/gid14.0-linux-x64.tar.gz and give it try?
Please tell us how it works.
If you prefer you can also download the installer from here https://web.cimne.upc.edu/groups/gid/gid14-repack/gid14.0-linux-x64-Install

Thanks fro your patience,
Best,
the GiD team


Almost Worked...
In the beginning I was getting the same error, then I take de libfontconfig.so.1 file contained in ~/GiDx64/14.0/lib/* and pasted it into /usr/lib64/ folder. Then I was able to run Gid, but nothing else were working (neither a terminal emulator or chrome). So I restored the old libfontconfig.so.1 file, and again, not able to run gid, getting the same error...

Re: GiD 14 Not Starting

Posted: Thu Jul 05, 2018 4:50 pm
by miguel
Hi,
Have you downloaded and installed the 'repacked' https://web.cimne.upc.edu/groups/gid/gi ... 64-Install ?

If you've used the https://web.cimne.upc.edu/groups/gid/gi ... x64.tar.gz this file will unpack to '~/gid14.0-x64' and not to ''~/GiDx64/14.0'

are you launching gid directly with 'gid.exe' ?
You should start gid with the script '~/GiDx64/14.0/gid' which defines the LD_LIBRARY_PATH so that gid.exe finds the needed libraries in '~/GiDx64/14.0/lib/'

Re: GiD 14 Not Starting

Posted: Sun Jun 09, 2019 7:40 am
by jbaiges
Hi,
I am running GiD in Fedora 30 and I have the same issue, with GiD version 14.0.1.
I have tried downloading the 14.0 file suggested in the previous post, but then I get the error:
error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory

Thank you for your help,
Joan

Re: GiD 14 Not Starting

Posted: Sun Jun 09, 2019 7:46 am
by jbaiges
Hi,
The issue in Fedora 30 is solved if using the latest developer version 14.1.3,

Joan