GiD failing to launch under Debian 9 Stretch

Moderator: GiD Team

oneilm
Posts: 1
Joined: Fri Feb 02, 2018 5:37 pm

GiD failing to launch under Debian 9 Stretch

Postby oneilm » Fri Feb 09, 2018 10:31 pm

I recently installed GiD 13.0.4 on my linux desktop, running Debian 9 Stretch, and GiD fails to launch when executing the command ./gid. I receive the error message:

Configuring GiD for GLX Rendering
Illegal instruction

When running ./gid.exe I receive the error message:

./gid.exe: error while loading shared libraries: libobjarray_64.so: cannot open shared object file: No such file or directory

This file, in fact, does exist in the directory GiDx64/13.0.4/scripts/objarray, but cannot be found.

Please advise on how to fix this - I have already purchased a USB license for GiD, and expect it to work on my linux system. I have an older video card with a Radeon HD 7970 chip, is this related to the problem?
User avatar
escolano
Posts: 1568
Joined: Thu Sep 18, 2014 3:31 pm

Re: GiD failing to launch under Debian 9 Stretch

Postby escolano » Mon Feb 12, 2018 3:57 pm

In Linux/Mac os X you must not directly run gid.exe but the script 'gid' or 'gidx' that set some environment variables prior to run gid.exe
In your case
./gid
is raising some error related to the graphic card its driver to use OpenGL acceleration

you can also try with OpenGL by software (mesa) with
./gidx

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest