If GiD install/.tgz does not run on some ubuntu versions perhaps you are not able to execute the installation program of GiD nor the kernel-2.6 packed (.tar.gz) version on the latest ubuntu distribution.

Check if the distribution you are using is a 64-bit one with

uname -a:

..... x86_64 ...

If you have used the Wubi installation program, by default it installs the 64-bit distribution on a machine which is able to run 64-bit applications, which are all the machines by now.

It seems that the default 64-bit installation of ubuntu (and kubuntu, xubuntu) does not include the 32-bit support to execute 32-bit applications.

The installation programs of GiD are 32-bit applications, including the 64-bit version.

As explained here: http://ubuntuforums.org/showthread.php?t=583454 just by doing:

apt-get install ia32-libs lsb-core

(or through the synaptic package manager)

You will be able to run the 32-bit installers of GiD and the 32-bit version of GiD on the 64-bit ubuntu.