The dynamic version of GiD failed on MEPIS kernel 2.6.15 because some libc symbols could not be resolved.

This problem could be avoided updating the g++ package to the 4.2 version:

sudo apt-get install g++-4.2