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GID USER MANUAL 1
PRESENTATION OF GID

This chapter will introduce the user to the user-interface and graphic environment of GiD.

GiD is a general purpose pre-postprocessor for computer analysis.
All the data, geometry and mesh generation can be performed inside. Also, the visualization of
all types of results can be performed.

It can be adapted to a specific analysis module by the creation of a 'problem type'.

Typical problems that can be successfully tackled with GiD include most situations in solid and
structural mechanics, fluid dynamics, electromagnetics, heat transfer, geomechanics, etc. using
finite element, finite volume, boundary element, finite difference or point based (meshless)
numerical procedures.



2 PRESENTATION OF GID

USER INTERFACE

Upon opening GiD, the following window appears on the screen:

i Gil Project: UNNAMED =10lx|
Files Yiew Geometry Utiities Data Mesh Calculate  Help
OO R MG [P BE 2|4 biDverens
NI.; L Geometry
R/.; IZ Data
) T T teshing
'TI 3 op menu Fils
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-E: Ultilities
‘/‘ %‘I Postprocess
_ Guit
% ﬁ! Toolbars sscope
=
@ :"2, Right buttons
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@ h=
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2 &
§ Command line
<P R
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o L
& %
S
> ]
Command, | -+

To change the configuration of toolbars and menus, use the toolbars option, located in
Utilities>Tools>Toolbars.




GID USER MANUAL 3

1. TOP MENU

The Top Menu offers various types of commands.

It is important to note that these options will differ depending on the whether the user is
performing a preprocessing or postprocessing analysis, and that the options needed in each
case differ as well.

Two possible configurations of the Top Menu are presented below:

Projeckt: UNNAMED

Files Wiew Geometry Ukilities Data Mesh Calculake Help

And in the postprocessing phase:

Projeck: UNNAMED

Files Yiew Utilities Docuts  Wiew results  Options  Window  Help

These two options will be presented in more detail later.
Next, each drop-down menu in the Top Menu will be described in detail.
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Files

Two main types of functions can be controlled in this menu: 1) the handling of files (i.e. create,
read, save, etc.) of GiD projects; and, 2) the importing and exporting of files.

Creates a new project
Reads a previously
created GiD project / Saves to disc all information related

to the project

Uszing Template .bas [only mesh)

s Mew Ctrl-x Cel-ry
. . 1 Open... Ctrl-o Import files
Saves information % Save Ctil=
with name chosen b - g
th ] y Save as... Ctrl-= Crl-= IGES... i
e use DF ... Ctil-d
|IT||:IDrt Parasolid...
Changes the configuration for E , ALIS...
postprocess phase Eszell YDA..
BEhino...
{} Postprocess Shapefile...
. - NASTRAN mesh...
Saves the drawing /& Fiirt to file r STL mash..
image shown on the Page/image setup... YRML mesh...
screen, in one of the “3 Frint I0Studio mesh...
following formats r'f"i GiD mesh. .
n— . HE-'QE-'FI': fles b Surface mesh...
i Vz’;s::al , Batch file... Chikb
= 'ﬂ guit \ Ctrl-q Inzert GiD' geometry...
EMP...
GIF..
e Export files
PHG...
TGA... . ) IGES..
- Closes GiD Window to set up -
TIFF... int DF...
WRML... some prin ALIS...
= properties and :
image properties D mesh..
Printing options Text data report...
ASCH project...
Open the OM layers
last models LCalculation file... Chrl-x Chil-:

3
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View

In the view menu (also available from the mouse menu) there are all the visualization
commands. These commands change the way to display the information in the graphical
window, but they do not change any definition of the geometry or any other data.

in
Offers various rotation Offers various zoom options 5O gt
options: for viewing of piece e
Dwnanic
-Q Trackball Previous
Screen axes N
Mext
Obiject anes
Cenh
==t Zaom 4 Permits translations of the
Plane ¥ (Orginal) Rotate 3 image, from one point to
Plane }Z P — another (two points), or
Plane ¥Z tan dynamically (dynamic)
’ o
Isometric T Redraw o (sl
/ Render LN _,-‘" Dynamic
Redraws geometry of the P?@pecwe“'
project /Chl:' planes. . Offers various illumination
options for the image
To change to a perspectivi Label r Nomal
(N Flat
» Smooth
Change light dir
Customize...

o Background image
entities for preprocess as

well for postprocess Image to clipboard

Fultiple windows. .

3

Opens a file image as a
background

projection Marmals
Set the near and far clippin Higher entities
planes )
Wi
Show numbering of the
/

tode

%

Eit screen...
Real size...
Default

Copy the image to the
clipboard

Switch the visualization
mode to geometry
mesh or postprocess

Draw the surfaces normal
sans line tangents

raw by colors the amount of
parents of an entity

Saves the actual position of

the current view
permits to have

Save...
Read...
several views of

the same project

This option
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Geometry
Geometry permits the user to create, delete, edit and model geometry.

Changes from the mesh viewing to

the geometry
aEam . "
] Creates drawing entities
Wiew geometry
Delet titi Create L4 o[BS
eletes entities =
\@ Delete » ., Straight line
Paints Edit 3 S NURBS line
Lines Parametric line
iulrfaces IE_)' Faolyline
olumes
| - " ™y A 2
Al types
Edits and permits 1 NURES surface b
changes to entities Parametric surface
Contact surface
Move point Surface mesh
Divide 4
Lines operations 4 @ Yolurme 4
Swap arc Contact 4
Balyline 4 ) ]
Surftdesh f‘ﬂ Object b
Edit MURES 4
Corvert to MURBS 4
Simplify MURES 3
Hule MURBS surface
Collapse L4
Uncollapse L4
Intersection »
Surface boolean op. L4

Wolume boolean op. 4
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Utilities

In the Utilities menu, GiD allows the user to define preferences

the geometry and the mesh entities.

Undo commands
Chooses the preferred executed during the work

or perform operations on both

options for project session
Chl-z
Opens the layers GiQ is flexible in its configuration of the
window \;q Preferences. .. Chilp screen and accor_nmodates dlffe’rent
menus depending on the user’s
% Layers... Cirl preference
Moves entities as | — Toalbars..
translation, rotation, Tools ¥ —
symmetry, scale, in this S i Euil..
case without duplicating £ Copy... Chil-c oo Sieen Blfests
entities MD‘\"E Etfl"‘\" Loordinates window...
Gi inf i bout ful — Bead batch window. .
ives information about usefu CamiEfs..
general data of the project T Status... Arimation contrals..
LISt » Animation script...
. . " / ) Macros...
Lists project entities and Benumber e
roperties
prop /ld Calculator...
Signal ¥ % Report...
Shows labels and .
coordinates of new Swap normals b
or existing points N
Distance Copies all types of entities by
Diimensian ¥ performing a translation,
Indicates on the screen the - rotation, mirror symmetry or
location of entities . entity scaling
Repair model
Manage the_ orientation of Renumbers the entity labels, in order
the entity normal to avoid gaps in numbering caused
by the elimination of entities during
) the description of geometry and its
Calculates the distance properties. Renumbers the mesh to
between points decrease the analysis interval
With this option it's possible to Create 4
add textual information to the Delete
Checks the internal coherence model, such as distances, Edit
of the data base angles or coordinates. -

ShowBox
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Data

This menu allows access to the definition of all data related to materials, boundary conditions,
etc., which will be necessary for the calculations that follow. The form of this data will depend on
the type of the analysis to be performed.

Defines type of problem

calculation
Describes the properties of e ansys5a 3
the problem and other data o
related to the geometric Problem type 3 E | "
entities \ = WA= .
. . Conditions ramzeneszh.h
Describes materials )
used in the problem — | Materialk Transform...
Interval Data Internet Betrieve. ..
/EE Prablem D ata Load...
Defines general ['ata units Urload
data of the interval Debugger...
Irterval k|
. Local axes L4
Describes generally the . . .
problem data Divides information of
problem into intervals
Defines the units
used in the problem Mew
Changes and defines local Cument
coordinate axes -
Delete
Define
Dyaw
Diraw all
Delete

Delete all
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Mesh

Mesh permits the user to generate and edit the mesh, as well as to select mesh creation

preferences.

Assigns element sizes
to entities for non
structured mesh

@ Azsigh sizes oh points
\ Azzigh sizes on lines
'{E Azzign sizes on sufaces
@ Assign sizes on volumes

Sizes by chordal enror. .
Sizes by background mesh...
Correct zizes...

Agzign entities L4

nztructured L
Structured L4
SemiStructured L4

Cuadratic elements L
Element tupe >\
rezh criteria L4

Chooses default mesh /Eeset mesh data

criteria, meshing of
determined entities or
not of others

Deletes assigned
information for mesh
generation

Draw in different
colors the different
mesh information

Generates the mesh

Cancels previously
generated mesh

Open the window with
the last meshing error
message

Defines a structured
mesh

*, Lines L
"*;I Surfaces P
@ Yolumez

/ Defines a semi
structured mesh
Wolumes
Set L4
\
Describes element
type to be used

v Momal
/Qraw 4 Huadratic
[uadraticd
<% Generate mesh... Ciil-g
Erasze mesh Assign element
Edit mesh < type to entities
Show emors. . Diefault »
/ Linear 4
Wiew mezh boundary .
Triangle
LCreate boundary mesR Quadrilateral
Mesh quality... \ \ Tetahedra
Hexahedra
Prigm
Only points
Shows
boundaries
of meshing Edits and permits
process changes to the mesh
Move node
Create
Shows quality of boundaries Split elements »
mesh elements of meshing Srngoth elements
generated process

Collapse
Delete
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Calculate

This command calculates the problem, according to the type of problem defined. This option
requires a previously activated interface between GiD and the corresponding calculation
program.

Start calculation -
process L-Elll:ulate
A= Caleulate
Shows details of the

Sends the mesh createdby Calculate remote calculation process

GiD to a remote server,
Cancel process
. . Opens the calculate window
E Wiew process info...

which calculates the results
Calculate window...

Interrupts the calculation
process
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Help
This menu permits the user to obtain different types of help and information about GiD.

Interactive help Help on how to configure
covering all GiD 2 Help... Fi GiD for a particular type of

options . analysis
P Customization Help... 1 4

What is new in Tuborials... —
this version \ . | GiD tutorials
whhat is new. .

FA0...
. . - \ .
Use this option to ——Frequently asked questions

register GiD and use ~—  Register Gil... about GiD
its professional version

Reqgizter Problem type. ..

Regizter from file...\
——— Ask for the file that contains

Register problem types Wizt GID web... passwords for all calculating
About modules

Go to the official website

Gives basic information for
GiD and the version being
used
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GiD Postprocess

Project: PuenteRomano

Files Wiew Utlities Do cuts Wewresults Options  ‘Window  Help

Files

This Top Menu of the postprocess phase is the same of that as the preprocess phase and has
the same name. The user can read and save files, save screen images, return to preprocess
phase options and exit the program.

t Starts a r)eV\; Reads mesh and
postprocess projec — Its information
F|I-:=~_~ results in i
from an ASCII file
l':l Mew Ctrl-n
T Qpen... Ll Import files
Reads postprocess files Open multiple... ﬂAngHAN mesh
EEMA&P file.
Merge... TECPLOT A5 fie...
Reads postprocess files wit Import ' L
multiples meshes Export 3 Ef;h

Save the current image 'Q‘ Preprocess .
in the selected format \ Export files

& Frint to file 2

age Setup...
Printing options//lj_El .

Send the image = Ot Ctrl-g

to the printer

Changes user interface to
the preprocess phase

Closes GiD
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Utilities
In the postprocess phase, the Utilities command permits the user to obtain information about
entities.

Opens a window to handle
the visualization style and
the sets

LItilikties
Chooses the preferred —— ™=

options for project 4 Preferences...
% Wiew styl CtrH Lists project entities and
Several tools like \ properties
macros, calculator ... Tools *
. Copy Chrl-c Indicates on the screen the
Opens the postproces/ batus location of entities
copy window = Modes
List 4 Elements
Gives information Id
about useful general Signal k With this option it's possible to
data of the project Distance add textual information to the
= i model, such as distances,
Dimenzion ¥ angles or coordinates.
Identifies any node of the
mesh being viewed, showing Collapze nodes Create 3
its Iab_el number and spatial Joi b Delete
coordinates Al =i
D§|EtE '\ ShowBox P
Calculates distance Tezture 4
between two points To join several sets
into one
To collapse nodes those To delete meshes,
are together in a set sets and cuts
To add textures Wiew »
td'sets Add » Yolume etz *

Surface etz ¥
Cut sets 4

Change F
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Do cuts
With the option Do cuts the user can make cuts through entities.

Makes parallel sections,
defining an axis in the normal
direction to the cuts, and the o .

number of divisions desired Do cuks ¢ D'V'd?ts voILtJtme ?ﬁts mh
oo wo parts, cutting throug

along this axis i Cut Plane + two points and relative to

the plane perpendicular to

Divide by zelection
o the screen, or by three
Djwvide wolume setz L

Creates a set with the user

selection Divide surface sets P—
Mk A A Divide lines L4 Divides surface sets in two
akes section through a C - parts, cutting through two
plane. This can be defined e points and relative to the
plane perpendicular to the

by two points and relative to Cut Sphere

the plane perpendicular to screen, or by three points
the screen, or by three points Carreert Cuisu'face sets

Makes a spherical cut

With this options cuts can be The user specifies a plane
converted to surface sets so which is used to get the lines
they can be saved, or cut at one side of this plane

again
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View results

This option permits the user to choose the viewing type in which the results of the postprocess
calculation will be presented.

Results are not viewed Selects for which step of
analysis results will be
View results viewed

Graphs are not viewed

\ Mo Results
Mo Graphs Same as contour fill, but with
defined ranges.
Chooses which result to vie Default AnalysizdStep  F
in colored iso areas w\ _ .
Contour Fill » Shows location a_nd value of
— hE Fill " a selected maximum and
Chooses which result to view amooth Lantour Fi minimum numerical result
in smoothed colored iso Contour Lines L4
areas Contour B anges r .
& hav b b , /Selects which vector
. : LT L) = result to vie
Chooses which result to view Disolau » u view
i lored lines IRl HeEler .
in co ke Siurfemes p . Creates iso areas of the
. . - results showing with colored
Sigenlies  ?| stups e piace e sah
3 subdivision finished
to the result vectors Graphs
Fezult Surface r Exact 4
Graphs Defarmation 3 Automatic 3
Coar Line Diagram 9 Sutomatic ‘idth  »
Point evolution  *
Faint graph 4
Border graph 4
Line graph 4

Graph-style lines will be
drawn over the line elements
Draws a scalar result (only active when line
following the element Shows mesh deformation elements are used in the
normal according to a mesh)
displacement field

Scalar ¥
Vector ¥
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Options
Options permit the user to make choices related to the presentation of results: for example,
color changes, number of result subdivisions, etc.

« Show
Opaque .
Selects box which

shows the value

Changes color

o Show Title ‘
assigned to the

Wolume sets ¥
+ Diraw User Limits -
N Surface setz #

Border scale of the results. volume, surface and et .
Eliees Tl cut sets. S
Outzide

¢ Automatic Comments

Changes the name
assigned to the volume,

How volumes,
surface and cut sets.

surfaces and cuts
should be drawn

Border Angle Murnber of Colors
Mazsive Body LEgEndS 4 wiidth ntervals
Lranparert Allows user to EEE-LW-S : '
Opagque Geametmy 4 Diefine Limits
Boit oo select the number Freset Limit Val
Point options. .. Chanage Colar ¥ X Beszet Limit Yalues
Line aptiahs - g of colors in the Reset Al
- ] i _ )
Lowering mesh Change Mame Chroma.tlc S(;?Le’ tax Options 4
int Slzle o | e i Options 4
- Contour 2 intervals, color R
Selects viewing = le. et Color Scale
i i |20 Surf ] scale, etc. Smoothing bpe 3
options of iso areas =0 auraces ot
Vech . Color windaow. ..
Display Style 3 Meciors \
Render » Stream Lines L4
Trarsparency  * Graphs . User can_choose
Corwert ta cuts =S how to wew_the
Line Diagrams L Stream lines vectors which
_ _ Fiesult Sur(au:e » options: kind of define the results
Defines options for = label, color, and
viewing graphics delete option. Interiordall vectars
Mumber of Colors
= LChange calar LColar Mode
DOutline on model
Grids Color Mode L4 Difzet
@i style Elevations are lines that Delete Change Colar [moka)
changeswle gk » | connect the nodes and the Label Detail >
Change cclor graph— + gauss points of the line Size & detail Size 3
Clrgige s et *| element and the graph style
E:G”gg i Da“:'” *| line that represents the result
t I . .
ekl Defines options for result
Change point size 4 Maone
Change fitle graph 2 Nodes only surfaces
Inwert graph sense 4 .
Delete graph 4 ) ‘v'\."'hoh?t line
Title 2 «¢ Filled line
Eeset axis values Contour filled
= axis
Y aris 4
Clear grafs
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Postprocess windows

\ ¥iew Results & Deformation

Wiew results 1 Main Mesh ] Reference mesh 1

View: |Display Vectors > Step;

Analysis: [Estatic 1

Auial Force
2 Ny

@ Ny

2 Mxy'

@ |axial Force|

factor: |9.08221e-005

Apply Cloze

Wigw style. ..
Wiew results.
Animate. .

17

Select & Display Style | =l
¥ wolumes W Sufaces W Cuts [ Fesulks Yisw
" alphabetic order ¥ Autoratic: Lirits
Mame [ ] [ ] [ I Deformation Static
50 ¢ B D [ Endless analysis
S 0 lines . B ® arimation
vV Delay: [200  ms. prafile
E [.] E ) Fename Step: |1
1
D [ ] t‘ Delete (LT
Style: |Body Bound hd @ @ @ @
Render: |Smooth hd (_A_) ||_ Save ITIFF > on £%
gy Mone = [Save IMF'EG > on £ .
Conditions: |Mone hd [
||Defau|t ~ Resize Cloze
To back Send ta Cloze

Graphs Window

Wigw graphz...
Several Results. .
Resultz ranges table...

Create l General Options ] Graph Management ]
Yigw: [Paint Evol. ™ Analysis: [Estatic = Step[1 -
Ctrl-rn # aiz: All steps Y awis:
— Al step at E static Displacements -
= M Reactions
2 b
@ My
2 Mz
% |M Feactions| LI
Apply Cloze

Results ranges table x|
Table will be applied ta current result Several RECHER ﬂ
Mame: A - X
! FRoT Results view:
bini R M
inirum || simum || Sl | * onebyone © one over another
Current list of results: Delete
v & Id & * Mo results ;I

Apply Cloze

1]

Close

I1.
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2. TOOLBARS

PRESENTATION OF GID

Option Utilities>Graphical=>Toolbars opens a window where it's possible to configure the

toolbars position or switch them on and off.

Geometry and View operations
(preprocess)

Zoom in: enlarges image area which
user indicates by drawing a mouse
window

Zoom out: reduces image area
which user indicates by drawing a
mouse window

=
Ao
— B

<4

Zoom frame: places image in center
of screen

&
_— ?.E‘@
Pan two points: displaces image / — i

from one point to another, both
chosen by the user

Redraw: redraws image

Rotate trackball: rotates the image

Create NURBS line: creates a line of
type NURBS

Create polyline: creates polyline
apart from other lines

/

Create NURBS surface: creates a
~__— NURBS surface defined by border
lines

\
Create volume: creates a volume
T—__ Create object: rectangle, circle,

polygon, sphere, cylinder, cone,
prism, thorus.

Delete: deletes entities

Create line: creates straight line

Create arc: creates an arc

N

List entities: permits listing of project
entities

Toggle geometry/mesh view
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Standard toolbar

Changes the
configuration for Opens the copy

Prints the postprocess window
current phase
Creates a project opens the
new preferences
project window
Standard Bar |
®@®|@@|&@|Q%@%|?l-ﬂ Ell]\-'ersiona
Reads a Opens the \
previously layers window GiD info
created GiD Saves to button
project disc all Saves the @
information drawing
related to image shown @ Opens the help
the project on the = window Quits GiD
screen, in  xl.s
one of the
following
formats:

2.0 & & B

TIFF

&
I
3
(L
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Geometry and View operations
(postprocess)

Zoom in: enlarges image area which
user indicates by drawing a mouse
window

Switch volume
sets on or off

Zoom out: reduces image area
which user indicates by drawing a
mouse window

Switch surface

/ sets on or off

- Switchcutsets
on or off

21 \ Do cuts: 2 points, 3

Zoom frame: places image in center
of screen

redraw: redraws image

Rotate trackball: rotates the image ;‘l1; points, succession
* N axis
Pan two points: displaces image et _-9
from one point to another, both L) E} {é
chosen by the user i Set maximum value
5! (Contour fill)
Change light vector direction: with ﬁ
this option the user can change the — Set minimum value
vector of the light direction (Contour fill)

interactively

Reset contour limit
Display style: values (Contour fill)
how volumes,

surfaces and cuts

should be drawn

X List entities: permits
Culling style: listing of project entities
none, front faces,
back faces or front
and back Faces.
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3. MOUSE MENU

The Mouse Menu is the auxiliary menu which appears by clicking on the right mouse button
while the cursor is over the GiD screen.

The Mouse Menu permits the user to quickly access various image placement and viewing
commands, to facilitate easy management and definition of the project.

Furthermore, the Mouse Menu contains the Contextual menu, which permits the user to
access to all options available in previously performed commands. The option Contextual is
only available after the user has performed a command from the Top Menu.

User can access options

available in each distinct Offers various zoom options
command, once they have i for viewing of piece
been executed 2 Ou

Dynamic

Offers various E::\ous

rotation options: / L=
’%- Erame

//

4 Trackball Contextual 4
Screen axes
Object axes ZDDITI »
Center = Permits translations of the
Plane %Y (Driginal Ratate b image, from one point to
Plane +Z Ban » — another (two points), or
Plare 2 ‘n-, e dynamically (dynamic)
lzometric =
Render T wo point
/ Label » A Dunamic
Redraws geometry of the Laver »
project Offers various illumination
Image ta cliphoard options for the image
. Mormal
Show numbering of the = Cluit Flat
entities for preprocess as Smoath
well for postprocess Change light dir
Copies the drawing
image shown on the
screen to the clipboard
] »
closes GiD ) ) E; 5
Activates or de-activates the !
layers which form the project Towse ¥
and changes entities from Send P

one layer to another layer. 22 Window
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4. COMMAND LINE

The Command Line option allows the user to directly enter all executable GiD commands,
without accessing the commands through drop-down menus.

T4 Enter commands ﬂ
This is the PROFESSIONAL Yersion. ;I #=0.01258
~ | y=0.01258
Command: [ -+ | =0

These commands should be written following the order which GiD would use to define them,
according to the Right buttons menus.

A side comment in reference to the Command Line: GiD does not distinguish between the use
of capital and small letters. In addition, in cases where ambiguities do not exist, commands
need not be written in entire words, but can be written with the primary characters of each word.
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INITIATION TO GID

With this example, the user is introduced to the basic tools for the creation of geometric entities

and mesh generation.

A A

i

A

ATA AL
A LA
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FIRST STEPS

Before presenting all the possibilities that GiD offers, we will present a simple example that will
introduce and familiarize the user with the GiD program.

The example will develop a finite element problem in one of its principal phases, the preprocess,
and will include the consequent data and parameter description of the problem. This example
introduces creation, manipulation and meshing of the geometrical entities used in GiD.

First, we will create a line and the mesh corresponding to the line. Next, we will save the project
and it will be described in the GiD data base form. Starting from this line, we will create a square
surface, which will be meshed to obtain a surface mesh. Finally, we will use this surface to
create a cubic volume, from which a volume mesh can then be generated.

1. CREATION AND MESHING OF A LINE

We will begin the example creating a line by defining its origin and end points, points 1 and 2 in
the following figure, whose coordinates are (0,0,0) and (10,0,0) respectively.

It is important to note that in creating and working with geometric entities, GiD follows the
following hierarchical order: point, line, surface, and volume.

T =

To begin working with the program, open GiD, and a new GiD project is created automatically.
From this new database, we will first generate points 1 and 2.
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Next, we will create points 1 and 2. To do this, we will use an Auxiliary Window that will allow

us to simply describe the points by entering coordinates. It is accessed by the following

sequence: Utilities= Tools=> Coordinates Window

Then, from the Top Menu, select Geometry%Create%Point

In the coordinate window opened previously, the following indicated steps should be used:

T Coordinates window

C. Spstem: IEartesian hd
IGIobaI -2

Local axes:

y: [0.00000

(1) Introduce

. : |0.00000
the coordinates 7

of point 1

Create new point: | Ask | Cha

(2) Create point 1 by
clicking on the button
Apply or by pressing

/Enter on the
kevboard

[ Use 'tab ShME and Return'

Apply

LCloze

And create point 2 in the same way, introducing its coordinates in the Coordinates Window.

The last step in the creation of the points, as well as any other command, is to press Escape,
either via the Escape button on the keyboard or by pressing the central mouse button. Select

Close to close the Coordinates Window.

Now, we will create the line that joins the two points. Choose from the Top Menu:

Geometry->Create—>Straight line. Option in the Toolbar shown below can also be used.

N

Next, the origin point of the line must be defined. In the Mouse Menu, opened by clicking the
right mouse button, select Contextual->Join C-a.
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Iw NOTE: With option Join, a point already created can be selected on the screen. The
command No Join is used to create a new point that has the coordinates of the point that is
selected on the screen. We can see that the cursor changes form for the Join and No Join
commands.

B Cursor during use of Join command
4=  Cursor during use of No Join command

Now, choose on the screen the first point, and then the second, which define the line. Finally,
press Escape to indicate that the creation of the line is completed.

Iw NOTE: It is important to note that the Contextual submenu in the Mouse Menu will always
offer the options of the command that is currently being used. In this case, the corresponding
submenu for line creation, has the following options:

Contexstual Base
Jain Chil-a
Zaam r Faint In Line
Botate Paint |n Surface
Pan Langelnlt InS Lirf1e
P armal In Surface
% Rediaw Arc: Center
Render Optionz
Label ke
Layer (]|
Ezcape

Image to clipboard

42 Quit
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Once the geometry has been created, we can proceed to the line meshing. In this example, this
operation will be presented in the simplest and most automatic way that GiD permits. To do this,
from the Top Menu select: Mesh-> Generate mesh.

And an Auxiliary Window appears, in which the size of the elements should be defined by the
user.

na NOTE: The size of an element with two nodes is the length of the element. For, surfaces
or volumes, the size is the mean length of the edge of the element.

In this example, the size of the element is defined in concordance with the length of the line,
chosen for this case as size 1.

s Enter value window

Ok Cahicel

Automatically GiD generates a mesh for the line. The finite element mesh is presented on the
screen in a green color.

The mesh is formed by ten linear elements of two nodes. To see the numbering of the nodes

and mesh elements, select from the Mouse Menu: Label>All, and the numbering for the 10
elements and 11 nodes will be shown, as below.

1 1.2 2 3 3 4 4 5% 5 6 K 7 7 8 8.9 9 101011
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Once the mesh has been generated, the project should be saved. To save the example select
from the Top Menu: Files>Save.

The program automatically saves the file if it already has a name. If it is the first time the file has
been saved, the user is asked to assign a name. For this, an Auxiliary Window will appear
which permits the user to browse the computer disk drive and select the location in which to
save the file. Once the desired directory has been selected, the name for the actual project can
be entered in the space titled File Name.

T3t Save Project il
Directony: Eexamples LI |‘=_°F
[ Import Particle. gid
) arcaD. gid
D c1404.qid
D cajon2D.gid
D cajon3D.gid
D frame.gid
0 motor. gid
Kl i
File name: [iritiatior] Save
Filez of type: |GiD project [*.gid) * LCancel

Iw NOTE: Next, the manner in which GiD saves the information of a project will be explained.
GiD creates a directory with a name chosen by the user, and whose file extension is .gid. GiD
creates a set of files in this directory where all the information generated in the present example
is saved. All the files have the same name of the directory to which they belong, but with
different extensions. These files should have the name that GiD designates and should not be
changed manually.

Each time the user selects option save the database will be rewritten with the new information
or changes made to the project, always maintaining the same name.
To exit GiD, simply choose Files>Quit.

To access the example, ejemplo.gid, simply open GiD and select from the Top Menu:
Files>Open. An Auxiliary Window will appear which allows the user to access and open the
directory iniciacion.gid.
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2. CREATION AND MESHING OF A SURFACE

We will now continue with the creation and meshing of a surface.
First, we will create a second line between points 1 and 3.

3(0,10,0

1(0,0,0 2(10,0,0)

We will now generate the second line. We will now use again the Coordinates Window to enter
the points. (Utilities>Tools>Coordinates Window)

Select the line creation tool in the toolbar. Enter point (0,10,0) in the Coordinates Window and

click Apply.
\ T Coordinates window |
C. System; |Cartesian hd
Local axes: IGIobaI A

« [0.00000
» 1d
2 [0.00000

Create new point: | Ask | Change

[ Uze 'tab Shift-tab and Retum’

Apply Close

With option Join (Contextual mouse menu) click over point 1. A line should be created between
(0,10,0) and (0,0,0). Press Escape.

With this, a right angle of the square has been defined. If the user wants to view everything that
has been created to this point, the image can be centered on the screen by choosing in the
Mouse Menu: Zoom->Frame. This option is also available in the toolbar.
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Finish the square by creating point (10,10,0) and the lines that join this point with points 2 and 3.

3(0,10,0

1(0,0,0 2(10,0,0)

Now, we will create the surface that these four lines define. To do this, access the create
surface command by choosing: Geometry->Create>NURBS surface>By contour. This
option is also available in the toolbar:

GiD then asks the user to define the 4 lines that describe the contour of the surface. Select the
lines using the cursor on the screen, either by choosing them one by one or selecting them all

with a window. Next, press Escape.

As can be seen below, the new surface is created and appears as a smaller, magenta-colored
square drawn inside the original four lines.

Once the surface has been created, the mesh can be created in the same way as was done for
the line. From the Top Menu select: Mesh-> Generate mesh.

An Auxiliary Window appears which asks for the maximum size of the element, in this example
defined as 1.
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We can see that the lines containing elements of two nodes have not been meshed. Rather the
mesh generated over the surface consists of planes of three-nodded, triangular elements.

Iw NOTE: GiD meshes by default the entity of highest order with which it is working.

GiD allows the user to concentrate elements in specified geometry zones. Next, a brief example
will be presented in which the elements are concentrated in the top right corner of the square.

This operation is realized by assigning a smaller element size to the point in this zone than for
the rest of the mesh. Select the following sequence: Mesh-> Unstructured->Assign sizes on
points. The following dialog box appears, in which the user can define the size:

b Enter value window X
9 Enter size to assign o points [0.0 to unassian)
[0 100000
1 | » |

Azsigh Claze
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We must now regenerate the mesh, canceling the mesh generated earlier, and we obtain the
following:

As can be seen in the figure above, the elements are concentrated around the chosen point.
Various possibilities exist for controlling the evolution of the element size, which will be
presented later in the manual.

To generate a surface mesh in which the elements are presented uniformly, the user can select
the option for a structured mesh. This guarantees that the same number of elements appears
around a node and that the element size is as uniform as possible. To generate this type of
mesh, choose: Mesh-> Structured->Surfaces.

Using this command, the user should first select the 4-sided NURBS surface that will be
defined by the mesh. Then, the number of subdivisions for the surface limit lines should be
entered. Pairs of lines define the partitions in the following way:

(1) Select 10 (2) Select 10
divisions for the more divisions for
horizontal lines k the vertical lines

—
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Iw NOTE: GiD only generates structured meshes for surfaces of the type 4-sided surface or
NURBS surface.

When this has been done, the mesh is generated in the same way as the unstructured mesh, by
choosing Mesh->Generate mesh.
Assign a general element size of 1, though in this case it is not necessary.

We can see here that the default element type used by GiD to create a structured mesh is a
square element of four nodes rather than a three-nodded, triangular element. To obtain
triangular elements, the user can specifically define this type of element, by choosing
Mesh->Element type-> Triangle, and selecting the surface to mesh as a triangular element.
Regenerate the mesh, and the following figure is obtained:
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GiD also allows the user to concentrate elements in structured meshes. This can be done by
selecting Mesh—>Structured->Lines>Concentrate elements

First, we must select the lines that need to be assigned an element concentration weight. The
value of this weight can be either positive or negative, depending on whether the user wants to
concentrate elements at the beginning or end of the lines. Next, a vector appears which defines
the start and end of the line and which helps the user assign the weight correctly.

Select the top line and assign a weight of 0.5 to the end of the line:

%4 Concentrate elen ﬂ
Start Weight End "Weight
o 2 [o5 2

LCancel

Select the bottom line and assign a weight of 0.5 to the beginning of the line:

i Concentrate elem 1[
Start ‘wheight End 'weight
s 2 =

LCancel
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From these operations, we obtain the following mesh:

We can see that in the figure above, the elements are concentrated in the left zone of the
square.

35
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3. CREATION AND MESHING OF A VOLUME

We will now present a study of entities of volume. To illustrate this, a cube and a volume mesh
will be generated.

Without leaving the project, save the work done up to now by choosing Files->Save, and return
to the geometry last created by choosing Geometry->View geometry.

In order to create a volume from the existing geometry, firstly we must create a point that will
define the height of the cube. This will be point 5 with coordinates (0,0,10), superimposed on
point 1. To view the new point, we must rotate the figure by selecting from the Mouse Menu,
Rotate—> Trackball. This option is also available in the toolbar:

9

Rotate the figure until the following position is achieved:

Next, we will create the upper face of the cube by copying from point 1 to point 5 the surface
created previously. To do this, select the copy command, Utilities> Copy.

In the Copy window, we define the translation vector with the first and second points, in this
case (0,0,0) and (0,0,10). Option Do extrude surfaces must be selected; this option allows us
to create the lateral surfaces of the cube.
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Entities type: ISurfaces ~7
Trarsformatiot: ITran&Iation A

~Firzt point

| " |U.EI

e z (00

Muim: % (0.0

~Second point

Hur: % 0.0

| w |00

a z |10

[ Duplicate entities

Do extrude: ISurfaces A

[" Create contacts

[ Maintain lapers

Multiple copies: i

Select Cancel

37

ua NOTE: If we look at the Copy Window, we can see an option called Duplicate entities.
By activating this option, when the entities are copied (in this case from point 1 to point 5) GiD

would create a new point (point 6) with the same coordinates as point 5.

If the user does not choose option Duplicate entities, point 6 will be merged with point 5 when

the entities are copied. By labeling the entities we could verify that only one point has been

created.
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Finishing the copy command for the surface, we obtain the following surfaces:

Now, we can generate the volume delimited by these surfaces. To create the volume, simply
select the command Geometry->Create->Volume->By contour. This option is also available

in the toolbar:
&

Select all the surfaces. GiD automatically generates the volume of the cube. The volume viewed
on the screen is represented by a cube with an interior color of sky blue.




GID USER MANUAL 39

Before proceeding with the mesh generation of the volume, we should eliminate the information
of the structured mesh created previously for the surface. Do this by selecting Mesh->Reset
mesh data, and the following dialog box will appear on the screen:

i Dialog window x|

9 Sure, pou want to reset all meshing information?

LCancel

In which the user is asked to confirm the erasure of the mesh information.

na NOTE: Another valid option would be to assign a size of 0 to all entities. This would
eliminate all the previous size information as well as the information for the mesh, and the
default options would become active.

Next, generate the mesh of the volume by choosing Mesh->Generate mesh. Another Auxiliary
Window appears into which the size of the volumetric element must be entered. In this
example, the value is 1.

4 Progress in meshing =10l x| |
%% Dialog window x|
Taotal nurmber of surfaces: 7
: ] .
Meshed surface: [7 I Mesh Generated. Press '0K to see it
Hum. of linear elernerta =44 ;I
Taotal nurmber of volumes: 1 Hurm. of Triengle elemeniz=103
Wieeties) vl IT Hum. of Hexahedra elernents =9E52
Hum. of nodes=2114
I ] 1

Ok i Cancel
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The mesh generated above is composed of tetrahedral elements of four nodes, but GiD also
permits the use of hexahedral, eight-nodded structured elements.

We will generate a structured mesh of the volume of the cube. This is done by selecting
Mesh->Structured->Volumes.

Now select the volume to mesh and enter the number of partitions in its edges which will be
created. Then, create again the mesh.

Dialog window x|
T Enter value window: il =
E tesh Generated. Press '0K' to zee it
0 Enter number of cells to azzign ta lines
MHum. of linear elemeanta- 44 :I
o MHum. of Triangle elemeniz=103
3 5 Hum. of Hexshedra elermenta=1000
J——I Hum. of nodes=1445
Aszzign Cloze
>,

Cancel




GID USER MANUAL 41

i

N
i T
=
s -
hE Fh|
B P
ﬁ P

IM NOTE: GiD only allows the generation of structured meshes of 6-sided volumes.

With this example, the user has been introduced to the basic tools for the creation of geometric
entities and mesh generation.
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CASE STUDY 1
IMPLEMENTING A MECHANICAL PART

The objective of this case study is implementing a mechanical part in order to study it through
meshing analysis. The development of the model consists of the following steps:

e Creating a profile of the part
e Generating a volume defined by the profile
e  Generating the mesh for the part

At the end of this case study, you should be able to handle the 2D tools available in GiD as well
as the options for generating meshes and visualizing the prototype.
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1. WORKING BY LAYERS

1.1. Defining the layers

A geometric representation is composed of four types of entities, namely points, lines, surfaces,
and volumes.

A layer is a grouping of entities. Defining layers in computer-aided design allows us to work
collectively with all the entities in one layer.

The creation of a profile of the mechanical part in our case study will be carried out with the help
of auxiliary lines. Two layers will be defined in order to prevent these lines from appearing in the
final drawing. The lines that define the profile will be assigned to one of the layers, called the
“profile” layer, while the auxiliary lines will be assigned to the other layer, called the “aux” layer.
When the design of the part has been completed, the entities in the “aux” layer will be erased.
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1.2. Creating two new layers

1. Open the layer management window. This is found in Utilities>Layers.

2. Create two new layers called “aux” and “profile.” Enter the name of each layer in
the Layers window (Figure 1) and click New.

3. Choose “aux” as the activated layer. To do this, click on “aux” to highlight it and

then click on the Layer To Use button. (Next to this button the name of the
activated layer will appear, “aux” in the present case.) From now on, all the entities
created will belong to this layer.

)
w ? of
profile ¥ o

Layer Touse: = aus

(] Calar...

On
ﬁ ﬂn Sel .

Delete Fename [ alphabetic

Toback = Send To - Cloze

Figure 1. The Layers window
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2. CREATING A PROFILE

In our case, the profile consists of various teeth. Begin by drawing one of these teeth, which will
be copied later to obtain the entire profile.

2.1. Creating a size-55 auxiliary line

1. Choose the Line option, by going to Geometry->Create->Straight line or by
going to the GiD Toolbox'.
2. Enter the coordinates of the beginning and end points of the auxiliary line?. For our

example, the coordinates are (0, 0) and (55, 0), respectively. Besides creating a
straight line, this operation implies creating the end points of the line.

3. Press ESC? to indicate that the process of creating the line is finished.

4, If the entire line does not appear on the screen, use the Zoom Frame option,
which is located in the GiD Toolbox and in Zoom in the mouse menu.

Figure 2. Creating a straight line

na NOTE: The Undo option, located in Utilities>Undo, enables you to undo the most recent
operations. When this option is selected, a window appears in which all the operations to be
undone can be selected.

' The GIiD Toolbox is a window containing the icons for the most frequently executed

operations. For information on a particular tool, click on the corresponding icon with the right
mouse button.

% The coordinates of a point may be entered on the command line either with a space or a
comma between them. If the Z coordinate is not entered, it is considered 0 by default. After
entering the numbers, press Return. Another option for entering a point is using the
Coordinates Window, found in Utilities>Tools->Coordinates Window.

3 Pressing the ESC key is equivalent to pressing the center mouse button.
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2.2. Dividing the auxiliary line near “point” (coordinates) (40, 0)

1. Choose Geometry->Edit->Divide->Lines->NearPoint. This option will divide the
line at the point (“element”) on the line closest to the coordinates entered.

2. Enter the coordinates of the point that will divide the line. In this example, the
coordinates are (40, 0). On dividing the line, a new point (entity) has been created.

3. Select the line that is to be divided by clicking on it.

4. Press ESC to indicate that the process of dividing the line is finished.

Figure 3. Division of the straight line near “point” (coordinates) (40, 0)

2.3. Creating a 3.8-radius circle around point (40, 0)

1. Choose the option Geometry->Create-> Object->Circle.

2. The center of the circle (40, 0) is a point that already exists. To select it, go to
Contextual=>Join Ctrl-a in the mouse menu (right-click). The pointer will become a
square, which means that you may click an existing point.

3. The Enter Normal window appears. Set the normal as Positive Z and press OK.
4, Enter the radius of the circle. The radius is 3.8. Two circumferences are
visualized; the inner circumference represents the surface of the circle.
5. Press ESC to indicate that the process of creating the circle is finished.
Y
N,

Figure 4. Creating a circle around a point (40, 0)

* In GiD the decimals are entered with a point, not a comma.
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2.4. Rotating the circle -3 degrees around a point

—_

Use the Move window, which is located in Utilities=>Move.

Within the Move menu and from among the Transformation possibilities, select
Rotation. The type of entity to receive the rotation is a surface, so from the
Entities Type menu, choose Surfaces.

Enter -3 in the Angle box and check the Two dimensions box. (Provided we
define positive rotation in the mathematical sense, which is counter-clockwise, -3
degrees equates to a clockwise rotation of 3 degrees.)

Enter the point (0, 0, 0) under First Point. This is the point that defines the center
of rotation.

Click Select to select the surface that is to rotate, which in this case is that of the
circle.

Press ESC (or Finish in the Move window) to indicate that the selection of
surfaces to rotate has been made, thus executing the rotation.

Enlities type: ISurfaces hd

Transformation: IHotation =
Angle: |-3 Degrees

rFirst paint———————
T % 0.0
wo(00
a2 z |00

IV Twa dimensions
~Second paint

T % 0.0

|00

» = |00

" Duplicate entities

Do extrude: IND -2
r

¥ Mairtain lapers
Multiple copies: |1

Select Cancel

Figure 5. The Move window
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2.5. Rotating the circle 36 degrees around a point and copying it.

1. Use the Copy window, located in Utilities=>Copy.
2. Repeat the rotation process explained in section 2.4, but this time with an angle of
36 degrees (see Figure 6).

@

I

O

Figure 6. Result of the rotations

na NOTE: The Move and Copy operations differ only in that Copy creates new entities while
Move displaces entities.
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2.6. Rotating and copying the auxiliary lines

49

1. Use the Copy window, located in Utilities=> Copy (see Figure 9).

2. Repeat the rotating and copying process from section 2.5 for the two auxiliary
lines. Select the option Lines from the Entities type menu and enter an angle of
36 degrees.

3. Select the lines to copy and rotate. Do this by clicking Select in the Copy window.

4. Press ESC to indicate that the process of selecting lines is finished, thus executing

the task (see Figure 7).

@

p—

O

Figure 7. Result of copying and rotating the line.

Rotate the line segment that goes from the origin to
point (40, 0) by 33 degrees and copy it (see Figure 8).

-)

=

@)

Figure 8. Result of the rotations and copies

Entities type: ILines hd
Transformation: IHotation v

Angle; |36 Degess
~Firzt paint——————
Tumn: w |0.0
I w |00

a =z |00
v Twao dimensions
~Second point
Hum: w 0.0
| w |D.D

= z |00

[™ Duplicate entities

Do extrude: IN:: hd

r

v tdaintain layers

Multiple copies: |1

Select Cancel

Figure 9. The copy window

Im NOTE: In the Copy and Move windows, the option Pick may be used to select existing

points with the mouse.
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2.7. Intersecting lines

Choose the option Geometry2>Edit>
Intersection>Line-line.

Select the upper circle resulting from the 36-
degree rotation executed in section 2.5.

Select the line resulting from the 33-degree
rotation executed in section 2.6 (see Figure
10).

Press ESC to conclude the intersection of
lines.

Create a line between point (55, 0) and the
point generated by the intersection. To select
the points, use the option Join Ctrl-a in the
Contextual menu.

Choose the option Geometry>Edit>
Intersection>Line-line in order to make
another intersection between the lower circle
and the line segment between point (40, 0) and
point (55, 0) (see Figure 11).

Then continue selecting to make an
intersection between the upper circle and the
farthest segment of the line that was rotated 36
degrees (see Figure 12).

CASE STUDY 1

O

Figure 10. The two lines selected

2

®

Figure 11. Intersecting lines

=

Figure 12. Intersecting lines
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2.8. Creating an arc tangential to two lines

N

Choose Geometry->Create>Arc—>Fillet curves.

2. Enter a radius of 1.35 in the command line (see footnote 2 on page 4).

3. Now select the two line segments shown in Figure 13. Then press ESC to indicate
that the process of creating the arcs is finished.

O
Figure 13. The line segments to be selected

2.9. Translating the definitive lines to the “profile” layer

1. Select the “profile” layer in the Layers window. The auxiliary lines will be
eliminated and the “profile” layer will contain only the definitive lines.
2. In the Sent To menu of the Layers window, choose Lines in order to select the

lines to be translated. Select only the lines that form the profile (Figure 14). To
conclude the selection process, press the ESC key or click Finish in the Layers
window.

Figure 14. Lines to be selected
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2.10. Deleting the “aux” layer

1.
2.
3.

4.
5.
6

Click Off the profile layer.

Choose Geometry->Delete>All Types (or use the GiD Toolbox).

Select all the lines and surfaces that appear on the screen. (The click-and-drag
technique may be used to make the selection.)

Press ESC to conclude the selection of elements to delete.

Select the “aux” layer in the Layers window and click Delete.

Select the “profile” layer.

na NOTE: When a layer is clicked Off, GiD reminds you of this. From this moment on,
whatever is drawn does not appear on the screen since it is in the hidden layer.

na NOTE: To cancel the deletion of elements after they have been selected, open the mouse
menu, go to Contextual and choose Clear Selection.

NOTE: Elements forming part of higher level entities may not be deleted. For example, a
point that defines a line may not be deleted.

NOTE: A layer containing information may not be deleted. First the contents must be

deleted.

2.11. Rotating and obtaining the final profile

wn

Make sure that the activated layer is the “profile” layer. (Use the option Layer To
use.)

In the Copy window, select the line rotation (Rotation, Lines).

Enter an angle of 36 degrees. Make sure that the center is point (0, 0, 0) and that
you are working in two dimensions.

In the Multiple Copies box enter 9. This way, 9 copies will be made, thus
obtaining the 10 teeth that form the profile of the model (9 copies and the original).
Click Select and select the profile. Press the ESC key or click Finish in the Copy
window in order to conclude the operation. The result is shown in Figure 15.

Figure 15. The part resulting
from this process
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2.12. Creating a surface

1. Create a NURBS surface. To do this, select the option Geometry->
Create>NURBS Surface>By Contour. This option can also be found in the GiD
Toolbox.

2. Select the lines that define the profile of the part and press ESC to create the
surface.

3. Press ESC again to exit the function. The result is shown in Figure 16.

7

Figure 16. Creating a surface starting from the contour

Iw NOTE: To create a surface there must be a set of lines that define a closed contour.
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3. CREATING A HOLE IN THE PART

In the previous sections we drew the profile of the part and we created the surface. In this
section we will make a hole, an octagon with a radius of 10 units, in the surface of the part. First
we will draw the octagon.

1. Select from the menu Geometry-> Create->Object->Polygon to create a regular
polygon.

Enter 8 as the number of sides of the polygon.

Enter (0,0,0) as the center of the polygon.

Enter or select (0,0,1) (Positive Z) as the normal of the polygon.

Enter 10 as the radius of the polygon and press ENTER. Press ESC to finish the
action.

ahwd

We get the result as shown in figure 20. As we only need the boundary we should remove the
associated surface. Select the option Geometry->Delete->Surfaces and then select the
surface of the octagon. Press ESC to finish.

Figure 17. Regular 8-sided polygon
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3.1. Creating a hole in the surface of the mechanical part

1. Choose the option Geometry->Edit>Hole NURBS Surface.
2. Select the surface in which to make the hole (Figure 18).
3. Select the lines that define the hole (Figure 19) and press ESC.

Figure 18. The selected surface in  Figure 19. The selected lines that
which to create the hole define the hole

4. Again, press ESC to exit this function.

O

Figure 20. The model part with the hole in it
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4. CREATING VOLUMES FROM SURFACES

The mechanical part to be constructed is composed of two volumes: the volume of the wheel
(defined by the profile), and the volume of the axle, which is a prism with an octagonal base that
fits into the hole in the wheel. Creating this prism will be the first step of this stage. It will be
created in a new layer that we will name “prism”.

4.1. Creating the “prism” layer and translating the octagon to this layer

1.
2.
3.

In the Layers window, type the name of the new layer and click New.

Select the “prism” layer and click Layer To use to choose it as the activated layer.
Choose Lines in the Sent To menu in the Layers window. Select the lines that define
the octagon. Press ESC to conclude the selection.

Select the “profile” layer and click Off to deactivate it.

7

Figure 21. The lines that form the octagon
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4.2. Creating the volume of the prism

1. First copy the octagon a distance of -50 units relative to the surface of the wheel, which
is where the base of the prism will be located. In the Copy window, choose
Translation and Lines. Since we want to translate 50 units, enter two points that
define the vector of this translation, for example (0, 0, 0) and (0, 0, 50). (Make sure that
the Multiple Copies value is 1, since last time the window was used its value was 9).

2. Choose Select and select the lines of the octagon. Press ESC to conclude the
selection.

Figure 22. Selection of the lines that form the octagon

3. Since the Z axis is parallel to the user’s line of vision, the perspective must be changed
to visualize the result. To do this, use the Rotate Trackball tool, which is located in the
GiD Toolbox and in the mouse menu.

Figure 23. Copying the octagon and changing the perspective

4. Choose Geometry>Create>NURBS surface>By contour. Select the lines that
form the displaced octagon and press ESC to conclude the selection. Again, press
ESC to exit the function of creating the surfaces.

Figure 24. The surface created on the translated octagon
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5. In the Copy window, choose Translation and Surfaces. Make a translation of 110
units. Enter two points that define a vector for this translation, for example (0, 0, 0) and

(0, 0, -110).

6. To create the volume defined by the translation, select Do Extrude Volumes in the
Copy window.

7. Click Select and select the surface of the octagon. Press ESC. The result is shown in
Figure 25.

Figure 25. Creation of the volume of the prism

8. Choose the option Render->Flat from the mouse menu to visualize a more realistic
version of the model. Then return to the normal visualization using Render-> Normal.

Figure 26. Visualization of the prism with the option Render>Flat.

na NOTE: The Color option in the Layers window lets you define the color of the selected
layer. This color is then used in the rendering of elements in that layer.
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4.3. Creating the volume of the wheel

1.

w

Nooak

Visualize the “profile” layer and activate it. The volume of the wheel will be created in
this layer. Deactivate the “prism” layer in order to make the selection of the entities
easier.

In the Copy window, choose Translation and Surfaces. A translation of 10 units will
be made. To do this, enter two points that define a vector for this translation, for
example (0, 0, 0) and (0, 0O, -10).

Choose the option Do Extrude Volumes from the Copy window. The volume that is
defined by the translation will be created.

Make sure that the Maintain Layers option is not checked.

Click Select and select the surface of the wheel. Press ESC.

Select the two layers and click them On so that they are visible.

Choose Render->Flat from the mouse menu to visualize a more realistic version of the
model (Figure 27).

Figure 27. Image of the wheel
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5. GENERATING THE MESH

Now that the part has been drawn and the volumes created, the mesh may be generated. First
we will generate a simple mesh by default.

Depending on the form of the entity to be meshed, GiD performs an automatic correction of the
element size. This correction option, which by default is activated, may be modified in the
Meshing card of the Preferences window, under the option Automatic correct sizes.
Automatic correction is sometimes not sufficient. In such cases, it must be indicated where a
more precise mesh is needed. Thus, in this example, we will increase the concentration of
elements along the profile of the wheel by following two methods: 1) assigning element sizes
around points, and 2) assigning element sizes around lines.

5.1. Generating the mesh by default

1. Choose Mesh->Generate Mesh.
2. A window comes up in which to enter the maximum element size of the mesh to be
generated (Figure 28). Leave the default value given by GiD unaltered and click OK.

T Enter value window EI

9 Enter size of elementz to be generated

v

Ok Cahcel

Figure 28. The window in which the maximum element size is entered

3. A window appears showing how the meshing is progressing. Once the process is
finished, another window opens with information about the mesh that has been
generated (Figure 29). Click OK to visualize the resulting mesh (Figure 30).
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i tesh Generated. Presz '0K' o see it

Murn, of Tetrahedra elements=3718 ;I
Num. of nodes=1335

LDk Cancel

Figure 29. The window with information ~ Figure 30. The mesh generated with
about the mesh generated default settings

4. Use the Mesh>View mesh boundary option to see only the contour of the volumes
meshed without the interiors (Figure 31). This visualization mode may be combined
with the various rendering methods.

Figure 31. Mesh visualized with the Mesh->View mesh boundary option
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5. Visualize the mesh generated with the various rendering options in the Render menu,
located in the mouse menu.

Figure 32. Mesh visualized with Mesh >View mesh boundary combined with
Render>Flat.

6. Choose View>Mode->Geometry to return to the normal visualization.

na NOTE: To visualize the geometry of the model use View->Mode->Geometry. To
visualize the mesh use View>Mode->Mesh.



GID USER MANUAL 63

5.2. Generating the mesh with assignment of size around points

1. Enter view rotate angle -90 90 ESC® in the command line. This way we will have a
side view.

Figure 33. Side view of the part.

2. Choose Mesh->Unstructured->Assign sizes on points. A window appears in which
to enter the element size around the point to be selected. Enter 0.7.

3. Select only the points on the wheel profile (Figure 34). One way of doing this is to
select the entire part and then deselect the points that form the prism hole. Press ESC
to conclude the selection process.

Figure 34. The selected points of the wheel profile

4. Choose Mesh->Generate mesh.

® Another option equivalent to view rotate angle -90 90 is Rotate->Plane XY, located
in the mouse menu.
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5. A window opens asking if the previous mesh should be eliminated (Figure 35). Click
Yes. Another window appears in which the maximum element size should be entered.
Leave the default value unaltered.

s Dialog window x|

9 The ald mezh will be erazed. Continue?

Cancel

Figure 35

6. A third window shows the meshing process. Once it has finished, click OK to visualize
the resulting mesh (Figure 36).

Figure 36. Mesh with assignment of sizes around the points on the wheel profile

7. A greater concentration of elements has been achieved around the points selected.
8. Choose View>Mode—>Geometry to return to the normal visualization.
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5.3. Generating the mesh with assignment of size around lines

1. Open the Preferences window, which is found in Utilities, and select the Meshing
card. In this window there is an option called Unstructured Size Transitions which
defines the size gradient of the elements. A high gradient number means a greater
concentration of elements on the wheel profile. To do this, select a gradient size of 0.8.
Click Accept.

2. Choose Mesh->Reset mesh data to delete the previously assigned sizes from section
5.2.

3. Choose Mesh->Unstructured->Assign sizes on lines. A window appears in which to
enter the element size around the lines to be selected. Enter size 0.7. Select only the
lines of the wheel profile (Figure 37) in the same way as in section 5.2.

Figure 37. Selected lines of the wheel profile

4. Choose Mesh->Generate mesh. A window appears asking if the previous mesh
should be eliminated. Click Yes.

5. Another window opens in which the maximum element size should be entered. Leave
the default value unaltered.
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6. A greater concentration of elements has been achieved around the selected lines. In
contrast to the case in section 5.2, this mesh is more accurate since lines define the
profile much better than points do (Figure 38).

Figure 38. Mesh with assignment of sizes around lines
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6. OPTIMIZING THE DESIGN OF THE PART

The part we have designed can be optimized, thus achieving a more efficient product. Given
that the part will rotate clockwise, reshaping the upper part of the teeth could reduce the weight
of the part as well as increase its resistance. We could also modify the profile of the hole in
order to increase resistance in zones under axle pressure.

To carry out these optimizations, we will use new tools such as NURBS lines. The final steps in
this process will be generating a mesh and visualizing the changes made relative to the
previous design.

This example begins with a file named “optimizacion.gid”.

6.1. Modifying the profile

1. Choose Read from the Files menu and open the file “optimizacion.gid”.

2. The file contents appear on the screen. In order to work more comfortably, select
Zoom In, thus magnifying the image. This option is located both in the GiD Toolbox
and in the mouse menu under Zoom.

2

£

Figure 39. Contents of the file “optimizacion.gid”.

3. Make sure that the “aux” layer is activated.

4. Choose Geometry->Edit->Divide->Lines->Num Divisions. This option divides a line
into a specified number of segments.

5. A window comes up in which to enter the number of partitions. Enter 8.

6. Select the line segment from the upper part of a tooth (Figure 39) and press ESC.
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10.

11.

12.

CASE STUDY 1

Using the option Geometry—>Create->Point, and create a point with the coordinates
(40, 8.5).

Choose Geometry->Create->NURBS line to create a NURBS curve. The NURBS line
to be created will pass through the two first points which have been created on dividing
the line at point (40, 8.5) and by the two last points of the divided line.

\»

Figure 40. Optimizing the design

Select the first point through which the curve will pass. To do this use Join Ctrl-a,
located in Contextual in the mouse menu.

One at a time, select the rest of the points except the last one. Use Join Ctrl-a each
time in order to ensure that the line passes through the point.

Before selecting the last point, choose Last Point in the Contextual menu. Then finish
the NURBS line. The result is shown in Figure 40.

Send the new profile (See Figure 41) to the “profile” layer and eliminate the auxiliary
lines.

Figure 41. Optimizing the design
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13. Repeat the process explained in sections 2.11 and 2.12 to create the wheel surface:
use the rotation tool to create the entire profile and, using Geometry—>
Create>NURBS Surface>By contour, select it to create a NURBS surface.

14. Repeat the processes explained in section 3 (except section 3.1) and sections 4.1 and
4.2 to create the prismatic volume.

6.2. Modifying the profile of the hole

1. Move the lines of the octagon placed in the profile surface to the “profile” layer (with the

Send To button).

Click Off the “prism” layer. Hiding it simplifies the space on the screen.

Choose Geometry->Create->Object>Circle.

Enter (-10.5, 0) as the center point. Enter a normal to the XY plane (Positive Z) and a

radius of 1.5.

5. From the Toolbox, use the Delete=>Surfaces tool to delete the surface of the circle so
that only the line is left. This way the Geometry->Edit-> Intersection>Multiple Lines
option may be used to intersect the circle (circumference). Select only the circle and
the two straight lines that intersect it.

6. Choose Copy from the Utilities menu and make seven copies (Multiple copies=7),
rotating the circle -45 degrees.

7. Using the intersection options, delete the auxiliary lines leaving only the valid lines,
thus obtaining the new profile of the hole. The result is illustrated in Figure 42.

8. Create the hole in the surface of the wheel using Geometry->Edit>Hole NURBS
Surface (the result is shown in Figure 43).

g /{)
\ﬁ ) \ \H\-‘
- o
A\ £

Figure 42. The new hole profile  Figure 43. The surface of the
new optimized design
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6.3. Creating the volume of the new design

Repeat the same process as in section 4.3:

1. In the Copy window, choose Translation and Surfaces. Enter two points that define a
translation of 10 units, for example (0, 0, 10) and (0, 0, 0). (Make sure that the Multiple
Copies value is 1).

2. Choose Do Extrude Volume in the Copy window.

3. Click Select and select the surface of the wheel. Press ESC.

Figure 44. The volume of the optimized design

4. Click On the “prism” layer.
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7. GENERATING THE MESH FOR THE NEW DESIGN

Generating the mesh for the optimized design is more complex. In this geometry it is especially
important to obtain a precise mesh on the surfaces around the hole and on the surfaces of the
teeth.

Initially, we will generate a simple mesh by default. Then we will generate a mesh using Chordal
Error® to obtain a more accurate result.

7.1. Generating a mesh for the new design by default

1. Choose the option Mesh->Generate mesh.
2. A window appears in which to enter the maximum element size for the mesh to be
generated. Leave the default value provided by GiD unaltered and click OK.

Figure 45. A detail of the mesh generated by default

® The Chordal Error is the distance between each element generated by the meshing
process and the real profile.
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7.2. Generating a mesh using "Chordal Error"

1. Choose Mesh->Unstructured->Sizes by Chordal error.
2. Provide the values shown in figure 46.

Assign sizes by chordal error x|

Chardal Errar: IDDEi

M aximum meshing size: [15

Minirnum meshing size: |0.1

K |

(] 4 LCancel

Figure 46. Chordal error windows

3. Choose Mesh->Generate mesh.
4. A greatly improved approximation has been achieved in zones containing curves and,

more specifically, along the wheel profile and the profile of the hole (see Figure 47).
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Figure 47. A detail of the mesh generated using Chordal Error
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CASE STUDY 2
IMPLEMENTING A COOLING PIPE

This case study shows the modeling of a more complex piece and concludes with a detailed
explanation of the corresponding meshing process. The piece is a cooling pipe composed of
two sections forming a 60-degree angle.

The modeling process consists of four steps:

Modeling the main pipes

Modeling the elbow between the two main pipes, using a different file
Importing the elbow to the main file

Generating the mesh for the resulting piece

At the end of this case study, you should be able to use the CAD tools available in GiD as well
as the options for generating meshes and visualizing the result.
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1. WORKING BY LAYERS

Various auxiliary lines will be needed in order to draw the part. Since these auxiliary lines must
not appear in the final drawing, they will be in a different layer from the one used for the finished

model.

1.1. Creating two new layers

Open the layer management
window, which is  found in  the
Utilities=>Layers menu.

Create two new layers called “aux” and “ok”.
Enter the name for each layer in the Layers
window (Figure 1) and click New.

Choose “aux” as the activated layer. To do
this, click on "aux" to highlight it and then click
on the Layer To Use button. (The name of
the activated layer will appear next to the
button, "aux" in this case.) From now on, all
the entities created will belong to this layer.

x|
L[]
v oo
¢ ol
¥ ool
Laver To use: - aux
On [ff Caolar...
ﬂ ﬁu Sel..
MHew
Delete Fename [ alphabetic
Toback - Send To - Cloge

Figure 1. The Layers window
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2. CREATING THE AUXILIARY LINES

The auxiliary lines used in this project are those that make it possible to determine the center of
rotation and the tangential center, which will be used later to create the model.

2.1. Creating the axes

Choose the Line option, by selecting Geometry-> Create-> Straight line'.

Enter the coordinate (0, 0) in the command line.

Enter the coordinate (200, 0) in the command line.

Press ESC? to indicate that the process of creating the line is finished.

If the entire line does not appear on the screen, use the option Zoom Frame, which is
located in the GiD Toolbox and in Zoom in the mouse menu.

Again, choose Line. Draw a line between points (0, 25) and (200, 25). The result is
shown in Figure 2.

arON -~

o

Figure 1

7. Go to the Copy window (Figure 4), which is found in Utilities=> Copy.

8. Choose Rotation from the Transformation menu and Lines from the Entities Type
menu.

9. Enter an angle of -60 degrees and click on Two dimensions.

' This option can also be found in the GiD Toolbox.

2 Pressing the ESC key is equivalent to pressing the center mouse button.
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10. Enter point (200, 0, 0) in First Point. This
is the point that defines the center of
rotation.

11. Click Select to select the first line we
drawn.

12. After making the selection, press ESC (or
Finish in the Copy window) to indicate
that the selection of lines to be rotated is
finished. The result is shown in Figure 3.

X

Figure 2. Creating the axes

Entities type: ILines -
Transformatior: IH:::tatiu:un -

Angle: [-60 Degrees
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¥ Two dimensions
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[T Duplicate entities

Do extrude: IN::: hd

-

¥ taintain lapers

kultiple copies: (1

Select Cancel

Figure 3. The Copy window
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2.2. Creating the tangential center

No o

Choose the menu option Geometry->Create-> Straight line. On the mouse menu,
choose Contextual and use Join Ctrl-a to select points (0, 0) and (0, 25). Press ESC.
In the Copy window, choose Rotation from the Transformation menu and Lines from
the Entities Type menu. Enter an angle of 120 degrees, and the coordinates (0, 25, 0)
in First point also check the Two dimensions option. Finally select last line created.
In the Copy window, choose Translation from the Transformation menu and Lines
from the Entities Type menu. The translation vector for the translation to be made is
the line just created. As the first point of the translation, select the point farthest from
this line segment. For the second point, select the other point of the line (Figure 5).

First point o
Tg)nd point \

\

Figure 4. The line segment selected Figure 5. Result of the translation

is the translation vector. with copy

Click Select to select the line segment that forms an angle of -60 degrees with the
horizontal. Press ESC to indicate that the selection has been made.

Choose Geometry->Edit->Intersection>Line-line.

Select the two inner lines.

Click Yes to confirm that there is an intersection and that, therefore, the shortest
distance between the two entities is 0. The intersection between the two entities (lines)
creates a point. This point will be the tangential center.

Press ESC to indicate that the process of intersection between lines is finished.
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Center of

e Tangency

\

N

Figure 6. The auxiliary lines

ua NOTE: The Undo option allows you to undo the operations most recently carried out. If an
error is made, go to Utilities>Undo; a window appears where you can select all the options to
be eliminated.
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3. CREATING THE FIRST COMPONENT PART

In this section the entire model, except the T junction, will be created. The model to be created
is composed of two pipes forming a 60-degree angle. To start with, the first pipe will be created.
This pipe will then be rotated to create the second pipe.

3.1. Creating the profile

1. Select the ok layer and click on Layer To use. From now on, all entities created will
belong to the ok layer.

2. Choose the Line option, located in Geometry->Create->Straight line.

3. Enter the following points: (0, 11), (8, 11), (8, 31), (11, 31), (11, 11) and (15, 11). Press
ESC to indicate that the process of creating lines is finished.

Figure 7. Profile of one of the disks around the pipe

4. From the Copy window, choose Lines and Translation. A translation defined by
points (0, 11) and (15, 11) will be made. In the Multiple copies option, enter 8 (the
number of copies to be added to the original). Select the lines that have just been
drawn.

/\'I/"I'T'I"I'I"I"I"I"IT'I'T'I'I"I"I'
[LELEEEE T =

Figure 8. The profile of the disks using Multiple copies
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5. Choose Line, located in Geometry->Create->Straight line. Select the last point on
the profile (at the right part of the profile) using the option Join Ctrl-a, which is in the
Contextual menu in the mouse menu. Now choose the option No join Ctrl-a. Enter
point (200, 11). Press ESC to finish the process of creating lines.

6. Again, choose the Line option and enter points (0, 9) and (200, 9). Press ESC to
conclude the process of creating lines (Figure 10).

nnnnnpnoononon w
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N\

Figure 9. Creating the lines of the profile Figure 10. Copy of the vertical line
segment starting at the origin of

coordinates

7. From the Copy window, choose Lines and Translation. As the first and second points
of the translation, enter the points indicated in Figure 11. Click Select and select the
vertical line segment starting at the origin of coordinates. Press ESC.

8. Choose Geometry->Edit->Intersection>Multiple lines. Select the last two lines
created and the vertical line segment coming down from the tangential center (see
Figure 12). Press ESC.
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N\

Figure 11. Selecting the lines to intersect

9. Choose Geometry->Delete>All Types. (This tool may also be found in the GiD
Toolbox.) Select the lines and points beyond the vertical that passes through the
tangential center. Press ESC. They will be deleted and the result should look like that
shown in Figure 13.

1 0

Figure 12. Profile of the pipe and the auxiliary lines
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3.2. Creating the volume by revolution

ook

Rotation of the profile will be carried out in two rotations of 180 degrees each. This
way, the figure will be defined by a greater number of points.

From the Copy window, select Lines and Rotation. Enter an angle of 180 degrees
and from the Do extrude menu, select Surfaces. The axis of rotation is that defined by
the line that goes from point (0, 0) to point (200, 0). Enter these two points as the First
Point and Second Point. Be sure to enter 1 in Multiple Copies.

Click Select. For an improved view when selecting the profile, click Off the “aux” layer.
Press ESC when the selection is finished. The result should be that illustrated in Figure
14.

Figure 13. Result of the first step in the rotation (180 degrees)

Repeat the process, this time entering an angle of —180 degrees.

To return to the side view (elevation), choose Rotate->Plane XY.

Choose Render->Flat from the mouse menu to visualize a more realistic version of the
model. Return to the normal visualization with Render->Normal. This option is more
comfortable to work with.
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Figure 14. The pipe with disks, created by rotating the profile.

ma NOTE: To select the profile once the first rotation has been performed, first select all the
lines and then delete those that do not form the profile. Use the option Rotate>Trackball from
the mouse menu to rotate the model and make the process of selection easier.



| 84

CASE STUDY 2 |

3.3. Creating the union of the main pipes

1.

Choose the Zoom-=>In option from
the mouse menu. Magnify the right
end of the model.

Make sure the "aux" layer is
visible.

From the Copy window, select
Lines and Rotation. Enter an
angle of 120 degrees and from the
Do extrude menu, select
Surfaces. Since the rotation may
be done in 2D, choose the option
Two Dimensions. The center of
the rotation is the tangential
center.

Figure 15. The magnified right end of
the model, and the lines to be selected

4. Click Select and select the four lines that define the right end of the pipe (see Figure
16). Press ESC when the selection is finished.

Figure 16. Result of the rotation
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3.4. Rotating the main pipe

1.  From the Copy window, select Surfaces and Rotation. Enter an angle of -60 degrees.
Since the rotation may be done in 2D, choose the Two Dimensions option. The center
of the rotation is the intersection of the axes, namely point (200, 0). Ensure the Do
Extrude menu is set to No.

2. Click Select and select all the surfaces except those defining the elbow of the pipe.
Press ESC when the selection is finished.

A

3
LT T T T T T T =4

Figure 17. Geometry of the two pipes and the auxiliary lines
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3.5. Creating the end of the pipe

1.

From the Copy window, select Surfaces and Rotation. Enter an angle of 180
degrees. Since the rotation may be done in 2D, choose the option Two Dimensions.
The center of rotation is the upper right point of the pipe elbow. Make sure the Do
Extrude menu is set to No.

Click Select and select the surfaces that join the two pipe sections.

In the Move window, select Surfaces and Translation. The points defining the
translation vector are circled in Figure 19.

Click Select and select the surfaces to be moved. Press ESC. The result should be as
is shown in Figure 20.

—

=

Figur:a —1 8 nThne

circled points define the | Figure 19. The final position of the translated

translation vector. elbow.
5. Choose
Geometry->Create>NURBS

surface->By contour and select the
four lines that define the opening of
the pipe (Figure 21). Press ESC.
From the Files menu, choose Save
in order to save the file. Enter a
name for the file and click Save.

Figure 20. Openin the end of the pipe
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4. CREATING THE SECOND COMPONENT PART: THE T JUNCTION

Now, an intersection composed of two pipe sections will be created in a separate file and the
surfaces will be trimmed. Then this file will be imported to the original model to create the entire
piece.

4.1. Creating one of the pipe sections

1. Choose Files>New, thus starting work in a new file.

2. Choose Geometry—->Create->Point and enter points (0, 9) and (0, 11). Press ESC to
conclude the creation of points.

3. From the Copy window, select Points and Rotation. Enter an angle of 180 degrees
and from the Do extrude menu, select Lines. The axis of rotation is the x axis. Enter
two points defining the axis, one in First Point and the other in Second Point, for
example, (0, 0, 0) and (100, 0, 0) (Figure 22).

4. Click Select and select the two points just created.

5. Repeat the process, this time entering an angle of —180 degrees, thus creating the
profile of the pipe section with a second rotation of 180 degrees. The rotation could
have been carried out in only one rotation of 360 degrees. However, in the present
example, each circumference must be defined between two points (Figure 23).

Figure 21. The result of the first Figure 22. The combined result of the
180-degree rotation. first rotation and the second rotation of
—180 degrees, thus obtaining the
profile of the pipe section.

6. From the Copy window, choose Lines and Translation. In First Point and Second
Point, enter the points defining the translation vector. Since the pipe section must
measure 40 length units, the vector is defined by points (0, 0, 0) and (-40, 0, 0).

7. From the Do extrude menu, choose the Surfaces option.
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8. Click Select to select the lines that define the cross-section of the pipe. Press ESC to
conclude the selection process.

Figure 23. Creating a pipe by extruding circumferences

4.2. Creating the other pipe section

1. Choose Geometry->Create->Point and enter points (-20, 9) and
(-20, 11). Press ESC to conclude the creation of points.

2. From the Copy window, select Points and Rotation. Enter an angle of 180 degrees
and from the Do extrude menu, select Lines. Since the rotation can be done on the xy
plane, choose Two Dimensions. The center of rotation is the coordinates (-20, 0, 0).

3. Click Select and select the two points just created. Repeat the process, this time
entering an angle of -180 degrees.

4. From the Copy window, select Lines and Translation. In First Point and Second
Point enter the points defining the translation vector. Since this pipe section must also
measure 40 length units, the vector is defined by points (0, 0, 0) and (0, 0, 40).

5. From the Do extrude menu, select the Surfaces option.

6. Click Select to select the lines that define the cross-section of the second pipe. Press
ESC to conclude the selection.

Figure 24. A rendering of the two intersecting pipes
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4.3. Creating the lines of intersection

N

Choose Geometry>Edit->Intersection>Surface-surface.

2. Select the outer surfaces of each pipe, thus forming the intersection of the two
surfaces selected.

3. Repeat the process to obtain the four lines of intersection.

Figure 25. Creating lines of intersection between the surfaces
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4.4. Deleting surfaces and lines

1. Choose Geometry->Delete>Surfaces and select the small surfaces inside the first
pipe. Press ESC to conclude the process of selection.

2. Choose Geometry->Delete->Lines. Select the lines defining the end of the second
pipe (foreground) that are still inside the first pipe (background). The result is shown in
Figure 27.

Figure 26. Final configuration after deleting surfaces and lines
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4.5. Closing the volume

1. The model now has three outlets. The two farthest from the origin of coordinates must
be closed. The third will be connected to the rest of the piece when the T junction is
imported.

2. Choose Geometry—>Create>NURBS Surface->By contour and then select the lines
defining the outlet in the foreground of Figure 28. Press ESC (see Figure 28).

Figure 27. Creating a NURBS surface to close the outlet in the foreground

3. Repeat the process for the other outlet to be closed.

4. From the Files menu, select Save to save the file. Enter a name for the file and click
Save.



[ 92 CASE STUDY 2 |

5. IMPORTING THE T JUNCTION TO THE MAIN FILE

The two parts of the model have been drawn. Now they must be joined so that the final volume
may be created and a mesh of the volume may be generated.

5.1. Importing a GiD file

1.  Choose Read from the Files menu. Select the file where the first part, created in
section 3, was saved. Click Open.

2. Choose Files=>Import->Insert GiD geometry from the menu. Select the file where
the second part, created in section 4, was saved. Click Open.

3. The T junction appears. Bear in mind that the lines which define the end of the first
pipe (background) of the T junction, and which have been imported, were already
present in the first file. Notice that the lines overlap. This overlapping will be remedied
by collapsing the lines.

4. Choose the option Geometry->Edit->Collapse->Lines. Select the overlapping lines
and press ESC.

o

Figure 28. Importing the T junction file to the main file.
Some points are duplicated and must be collapsed.
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5.2. Creating the final volume

1. Choose Geometry->Create=>Volume->By contour and select all the surfaces that
define the volume. Press ESC to conclude the selection process.
2. Choose Render->Smooth to visualize a more realistic version of the model.

Figure 29. A rendering of the finished piece of equipment
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6. GENERATING THE MESH

Now that the model is finished, it is ready to be meshed. The mesh will be generated using
Chordal Error in order to achieve greater accuracy in the discretization of the geometry. The
chordal error is the distance between the element generated by the meshing process and the
real profile of the model. By selecting a sufficiently small chordal error, the elements will be
smaller in the zones with greater curvature.

6.1. Generating the mesh using Chordal Error

1. Choose the option Mesh->Unstructured-> Sizes by Chordal error.

2. Enter 1 for the minimum element size.

3. Enter 15 for the maximum element size.

4. Enter 0.2 for the chordal error.

5. Choose Mesh->Generate mesh.

6. A window opens in which to enter the maximum element size of the mesh to be
generated. Leave the default value provided by GiD unaltered and click OK.

7. When the meshing process is finished, a window appears with information about the

mesh that has been generated. Click OK to visualize the mesh.

8. Choose Mesh->View Mesh Boundary to see only the contour of the volumes meshed
but not the interiors.

9. The visualization may be rendered using the various options in the Render menu,
located in the mouse menu.

Figure 30. The mesh generated for the piece

ma NOTE: By default GiD corrects element size depending on the form of the entity to mesh.
This correction option may be deactivated or reactivated in the Meshing card in the
Preferences window under the option Automatic correct sizes.
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6.2. Generating the mesh by assignment of sizes on surfaces

1. Choose Mesh->Unstructured->Assign sizes on surfaces. A window opens in which
to enter the element size for the surfaces to be selected. Enter size 1.

Select the surfaces of the elbow.

Choose Mesh—>Generate mesh.

A window appears asking whether the previous mesh should be eliminated. Click Yes.
Another window appears in which the maximum element size should be entered.
Leave the default value provided by GiD unaltered and click OK.

Choose Mesh->View Mesh Boundary to see only the contour of the meshed volumes
but not the interiors (Figure 32).

aoRr0dD

o

Figure 31. The mesh with a concentration of elements on the surfaces of the elbow

7. A greater concentration of elements has been achieved on the selected surfaces.
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ASSIGNING ELEMENT SIZES FOR GENERATING THE

MESH

The objective of this example is to mesh a mechanical piece using the various options in GiD for

assigning sizes to elements, and the different surface meshers available. In this example a

mesh is generated for each of the following methods for assigning sizes, using different surface

meshers:

Assigning sizes around points
Assigning sizes around lines

Assigning sizes on surfaces

Assigning sizes with Chordal Error
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1. INTRODUCTION

In order to carry out this example, start by opening the project “ToMesh4.gid”. This project
contains a geometry that will be meshed using four different methods, each one resulting in a
different density of elements in certain zones.

1.1. Reading the initial project

In the Files menu, select Read. Select the project “ToMesh4.gid” and click Open.

The geometry appears on the screen. It is a set of surfaces.

Select Render>Flat from the mouse menu'.

Select Rotate->Trackball from the mouse menu. (This tool is also available within the
GiD Toolbox.) Make several changes in the perspective so as to get a good idea of the
geometry of the object.

5. Finally, return to the normal visualization, selecting Render->Normal. This mode is
more user-friendly.

PONA

Figure 1. Contents of the project “ToMesh4.gid”.

' The mouse menu appears when the right mouse button is clicked.
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2. ELEMENT- SIZE ASSIGNMENT METHODS

GiD automatically corrects element sizes according to the shape of the entity to be meshed and
its surrounding entities. This default option may be deactivated and reactivated by going to the
Mesh menu, selecting Preferencesz, and then Automatic correct sizes®.

Sometimes, however, this type of correction is not sufficient and it is necessary to indicate
where on the mesh greater accuracy is needed. In these cases, GiD offers various options and
methods allowing sizes to be assigned to elements. Five examples are shown to illustrate the
default method and the four other methods.

2.1. Assignment using default options

1. Select Mesh->Generate Mesh.

2. A window appears showing the maximum element size. Leave this default size
unaltered and click OK.

3. A meshing process window opens. Then another window appears with information
about the mesh generated. Click OK to visualize the mesh (see Figure 2).

-

Figure 2. Meshing by defauilt.

2 The Preferences option can also be found in the Utilities menu.

® Automatic correct sizes automatically executes the options Assign sizes>By
geometry and Assign sizes>Correct sizes.
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Note that in the zone highlighted in Figure 3, elements are smaller than in the rest of the model.
This is because of the shape of the surface placed there. When all meshing preferences are set
to their default levels, as for this example, the RFAST surface mesher is used. In this way,
geometrical entities are meshed hierarchically: first of all lines are meshed, then the surfaces,
and finally the volumes. The line elements size depends on the shape of surfaces (as can be
seen in this example). Later on we will see an example using RIUMP mesher, where element

sizes are distributed differently.

RSN R
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Figure 3. Meshing by default. Zone where elements are smaller because of the
surface shape.
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2.2. Assignment around points

1. Select Mesh>Unstructured->Assign size on points. A window appears in which to
enter the element size around the points to be chosen. Enter 0.1 and click OK.

2. Select the point indicated in Figure 4. Press ESC’ to indicate that the selection of
points is finished.

3. Select Mesh->Generate Mesh.

4. A window opens asking whether the previous mesh should be eliminated. Click Yes.

5. GIiD then asks you to enter the maximum element size. Leave the default value
unaltered and click OK.

il

V |
{ /
i !

/

Figure 4. Geometry of the model. The point Figure 5. The mesh with a concentration of
around which the mesh will be concentrated. elements around the point.

6. A concentration of elements appears around the chosen point, given the selected size
(0.1) of these elements (see Figure 5).

7. Go to Utilities and open Preferences. Click Meshing. In the window that appears
there is the option Unstructured Size Transitions. This option defines the transition
gradient of element sizes (size gradient), whose values are between 0 and 1. The
greater the size gradient, the greater the change in space. To test this, enter the value
0.4 and click Accept.

8. Again, select Mesh->Generate Mesh.

* Instead of pressing the ESC key, the center mouse button or the mouse wheel can
also be used.
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9. A window opens asking whether the previous mesh should be eliminated. Click Yes.
10. GiD then asks you to enter the maximum element size. Leave the default value

unaltered and click OK.
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Figure 6. Mesh with the elements concentrated around a point, with a

size gradient of 0.8.
11. The size gradient (0.4) results in a higher density around the point (see Figure 6).

12. Now go back and enter 0.6 in Unstructured Size Transitions. This will result in a
mesh more suitable for our objectives. Click Accept.
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2.3. Assignment around lines

1.

ok w

Select Mesh->Unstructured->Assign size on lines. In the window that appears,
enter the size of the elements around the lines that will be chosen. Enter 0.5 and click
OK.

Select the lines defining the base of the prism (i.e. lines 1, 2, 3, 4 and 40). To see
entity numbers select Label from the mouse menu or from the View menu. If you wish
geometrical entity labels to be displayed, the view mode has to be set to Geometry
using View>Mode->Geometry (this option may also be found in the GiD Toolbox),
and the render mode must be set to Normal. Press ESC.

Select Mesh->Generate Mesh.

A window opens asking if the previous mesh should be eliminated. Click Yes.

Another window appears in which you may enter a maximum element size. Leave the
default value unaltered and click OK. This results in a high concentration of elements
around the chosen lines, given that the selected element size (0.5) is much smaller
than that of the rest of the elements in the model (see Figure 7).
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Figure 7. Mesh with a concentration of elements around lines.
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2.4. Assignment on surfaces
1.

0.5 and click OK.
2.

Select Mesh>Unstructured-> Assign size on surfaces. In the window that appears,
enter the size of the elements to be assigned on the surfaces that will be chosen. Enter

Select the triangular surface resulting from the section of one of the vertexes of the
prism (surface number 1). Press ESC.

3. Select Mesh->Generate Mesh.
4. A window opens asking if the previous mesh should be eliminated. Click Yes.
5. Another window appears in which you can enter the maximum element size. Leave the
default value unaltered and click OK. This results in a high concentration of elements
on the chosen surface; due to the value selected (0.5) (see Figure 8).
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Figure 8. Mesh with a concentration of elements on a surface.
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2.5. Assignment with Maximum Chordal Error

POON=

No o

Select Mesh->Unstructured->Sizes by chordal error....

GiD asks for the minimum element size. Enter 0.1.

GiD asks for the maximum element size. Enter 10.

Enter the chordal error. This error is the maximum distance between the element
generated and the real object (geometry). Enter 0.05 and press OK.

Select Mesh->Generate Mesh.

A window opens asking if the previous mesh should be eliminated. Click Yes.

Another window appears in which you can enter a maximum element size. Leave the
default value unaltered and click OK. This results in a high concentration of elements
in curved areas. Now our approximation is significantly improved (see Figure 9).
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Figure 9. Mesh using sizes assignment by chordal error. Here, there
is a greater concentration of elements in the curved zones.
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3. RUIUMP MESHER

3.1. RJump default options

The RJump mesher is a surface mesher that meshes patches of surfaces (in 3D space) and is
able to skip the inner lines of these patches when meshing. By default, the RJump mesher skips
the contact lines between surfaces that are tangent enough, and points between lines that are
tangent enough. By selecting Mesh->Draw—> Skip entities (Rjump), the entities that RJump is
going to skip and the ones that it is not going to skip are displayed in different colors. In this
chapter we will see the properties of this mesher.

1.
2.

ook~

Select Mesh->Reset mesh data to reset all mesh sizes introduced previously.

A window appears advising that all the mesh information is going to be erased. Press
OK.

Go to Utilities and open Preferences. Click Meshing. In the window that appears you
can choose between the three surface meshers available in GiD (RFast, RSurf and
RJump). Select RJump mesher. Click Accept.

Select Mesh->Generate Mesh.

A window opens asking if the previous mesh should be eliminated. Click Yes.

Another window appears in which you can enter a maximum element size. Leave the
default value unaltered and click OK. This results in a mesh where contact lines
between surfaces that are tangent enough do not have nodes; contact points between
lines tangent enough are also skipped when meshing (see Figure 10).

Wi
2 \fx : 1

Figure 10. Mesh using the RJump mesher.
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Note that the smaller elements shown in Figure 3 do not appear in this mesh, because of the
properties this mesher.

7.

8.
9.
1

11.
12.
13.

0.

Using the RJump mesher it is possible to assign sizes to different entities. As an
example, select Mesh->Unstructured->Size by chordal error....

GiD asks for the minimum element size. Enter 0.1.

GiD asks for the maximum element size. Enter 10.

Enter the chordal error. This error is the maximum distance between the element
generated and the real object. Enter 0.05 and press OK.

Again, select Mesh->Generate Mesh.

A window opens asking if the previous mesh should be eliminated. Click Yes.

Another window appears in which you can enter a maximum element size. Leave the
default value unaltered and click OK. This results in a high concentration of elements
in curved areas, without the nodes in the lines and points that mesher skips. Now our
approximation is significantly improved (see Figure 11).
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Figure 11. Mesh using the RJump mesher and assigning sizes
by chordal error.
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3.2. Force to mesh some entity

If there is a line or a point that the RJump mesher would usually skip, but that you wish to be
meshed, you can specify the entity so that it is not skipped. As an example, we will force Rjump
to mesh line number 43, in order to concentrate elements around point number 29, as it was
done in chapter 2.2.

1. Select Mesh->Mesh criteria=>No skip-=>lines, and select line number 43. Press ESC.

2. Select Mesh->Draw-> Skip entities (Rjump) to display the entities that will and will
not be skipped in different colors. As is shown in Figure 12, line 43 will now not be
skipped; the rest of the lines are unaffected, and RJump will either skip or mesh them
according to its criteria.

Riump Skip

\\ No Skip

- Skip

Y

244

. i
Figure 12. Entities that will be skipped and not skipped using the
RJump mesher.

3. Select Mesh>Unstructured->Assign size on points. A window appears in which to
enter the element size around the points to be chosen. Enter 0.1 and click OK.

4. Select the point indicated in Figure 4 (point number 29). Press ESC to indicate that the
selection of points is finished.

5. Select Mesh>Generate Mesh.

6. A window opens asking if the previous mesh should be eliminated. Click Yes.
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7. Another window appears in which you can enter a maximum element size. Leave the
default value unaltered and click OK. This results in a mesh like the one obtained
before (in Figure 10), but with high concentration of elements around point number 29.
Note that there are nodes on line number 43 because we have forced RJump not to
skip this line (see Figure 13).

x : [ﬂm
Figure 13. Mesh using the RJump mesher, assigning sizes by
chordal error and forcing an entity to be meshed.

In this last example we have forced the mesher not to skip an entity, but it may be interesting in
some models to allow the mesher only to skip a few entities, meshing almost all or them. In this
case, a different surface mesher can be selected (in the Preferences window). One option is
the RSurf mesher which meshes everything except the entities that you ask it to skip, using the
Mesh->Mesh criteria->Skip command. Here, because RJump is not selected, no entity will be
skipped automatically according to tangency with neighboring entities. The next example shows
how to work with this mesher.

8. Select Mesh->Reset mesh data to reset all mesh sizes introduced previously.

9. A window opens advising that all the mesh information is going to be erased. Press
OK.

10. Go to Utilities and open Preferences. Click Meshing. In the window that appears you
can choose between the three surface meshers available in GiD (RFast, RSurf and
RJump). Select the RSurf mesher. Click Accept.

11. Select Mesh->Mesh criteria-> Skip—2>lines, and select lines 48 and 53. Press ESC.

12. Select Mesh->Generate Mesh.
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13. A window opens asking if the previous mesh should be eliminated. Click Yes.

14. Another window appears in which you can enter a maximum element size. Leave the
default value unaltered and click OK. The result is a mesh similar to the first example
obtained in chapter 2 (see Figure 2), but the smaller elements highlighted in Figure 3
do not appear because lines 48 and 53 (which were meshed before) are now skipped
when meshing (see Figure 14).

=4,

x \ 5i0}
Figure 14. Mesh using the RSurf mesher, with

some lines skipped.
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METHODS FOR GENERATING THE MESH

The objective of this example is to mesh a model using the various options available in GiD for
controlling the element type in structured, semi-structured and unstructured meshes. It also
presents how to concentrate elements and control the distribution of mesh sizes.

The six methods covered are:

Generating a mesh using tetrahedra

Generating a volume mesh using points

Generating a mesh using quadrilaterals

Generating a structured mesh on surfaces and volumes
Generating a semi-structured volume mesh

Generating a mesh using quadratic elements
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1. INTRODUCTION

In order to carry out this example, start from the project "ToMesh3.gid". This project contains a
geometry that will be meshed using different types of elements.

1.1. Reading the initial project

1. In the Files menu, select Read. Select the project “ToMesh3.gid” and click Open.

2. The geometry appears on the screen. It is a set of surfaces and three volumes. Select
Render->Flat from the mouse menu' or from the View menu. In Figure 1 shows the
geometrical model loaded.

3. Select Rotate>Trackball from the mouse menu. (This option is also available in the
GiD Toolbox.) Make several changes in the perspective so as to get a good idea of the
geometry involved.

" Figure 1. Contents of the project “ToMesh3.gid”.

4. Finally, return to the normal visualization Render->Normal. This mode is more user-
friendly.

' The mouse menu appears when the right mouse button is clicked.
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2. GENERATING THE MESH - TYPES OF MESHES

Using GiD the mesh may be generated in different ways depending on the needs of each
project. The two basic types of meshes are the structured” mesh and the unstructured mesh.
For volumes only there is one additional type, the semi- -structured® mesh. For all these types of
mesh a variety of elements may be used (linear ones, triangles, quadrilaterals, tetrahedra,
hexahedra, prisms, spheres or points). In this tutorial you will become familiarized with the

mesh-generating combinations available in GiD.

2.1. Generating the mesh by default

Select Mesh>Generate mesh.

A window comes up in which to enter the maximum element size for the mesh to be
generated. Leave the default value unaltered and click OK.

A meshing process window comes up. Then another window appears with information
about the mesh generated. Click OK to visualize the mesh.

The result is the mesh in Figure 2. There are various surfaces and volumes. By default,
mesh generation in GiD obtains unstructured meshes of triangles on surfaces and
tetrahedra on volumes.

Select Render->Flat to see the mesh in render mode. As is shown in Figure 3, volume
meshes are represented a little bit differently from surface meshes, although in both
cases triangles are shown. If the triangles you see are the boundary of a volume mesh,
they are shown with black edges that are thicker than surface meshes triangles. If the
triangles form a boundary volume mesh and, at the same time, a triangle surface mesh
(this can be obtained if surfaces are selected with the option Mesh->Mesh
criteria>Mesh->Surfaces), the wider edges are colored with the color of the surface
layer. Examples of these different kinds of render are shown in Figure 3.

2 A structured mesh is one in which each node is connected to a constant number of elements.

% A semi-structured volume mesh is one in which you can distinguish a fixed structure in one
direction, i.e. there is a fixed number of divisions. However, within each division the mesh need
not be structured. This kind of mesh is only practical for topologically prismatic volumes.
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Figure 3. Different render styles: a) surface mesh, b)
volume mesh, c) surface mesh and volume mesh together
(surface layer is red and volume layer is blue).
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2.2. Generating the mesh using points

5.

Select Mesh>Element type>Only points. Select volume number one and press
ESC*. To see entity numbers select Label from the mouse menu or from the View
menu. If you wish the geometrical entity labels to be displayed, the view mode needs
to be changed to Geometry using View—>Mode->Geometry (this option may also be
found in the GiD Toolbox). Select Render>Normal to see the labels.

Select Mesh->Generate mesh.

A window comes up asking whether the previous mesh should be eliminated. Click
Yes.

Another window appears in which to enter the maximum element size. Leave the
default value unaltered and click OK. The result is a mesh as illustrated in Figure 4.

Figure 4. Generating a mesh on a volume using points.

Now volume number one is meshed using only the generated nodes.

* Instead of pressing the ESC key, the center mouse button or the mouse wheel can also be

used.
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2.3. Generating the mesh using quadrilaterals

1. Select Mesh->Element type—>Quadrilateral. Select surface number 10.

2. Select Mesh->Generate mesh.

3. A window comes up asking whether the previous mesh should be eliminated. Click
Yes.

4. Another window appears in which the maximum element size can be entered. Leave
the default value unaltered and click OK. The result will be the mesh illustrated in
Figure 5.

FigUfe 5. An unstructured mesh generated using quadrilaterals.

5. The surface is meshed with quadrilaterals, forming an unstructured mesh.
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2.4. Generating a structured mesh (surfaces)

1. To mesh surfaces  with a structured mesh, select the option
Mesh->Structured->Surfaces>Assign.

2. Select surfaces 11 and 12 and press ESC.

3. A window appears in which to enter the number of divisions that the lines to be
selected will have. Enter 4.

4. Select the lines defining the boundaries of the surfaces®. Press ESC.

5. Another window appears in which to enter the number of divisions on the lines. In this
case, all the lines have already been defined with the same number of divisions.
Therefore, click Cancel.

6. Select Mesh->Element type->Triangle. Select surface 12.

Jla NOTE: The edges of surfaces meshed with an unstructured quadrilateral mesh must
always be divided into an even number of segments. So, if these surfaces share edges with a
structured surface mesh, the edges of the structured surface must also be divided into an even
number of segments. In this example, therefore, lines are divided into 4 segments.

Figure 6. Structured mesh of quadrilateral and triangular elements on surfaces.

® When selecting a line, GID automatically selects all lines parallel to it.
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Select Mesh>Generate mesh.

A window comes up asking whether the previous mesh should be eliminated. Click
Yes.

Another window appears in which to enter the maximum element size. Leave the
default value unaltered and click OK. The result is the mesh shown in Figure 6.

As seen in Figures 6 and 7, GiD can obtain surface structured meshes made of
quadrilaterals or triangles. There are two kinds of structured mesh that use triangles:
the one shown in Figure 6 is obtained when the
Utilities>Preferences>Meshing>Symmetrical structured triangles option is set.
If this option is not set, the mesh presented in Figure 7 is produced (with fewer nodes
than if using the previous option).

Figure 7. Structured mesh of quadrilateral and triangular elements on
surfaces, with the option Symmetrical structured triangles not set.
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2.5. Generating structured meshes (volumes)

1. To mesh volumes  with a structured mesh, select the option
Mesh->Structured>Volumes.

2. Select volumes 1 and 2 and press ESC®.

3. A window appears in which to enter the number of divisions that the lines to be
selected will have. Enter 6.

4. Select lines of both volumes parallel to the X- and Z-axes. GiD automatically selects all
the lines in each volume parallel to these in order to create the structured mesh. Press
ESC.

5. Another window appears in which to enter the number of divisions on the lines. Divide
the lines parallel to the Y-axis into 8 segments. Enter 8 and click OK.

6. Select an edge of volume 1 or 2 parallel to the Y-axis and press ESC. Again, the line-
division window comes up. Since we have already finished the assignments, click
Cancel.

Figure 8. Structured volume mesh of hexahedra and tetrahedra.

6 Only volumes that are topologically cubic can be meshed with a structured mesh.



120

11.

METHODS FOR GENERATING THE MESH

For structured volumes, GiD generates hexahedron meshes by default, but tetrahedron
structured meshes can also be assigned. Select Mesh->Element type—>Tetrahedra
and then select volume number 2.

Select Mesh->Generate mesh.

A window appears asking whether the previous mesh should be eliminated. Click Yes.

. Another window comes up in which to enter the maximum element size. Leave the

default value unaltered and click OK. The result is the mesh shown in Figure 8.

GiD can obtain volume structured meshes made of hexahedra, tetrahedra or prisms.
As can be seen in Figures 8 and 9, there are two kinds of tetrahedron structured mesh:
the one shown in Figure 8 is obtained when the option
Utilities>Preferences>Meshing-> Symmetrical structured tetrahedra is set. If this
option is not set, the mesh presented in Figure 9 is produced (with fewer nodes than if
using the previous option; also, it is not topologically symmetrical).

Figure 9. Structured volume mesh of tetrahedra with the option Symmetrical
structured tetrahedra not set.
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2.6. Generating semi-structured meshes (volumes)

No o

To mesh volumes with a semi-structured mesh, select the option
Mesh->SemiStructured->Volumes.

A window appears in which to enter the number of divisions for the direction in which it
is structured (the prismatic one). Enter 8.

Select volume 3 and press ESC’. As volume 3 is prismatic in one direction only (i.e.
parallel to Y-axis) GiD will automatically detect this fact and will select it to be the
direction in which the semi-structured volume mesh is structured.

Another window appears in which to enter the number of divisions in the direction of
the structure. In this case we do not want to select any more volumes, so click Cancel.

Select Mesh->Generate mesh.

A window appears asking whether the previous mesh should be eliminated. Click Yes.

Another window appears in which to enter the maximum element size. Leave the
default value unaltered and click OK. The result is the mesh shown in Figure 10.

Figure 10. Semi-structured volume mesh of tetrahedra.

! Only volumes that are topologically prismatic can be meshed with a semi-structured mesh.



122 METHODS FOR GENERATING THE MESH

As can be seen, volume 3 has been meshed with tetrahedra. Semi-structured volumes are
meshed with prisms, by default. However, in this case it was not possible because of volume 2,
which has tetrahedra assigned and shares one surface with volume 3. In the following steps a
hexahedron mesh is produced.

8. Select Mesh>Element type->Hexahedra.

9. Select volumes 2 and 3 and press ESC.

10. Select Mesh->Generate mesh.

11. A window opens asking whether the previous mesh should be eliminated. Click Yes.

12. Another window appears in which to enter the maximum element size. Leave the
default value unaltered and click OK. The result is the mesh shown in Figure 11.

Figure 11. Semi-structured volume mesh of hexahedra.

In case of volume number 3 there is only one direction in which it can possibly be structured (i.e.
in the direction of the prism). If the volume is prismatic in more than one direction, there are two
ways to choose between them: selecting one top surface
(Mesh->SemiStructured->Set->Master surface) or the direction of the structure
(Mesh->SemiStructured->Set->Structured direction). The following example explains this
procedure.

13. Select the option Mesh->SemiStructured>Volumes.

14. A window opens in which to enter the number of divisions in the structured direction
(prismatic). Enter 6.

15. Select volume 1 and press ESC.

16. Select Mesh->SemiStructured->Set->Structured direction.
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17. Select one line parallel to the X-axis of volume number 1 (for example line number 11)
and press ESC.

18. Select Mesh->Unstructured->Assign Entities>Surfaces.

19. Select surfaces 1 and 6 and press ESC®.

20. Select Mesh->Generate mesh.

21. A window opens asking whether the previous mesh should be eliminated. Click Yes.

22. Another window appears in which to enter the maximum element size. Leave the
default value unaltered and click OK. The result is the mesh shown in Figure 12.

Figure 12. Semi-structured volume mesh of prisms and hexahedra.

IM NOTE: As can be seen, by selecting different element types for different geometrical
entities, several kinds of meshes can be generated. Remember always to take care over the
compatibility between element types in shared geometrical entities.

& Volume number one have not been selected as semi-structured, but GiD will assign this mesh
criteria to it automatically when selecting one of its lines to be a structured direction.

It's necessary to set one top surface of the volume “unstructured” because, otherwise, volume
1 will become totally structured. It is because all contour surfaces of this volume have been
assigned as structured automatically when assigning previously this kind of mesh to the volume
(step 2 of chapter 2.5).
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2.7. Concentrating elements and assigning sizes

1. Select Mesh->Structured->Lines>Concentrate elements.

2. Select some structured lines, for example lines 3 and 23. Press ESC.

3. A window comes up in which to enter two values for the concentration of elements.
Positive values concentrate the elements and negative values spread them. Enter 1 as
Start Weight and —0.5 as End Weight'’.

Select Mesh->Generate mesh.

A window opens asking whether the previous mesh should be eliminated. Click Yes.
Another window appears in which to enter the maximum element size. Leave the
default value unaltered. The result is the mesh shown in Figure 13.

ook

" Figure 13. Concentration of elements on lines 3 and 23.

It is also possible to assign sizes to geometrical entities, so that mesh elements can be
concentrated in certain zones. In the following steps some examples are given.

10 Start Weight and End Weight refer to the start point and end point of the line, oriented as it is
drawn when you select it.
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7. Select Mesh>Unstructured->Assign sizes on points.

8. A window appears in which to enter the size to be assigned to points. Enter “0.1”.

9. Select point number 11 and press ESC.

10. Another window appears in which to enter the size to be assigned to points. In this
case, we do not want to assign sizes to any other points, so click Cancel.

11. Select Mesh->Unstructured->Assign sizes on lines.

12. A window appears in which to enter the size to be assigned to lines. Enter “0.5”.

13. Select line number 21 and press ESC.

14. Another window appears in which to enter the size to be assigned to lines. In this case,
we do not want to assign sizes to any more lines, so click Cancel.

15. Select Mesh->Generate mesh.

16. A window appears asking whether the previous mesh should be eliminated. Click Yes.

17. Another window appears in which the maximum element size should be entered.
Leave the default value unaltered. The result is the mesh shown in Figure 14.

<\
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Figure 14. Unstructured size assigned in point 11 and line 21.
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METHODS FOR GENERATING THE MESH

2.8. Generating the mesh using quadratic elements

1.

w

No o s

®

9

Select Zoom—>In from the mouse menu (this option may also be found in the GiD
Toolbox or in the View menu). Enlarge one area of the mesh (e.g. the zone near point

number 3).
Select Label2>All in>Points. The result is shown in Figure 15.

. ,}sz' 23

—E
A

Figure 15. Each number identifies a node. There is a
node for each element vertex.

The node identifiers created by generating the mesh appear on the screen. There is
one identifier for each vertex of each element.

Select Mesh->Quadratic elements—> Quadratic.

Select Mesh->Generate mesh.

A window opens asking whether the previous mesh should be eliminated. Click Yes.
Another window appears in which the maximum element size should be entered.
Leave the default value unaltered and click OK.

Once the mesh has been generated, select Label2>All in>Points. The result is
shown in Figure 16. Now, there are not only nodes at the vertices, but also at the
midpoints of the edges of the elements.

Select Mesh->Quadratic elements-> Quadratic9.

16. Select Mesh->Generate mesh.

na NOTE: By default GiD meshes with first degree (linear) elements. To find out which mode
GiD is working in, select Mesh->Quadratic elements, and it is the flagged option.
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Figure 16. Each number ldent/f/es a node There is a node at each element
vertex and at the midpoint of each edge.

11. A window opens asking whether the previous mesh should be eliminated. Click Yes.
12. Another window appears in which the maximum element size should be entered.

Leave the default value unaltered.

13. Select Label>All in>Points (see Figure 17).
14. Notice that the four-sided elements (quadrilaterals) also have a node in the center, in
addition to the nodes at the vertices and midpoints of the edges. Similarly, hexahedra

also have a node at their center point.

il

!sss T
J 2‘%5”;7»

Figure 17. Each number /dentlfles a node There is a node at each vertex, at
the midpoint of each edge and in the center of quadrilaterals and hexahedra.
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A POST-PROCESS CASE STUDY

POST-PROCESSING A RATCHET WHEEL

The objective of this case study is to run a post-process analysis of a steel ratchet wheel
subjected to a set of forces. We will observe the stresses on the material and the resulting
deformations.

The analysis is carried out in four steps:

e Redefining the part

e Entering conditions and materials

e  Generating the mesh for the entire part and calculating the stresses
e Visualizing the results

By the end of this study, you should be able to run a structural analysis of a model subjected to
external forces and visualize the results in GiD Post-process.
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1. INTRODUCTION

The model in this study will be the one created in Tutorial 1, located in the file “pieza.gid”. The
geometry in this file will be the object of this post-process study.

In order to follow this tutorial, the calculating module Ramsolid' must be installed. To install
Ramsolid, select Data2>Problem type->Internet Retrieve. A window with the available
modules will appear. Select RamSeries Windows, which contains Ramsolid, and click
Retrieve Problem type to install it.

T Retrieve analysis Problem bypes il

Mote: In order to use thiz function. it is neceszary to be connected to internet

Froblen type Version | Ins... | Characteristics

Fiam .. G5 B Stuctural An f bea ; and 3
RamSenes Linus B.0b1 1 Stuctural Analysis of beams, ghells and 30 zolids for Linus
FamSeries Mac05x B.0b1 I Stuctural Analysis of beams, shells and 30 solids for Macintosh Mac05K
Tdyn 414 2 forwiing. 4.14.2b 1 Multiphysics solver for Windows [inchuding fuid fow, heat transfer, speci. .
Tdun 4.17 for Linus 411 1 Muliphyzics solver for Linus [including fuid flow, heat tranzsfer, species ...
TdynLin 1.2 1 CFD panel code for zolving the linearized potential free suface problem
GiD-CEM 3.0 Linux a0 1 Prepostproceszing program with specialized toolz for electromagneticis...
Mastran 3.1.1 311 1 Statics and dynamic interface [beta] for MASTRAM analysiz progran
Masztran examplesz 20 1 Ewxamples for Magtran 2.0
Abagus 1.0 1 Interface to Abaqus program
Caltep 2000 1 Calculuz program to zolve heat problems
[ |
Problem type infa Prablem type news Fietrieve Prablem type Cloze

na NOTE: You can find the finished model on the GiD CD-ROM or on the GiD web page:
http.//www.gidhome.com/support.

! For further information on Ramsolid, consult www.compassis.com
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1.1. Reading the initial file

1. From the Files menu, choose the option Read. Select the file named “pieza.gid” and
click Open. The geometry in Figure 1 appears on the screen.

2. Choose Render->Flat from the mouse menu.

3. Choose Rotate->Trackball from the mouse menu. (This tool is also located in the GiD
Toolbox.) Make a few changes to the perspective in order to get an idea of the
geometry under study.

Figure 1. Contents of the “pieza.gid” file

4. Return to the normal visualization by selecting Render>Normal. This mode is more
comfortable to work with.
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2. CREATING A SINGLE VOLUME

When you carry out a stress test which involves the different volumes that define a structural
solid, Ramsolid requires these volumes to share the surfaces of interaction, that is, these
surfaces must belong to both volumes.

Since the geometry of this study is formed by two volumes with separate surfaces, the volumes
must be connected. To do this, we will delete the existing volumes (those of the axle and the
wheel) and create one new volume as a union of the two.

2.1. Deleting volumes and surfaces

1. Choose Geometry->Delete>Volumes®.
2. Select the two volumes in the file. Press ESC®.

3. Choose Geometry>Delete->Surfaces®. Select’ the surfaces shown in Figure 2 and
Figure 3 and press ESC.

Figure 2. The axle surfaces to select Figure 3. The wheel surfaces to select

2 This option may also be found in the GiD Toolbox.
3 Pressing the ESC key is equivalent to clicking the center mouse button.
* To facilitate the selection of these surfaces, deactivate any unnecessary layers.
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Figure 4. The result after deleting volumes and surfaces

2.2. Creating new surfaces and the final volume

1. Choose the option Utilities->Copy; the Copy window appears. In this window choose
Translation and Lines. The translation vector of the required translation is the line
segment shown in Figure 5. Enter as First Point and Second Point the two points
defining this vector. These points are also shown in Figure 5.

Figure 5. The translation vector and the points that define it
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2. Choose the option Surfaces from the Do Extrude menu in the Copy window.

3. Verify that the “Duplicate entities” option is unchecked, and then click Select and
select the lines defining the hole in the wheel. Press ESC. (See Figure 6.)

Figure 6. Visualization of the new surfaces created at one end of the axle

4. Repeat the process to create the surfaces at the other end of the axle.

5.  When all the surfaces have been created, thus defining a new part (axle and wheel as
one), choose Geometry->Create->Volume—->By contour? and select all the surfaces.

Press ESC.

Figure 7. Visualization of the new volume

6. Choose Geometry->Delete>Lines and select all the lines in the model. Press ESC.
7. Only the lines not contained by the volume will be deleted.
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3. CALCULATING WITH RAMSOLID

Since this is a 3D problem, the calculating module “Ramsolid 5.5” will be used to run it. First we
must load the problem type ramsolid which is located in Data>Problem type.

Note: Your Ramsolid version can be different to the related 5.5, but the steps to follow will be
analogous.

The object of the study is a ratchet wheel that permits rotation of the axle in only one direction.
The aim is to study how the part behaves when subjected to external forces, especially when
the wheel is in equilibrium. In this condition, rotation is blocked by the pole, which resists the
rotating force coming from the axle. At the same time, the pole exerts an equal and opposite
force on one of the teeth. This system is illustrated in Figure 8.

Figure 8. Ratchet wheel and (in red) pole

In order to simulate this condition, the following simplification will be made: the ends of the axle
will be blocked and pressure will be applied to the surfaces of the tooth where the pole resists
rotation. The material is steel.
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3.1. Defining the problem: materials and conditions

1. Since this is a three-dimensional solid problem, choose the option Data->Problem
type>RamSeries5.5>ramsolid.

anisys5a 4
- cma2d
Lorstraints Examples »
Contact ]
I — v I ramsolid
Masses Transfarm

Intemet Retrieve.
Load...

Load cases Urload
Debugger...

Initial_Conditions

Static loads L
Dynamic loads

Fioperties

Pioblem data
Advanced.

Reports...
“Werfy assigned properties

Local axes r

2. Choose Data->Constraints. A window appears in which the problem constraints
are entered.

3. We are dealing with constraints acting on surfaces: the surface symbol ‘{I:.I must

be clicked
Constraints 5' 5'
e N s
Constraints > 2 @ Loeal Pressures Load - a2 @
Flags l\falues | Uritz ~ M-mckg — —
Local Axes GLOBAL: — Mormal inwards | 268
[V Constraint
¥ ¥ Constraint
V¥ Z Constraint
Azzign Entitizz Dirawe Unazsign Azzign  Entities Dirawe Urazsign
LClose LCloze:
Figure 9. The Constraints window. Figure 10. The Static Loads window with the

Local Pressure Load option selected over

surfaces.
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4. In the Constraints window, click Assign. Select the two surfaces that are the ends
of the axle then press ESC (or Finish in the Constraints window).

Figure 11. Selecting the surfaces that are the ends of the axle

5. Choose the Draw option from the menu in the Constraints window. Then select
the colors option (see Figure 12).

Figure 12. Visualization of the condition applied to the surfaces under pressure
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6. Click Data-> Static loads and select surfaces. ﬂ

7. From the pull-down menu select Local Pressure Load. This option enables you to
define the surfaces under pressure5 and specify the value of the pressure. Enter
2e8 having selected N-m-kg in the units menu (see Figure 10). Click Assign and
select the surfaces which will be subject to pressure.

Figure 13. Surface of a tooth . L ”
under pressure Figure 14. Visualization of the condition

applied to the surfaces under pressure

Figure 15. Visualization of all the conditions entered

® Pressure is applied to a surface in the direction of the normal to the surface. If the surface is
part of a volume, a positive pressure value indicates a force towards the interior of the volume.
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The next step is specifying the material of the part. Choose Data->Properties. The
Properties window appears. We want to simulate steel, so enter the corresponding
values of its Young’s Modulus (E), Poisson Ratio (nu) and Specific weight. Make
sure you have selected N-m in the units menu.

s Properties ﬂ
Solid > k2
Uitz M-m-kg =
E|[21ell

nu 0.2
Specific weight | 73000

Azzign  Entities Draw  Unaszign

Cloze

Figure 16. The Properties window

Click Assign and select the volume of the part. Press ESC when the selection is
finished.

Choose the Problem Data option from the Data menu. The Problem Data window
appears. In the Units card, make sure that Mesh units is set to m, and that
Results units is set to N-m-kg. In the Gravity card, we can change the direction in
which gravity acts. Leave this as the default value (Z direction). Press Accept
Data to finish.
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T Problem data x| @ Problem data

(9 |x

Urnits ] Gravity | Analysis | Units ~ Giravity ].l'—‘malysis |

Meshunits m = Grawiby #: (0.0
; Grawity ' IEIDi
Results urits M-r-kg — )

Gravity 2 I'Ilili

LCloze LCloze
%5 Problem data x|
r? )
Units | Grawity ~ Analysis
Analpziz Type Linear Static =

LCloze

Figure 17. The Problem Data window

ua NOTE: GiD enables you to define intervals. An interval is a set of conditions of the kind
entered in this section. Depending on the calculation mode, intervals may be used for different

reasons. By default, only one interval is used.

In the Data menu, there is a submenu labeled Intervals where intervals can be managed: New
(for creating a new interval), Current (for selecting the current interval), and Delete (for deleting
the current interval).
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3.2. Generating the mesh and running calculations

1. Choose Mesh->Generate mesh.

2. A window appears in which to enter the desired element size for the mesh to be
generated. Leave the default value provided by GiD unaltered and click OK. When
using an evaluation version, this may cause a problem if the number of mesh elements
generated exceeds the number permitted for unregistered copies of GiD.

[warning E

This version of GIiD only allows to
0 generate 1010 nodes and there

were 7570.

Check menu Help->Register GID

s

3. If you obtain a message like the one above, you can get a temporary trial password, or
try generating fewer elements by changing the meshing preferences and selecting a
larger element size.

a. Select the option Mesh->Reset mesh data to clear all previously assigned sizes.

b. Open the Preferences window (Utilities>Preferences) and select the Meshing
card. Set the value for Unstructured size transition to 0.9, click Accept and
then Close.

c. Select the option Mesh->Generate mesh and set the size to 10.

4. Once the meshing process has concluded, a window appears with information about
the mesh that has been generated. Click OK to visualize it.

5. Another window shows the meshing process. When the process is finished, use
Mesh->Vies mesh boundaries to see just the contours of the volumes that have been
meshed, not their interiors. This visualization mode may be combined with one of the
various rendering methods (see Figure 18).

VAVARR

AN

Figure 18. Meshing the part with default settings
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6. Now we can begin to perform the calculations. Choose the Calculate option from the
Calculate menu. The Ramsolid calculating module begins the process6 which is run in
background. When the process finishes, a new window appears.

il Process info

Process 'test' started at Wed Oct
26 14:58:31 has finished.

Postprocess

Figure 19.The Process info window

AT

7. Click on Postprocess in order to analyze the results.
8. Select View results=>Displacements—>|Displacements.

K

EETA
Eu

Figure 20. Displacement results Figure 21. Von Misses results.

9. Instead of displacements, we can choose View results>Von Misses

10. Calculating the stresses on the part is especially significant when the surfaces around
the tooth are under pressure. It is important that the mesh on these surfaces is
sufficiently accurate. Accordingly, a smaller sized element will be assigned to these
surfaces.

® For further information about the calculation process, select Calculate Window. A window appears
indicating the moment when the calculation began and its PID. To close this window, click Kill.
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11. Before we continue we need to obtain temporary passwords for both GiD and
Ramseries in order to work with larger meshes. If you already have the passwords skip
this step, if not, follow these steps:

a.Obtain a temporary password for GiD at: http://www.gidhome.com/password
b.Obtain a temporal password for Ramseries at: http://www.compassis.com.

12. Return to GiD Preprocess, go to Utilities>Preferences>Meshing and press Reset.
Another possibility is to select the menu option Mesh->Reset mesh data.

na NOTE: On the Meshing card in the Preferences window, there is an option labeled
Unstructured size transitions, which defines the transition gradient of element sizes (size
gradient), the gradient values being between 0 and 1; the greater the size gradient, the greater
the change in space. The default value for this element size is 0.6.

1. Choose Mesh->Unstructured>Surfaces. A window appears in which to enter the
element size for the surfaces to be selected. Enter size 1.

2. Select the surfaces under pressure and the surfaces around them.

Mﬁﬁ/\ﬁ

Figure 22. Selecting the surfaces to be assigned size 1 elements

3. Choose Mesh->Generate mesh.

4. A window appears asking whether the previous mesh should be eliminated. Click Yes.
Another window opens in which the maximum element size should be entered. Leave
the default value unaltered.
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Figure 23. Concentration of elements on the selected surfaces

5. Now ’ghe calculation can be run. Choose the Calculate option from the Calculate
menu’.

6. Wait until a window appears stating that the calculation is finished.

Process info |

& Process 'pieza_rmallada’ started at Fri
" May 24 13:45:32 has finished.

Postprocess

Figure 24. The Process info window

ma NOTE: The greater the accuracy of the mesh, the greater the accuracy of the calculation
and representation in post-processing. Nevertheless, bear in mind that for a large number of
elements, the total calculation time can be rather long.

" The calculation process runs in the background. You can continue working with GiD, albeit at
a slower pace.
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4. POST-PROCESSING THE PART

Once the calculation has been run, the post-process study may begin. GiD Post-process
enables you to visualize the results based on the analysis.

4.1. Visualizing the results

1. Select Files=>Postprocess.

2. From the Windows menu, choose the View Results option. By default, no
result is visualized when you enter the post-processing component.

[l ¥iew Results & Deformation @

Wiew results I Main Mesh | Reference mesh |

Wiew: |Contaur Fill ¥ | Step:

Analysis: [Estatic =N 4|

I Dizplacements [m)
I Reactiong [M]
I Streszes (Pa)

L 0N

Ii
Apply Cloze

3. Select Contour Fill in the View combo box and Von Misses from the list of
available results.

Figure 25. Visualization of the VON MISSES calculation
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4. The View menu and the Results menu may be combined in order to see the
various calculations with each one of the visualization methods. For example,
select Windows->View style and Hidden Bound in the Style combo box.
Then in the View results window select Contour Lines from the View combo
box and from the list of results select the Sx component of the Stresses result.
Click Apply.

/. ,\ N ™

\f\

A

\

pLLARE

Figure 26. Visualization of the X component of the NODAL STRESS
calculation using Contour Lines
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GillSelect & Display Style E| Gill Wiew Results & Deformation E|

¥ “aolumes [ Sufaces W Cuts iew results l tain Mesh ] Feference mesh ]
| alphabstic ardzr View: |Contour Lines *| Step:
Mame [ 1 | | | Analysis: |Estati N hd
V perfl O nalysis: [Estatic Rl |
Digplacements [m) -
Feactions [M)
= Streszes [Pa)
& @B e ‘B
2 Sy
BOE o +
2 Tuy
T Hidden B ound RG] ol
pre—— 2 Twz
Render: [Maormal -] - @ SiShesses [Pa) ﬂ
Culling: |None -
Conditions: |Mone o
Toback | Send to | Cloze | Apply Close
Figure 27. View Style window Figure 28. View Results window

5. Return to the visualization of the Von Misses calculation by using the Contour
Fill option.

6. The part will be rendered with a scale of colors covering the range of calculated
values (Figure 29). In this example only one interval of the total results range is
of interest. The scale of colors must be adapted so that the lower limit is 5.5e7
and the upper limit is 1e9 (Figure 30).

7. Choose Options=>Contour->Define Limits®. The Contour Limits window
appears (Figure 31). Enter 1e€9 in the box labelled Max and 5.5e7 as the Min
value, then click Apply.

® This option is also available in the post-process Toolbox (Figure 31).



GID USER MANUAL

147

Yan Ilisses YO NﬁE S
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Figure 29. The color scale for the
default values

Figure 30. The color scale with the new limits
for representing the VON MISSES calculation

€S o
o
Contour Limits ". 1_:: m_g ﬁ|

o,

| b [1e+003 & 1] Apply L }:{
° s

| Min: [55e+007  &|7| Close
— nd

Figure 31. The Contour Limits window
Figure 32. Entering the lower limit in the post-
process Toolbox
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Figure 33. Visualization using the new color scale

8. The color scale is distributed between the values 1€9 and 5.5e7. All values outside

this range are colored black. The way in which these values are shown can be
changed. For example, select these options:

Options->Contour>Min Options=>Out Min Color->Min Color and

Options—>Contour->Max Options>Out Max Color->Transparent.

Those values below the visualization range are now represented in the same color
as the minimum value. Those values greater than the maximum value are not
drawn; they are perceived as transparent.

Figure 34. Visualization using the color scale established in step 8. The calculated values in
transparent zones are greater than 1e9.
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9. To return to the initial visualization limit values, choose Options>
Contour>Reset Limit Values.

10. Visualizing the results using vectors is also an option. A vector is drawn for
each element of the mesh. In the View Results window, choose Display
Vectors from the View combo box and Stresses from the results available.
Then choose the S; (the great main stress). Click Apply. Magnify the zone
indicated in Figure 35.

4
&

A
Y=z T

Qe

Figure 35. Visualization of the results

Figure 36. Si main stresses detail
using vectors

11. Now select the All component from the Stresses result. Click Apply; the result
is shown in Figure 388. Red vectors indicate traction (tensile stress) and blue
vectors indicate compression.

(il View Results & Deformation E|

Wiew results l M ain Mesh ] Reference mesh ]

Wiew: W Shep:
Bnalysis: [Estatic = =]
I Displacements [m)

Il Reactions (M)
EH Strezses [Pa)
@ 5i
@ Sii
@ Sii

»
factar: |1.08338e-005

Apply Cloze

Figure 37. Result and scale selection Figure 38. Visualization of all stresses
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4.2. Modes of visualization

1. Choose Windows->View Style. A window labeled Select & Display Style appears
in which the options for visualizing the geometry can be changed. This window is
composed of various menus, each characterizing some aspect of the visualization
of the model. Options from all these menus can be combined to achieve a suitable
visualization.

ma NOTE: In the post-processing component, the elements of the mesh are classified into
Meshes, Sets and Cuts. A new Set is created for each group of surfaces that share the same
material, while there is a Mesh for each group of volumes sharing the same material. Cuts are
sections made into the geometry during post-processing.

The categories Meshes, Sets and Cuts are at the top of the “Select & stile” window. For each
category a color can be chosen using the Color option. Each one may be clicked On or Off°, or
deleted (Del). In the present example there is only one volume and therefore only one Mesh
appears. It is named “Mesh1”.

The Style, Render, Culling and Conditions menus as well as the Massive and Transparent
options affect the visualization of the entire mesh.

2. Try out the various options offered in the Style9 menu. Click Apply to see the
results.

3. Try out the various options offered in the CuIIing9 menu combined with the
Conditions menu and the Transparent and Massive options. Click Apply to see
the results.

® This option is also located in the post-process Toolbox. For further information about the tools in the
Toolbox, click on the corresponding icon with the right mouse button.
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Figure 39. Visualization Figure 40. Visualization using  Figure 41. Visualization using
using Style 2Boundaries Style 2All Lines Style 2Hidden Lines

Figure 42. Visualization

Figure 43. Visualization using  Figure 44. Visualization using
using Style 2Body

Style >Body Bound Style »Body Lines

Figure 45. Culling >Front Figure 46.  Culling >Front Figure 47. Culling>None,
Faces. Faces with the Massive option Conditions »Geometry and

the Transparent option
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[ Select & Display Style E|
W %olumes | Surfaces W Cuts
[ alphabetic order

Massive Na“‘e

options. —\

7—Transparent options.

Delete

Style: Bod_l,J Lines hd
Render; |Smooth
Culling: |Maone hd
Conditionz: |Geannetry hd
To back | Send to | Cloze |

Figure 48. The Massive and Transparent options in the Display Style window
4.3. Visualizing the deformed geometry

1. Choose Windows->View results. The View Results & Deformation window
appears.

2. From the Style menu in the Select & Display Style window, select
Boundaries.

3. From the Mesh Deformation window, select Deformation, under the heading
Main Geometry. Under the heading Reference Geometry select Original.
Click Apply. In order to better distinguish the two geometries, select Body
Bound from the Style menu in the Select & Display Style window.

na NOTE: Changes carried out in the Select & Display Style window do not affect the
reference geometry (in Reference Geometry in the Mesh Deformation window).

na NOTE: The factor box in the Mesh Deformation window indicates the multiplication factor
of the real deformation.

na NOTE: In the Steps boxes in the Mesh Deformation window, the steps to be visualized
can be selected.
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Gill ¥iew Results & Deformation fg|

Yiew results  Main Mesh l Reference mezh ]
Deform main mesh
" Orginal ™ Defomed

Analyziz; Eztatic |

Step: |1 A

Resl Displacements [m) J

Reactions [M]

factor: [15.4623 [ fixed deformation

[ Position wector

Results will be dravn on this deformed model.

Apply Claze

Gill ¥iew Results & Deformation f‘>_(|

Yiews results ] Mair Mesh  Reference mesh l
Detorm reference mesh
 0f ™ Onginal ¢ Deformed

[ Use this color: -

Analyziz: |

Step: |1 - -

Rzl [Displacements [m) J

Feactions [M)

This iz a shapshat of the model. Results will MOT be
drawin over thiz representation,

factor (15,4629 B

Apply Claze

Figure 49. The Mesh Deformation window

Figure 50. The (yellow) deformed geometry (Body Bound) versus
the original geometry (Boundaries)
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4. Now the deformed geometry can be visualized. For example, in the View
Results window, select Contour Fill and NODAL V.MISES then click Apply.

Figure 51. Visualizing the results of the deformed mesh (colored)

4.4, Cuts and divisions

1. In GiD Post-process, you can cut or divide
the mesh to visualize the results within the
interior of the part. Begin the cutting
process by choosing Do cuts>Cut
plane->3 points'’.

W Ve
R

2. Using the Join Ctrl-a option in the

Contextual menu, located in the mouse BTN R
menu, select the three points indicated in ?‘6‘;\“&@?"‘%
1% K
| | - Zoha
3. A Cut is made (see Figure 54). To visualize g‘“‘\‘ﬁ“
it, click Off “V perfil” in the Select & Display N 3

Style (Figure 53).

Figure 52. The cutting plane defined
by three points

' Another option is Do cuts->Cut plane->2 points. Here, the cutting plane is the plane perpendicular to the
screen that passes through the line defined by the 2 points. The cutting options are also located in the post-
process Toolbox.
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Select & Display Style =l

v Volumes [V Sufaces ¥ Culs

| ¥ perfil -
+ LCCutSet 1 perfil

;;I_ﬂj
Color. Rename Delete
SOe(mE

Style:  Hidden Lines —
Render. Momal — (—%{—)

Culling: MNone —
Conditions: Mone — —!

Figure 53. *V perfil” is Off.

Figure 54. The section resulting
from the cut

Im NOTE: The sections (Cuts) made in the original mesh also deform when the mesh
deforms. And vice versa, the cuts made in the deformed mesh deform when the mesh returns to

its original state.
Starting from the View Results window, select Contour Lines from the View

menu, and select Von Misses from the Results available in the list. Click
Apply, thus visualizing the results within the cut (Figure 55).

4.

Figure 55. Visualizing the results within the cut
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5. From the mouse menu, choose Label>Select>Results. Select several nodes,
thus obtaining the numerical value of the VON MISSES module for each node
selected.

1.91e+006

i .56e+@08

el
e
N

Figure 56. Visualizing the numerical values of the VON MISSES module

6. To return to the previous visualization, choose Label>Off from the mouse
menu.

7. In the Select & Display Style window (Figure 53), click “Cut1” Off and “V perfil”
On. Choose Rotate->planeXZ from the mouse menu.

8. Choose Do cuts=>Cut Plane>Succession. This tool enables you to make a
specific number of equidistant cross-sections along an axis. Enter two points to
define the axis (see Figure 57).
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Figure 57. Defining the axis

9. A window appears in which the number of cuts to make can be entered. For the
present example, enter 20. In the Select & Display Style window (Figure 59),
click “V perfil” Off.
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Figure 58. Cuts made using Do cuts>Cut
Plane 2Succession with no visualization of To hack | Sendto | Close |

10.

11.

12.

13.

POSTPROCESSING A RATCHET WHEEL

(1] Select & Display Style E|
v Yaolumes |v Surfaces v Cuts

[ alphabetic order

C CutSet 1 perfil
C CutSet 2 perfil
C CutSet 3 perfil

e

Style: |Body Lines -
Render: |Flat hd eﬁ
Culling: [Hote hd

Conditions: |Mane

the results

Figure 59. The Select & Display Style window
with a list of all the cuts made

Use the View Results window and the Select & Display Style window to
visualize results in the cuts that have been made.

ma NOTE: With the option Files->save cut, the cuts may be saved in a file in
order to be used during another GiD session.

In the Select & Display Style window, select all the cuts and click Del to delete
them. Click “V perfil” On. Choose the Rotate->planeXY option from the mouse
menu.

Choose Do cuts->Divide volume sets=>2 points. Using this option the mesh
is divided by a plane, without cutting the elements. (The plane may be defined
by two or three points and the right or left portion of the model may be selected.
A new mesh is created that contains the selected portion.
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u
Figure 60. The cutting line

14. Enter two points to define the plane that will divide the part, as shown in Figure
60. Click on the right portion of the model to indicate that this is the side to
select. After clicking “V perfil” Off, the result will be that shown in Figure 61.

Figure 61. A visualization of the divided volume using Von Misses and Contour Fill

na NOTE: The dividing tools are classified in three groups: Divide volume sets, Divide
surface sets and Divide lines. In the three cases, entities may be divided by defining 2 or 3
points.
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IMPORTING FILES: A CASE STUDY

IMPORTING FILES

The objective of this case study is to see how GiD imports files created with other programs.
The imported geometry may contain imperfections that must be corrected before generating the
mesh.

For this study an IGES formatted geometry representing a stamping die is imported. These
steps are followed:

e Importing an IGES-formatted file to GiD
e  Correcting errors in the imported geometry and generating the mesh
e  Generating a conformal mesh and a non-conformal mesh
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1. IMPORTING AN IGES FILE

GiD is designed to import a variety of file formats. Among them are standard formats such as
IGES, DXF, or VDA, which are generated by most CAD programs. GiD can also import meshes
generated by other programs, e.g. in NASTRAN or STL formats.

1. Select Files=>Import>IGES ...

View Geometry  Ltlities Data Mesh  Caloulabe  Help

F'D» Hew Chelw Crl-r
T2 Open... Chil-o
3 Save Cirl-z
Save az.. Chel-w Chrl-2
Export L4 Di=F .. Ctrl-d
Parazalid...
'Q\ Postprocess A0S
&u Frirt to file 2 YDA,
Page/image setup... Bhina...
3 Prirt... Shapefile...
Recent files 4 HASTRAM mesh...
& Quit Ciikg STL mesgh...
WRML meszh...
ﬁ A DS tudio mesh..
{1 GiDr mesh...
x Surface mesh...
F‘ﬁa [ Batch file... Chikb
- Inzert GID geometry. .

L

2. Select the IGES-formatted file “base.igs” and click Open.

The file importing process is not always error-free. Sometimes the original file has
incompatibilities with the format required by GiD. These incompatibilities must be overcome
manually. This example deals with various solutions to the difficulties that may arise during the
importing process.
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Directory Entry: G185 Percentage Done 54

Figure 1. Reading the file. Figure 2. Collapsing the model.

IGES Global section parameters: -
Sending Systermn: 98100o0p20.1GS

File name: 981000p20IGS

System ID: MATRA-DATAVISION ELCLIDI
Preprocessor Version: IGESH-E32.1800
Product |0: 981000p20L1GS

hodel Scale: 1

Unitflag: Millimeters

Diate And Time Exchange: 07/6/1998 17:18:0
hinimum Resolution: 0.025

Approximate Meximum Caordinate: 2500
Specification Yersion: 5.1

Date And Time Modification: 07/6/199917.19: 0

‘warning: They are 1897 hidden entities in hack layers

Collapse genmetry, Time=4 seconds “created -1773 points -1 480 lines -4 surfaces, 0 volumes. Imp
ortTolerance=0.011885

Errorin MurbLine:CalcClPinSpline. Interpolation points equal

Errorin MurbLine:Createlnterpolatad.

‘tARNING: Line number 638 has bad definition and couldn't be fixed.ou should erase it

Errorin MurbLine:CalcCrIPinSpling. Interpolation points equal

Etrorin NurbLine: Createlnterpolatad.

(ARMNING: Line number 839 has bad definition and couldn't be fixed.You should erase it

Close

Figure 3. Importing process information.

3. After the importing process, the IGES file that GiD has imported appears on the

screen.

T~ 111

]
L= ]
i

|

- < WA —

Figure 4. File “base.igs” imported by GiD.
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na NOTE: One of the operations in the
importing process is collapsing the model (Figure
3). We say that two entities collapse when, the
distance between them being less than the
Import Tolerance, they become one.

The Import Tolerance value may be modified by
going to the Utilities menu, opening
Preferences, and bringing up the Exchange
card. By default, the Automatic import
tolerance value is selected. With this option
selected, GiD computes an appropriate value for
the Import Tolerance based on the size of the
geometry.

Collapsing the model may also be done
manually. This option is  found in
Geometry>Edit> Collapse>Model.

% Preferences

QGraphical lMeshing Exchange lFDnt}

163

rlmport
V¥ Automatic collapse after import

¥ Automatic import tolerance value

Irmport tolerance: [0.0085039

Collapse:

& |gnating layers

= Each layer separately

W IGES: Curve on sudace from 30

rExport
v IGES: B-Rep output style

Beset Close

Figure 5. The Preferences window
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2. CORRECTING ERRORS IN THE IMPORTED GEOMETRY

The great diversity of versions, formats, and programs frequently results in differences (errors)
between the original and the imported geometry. With GiD these differences might give rise to
imperfect meshes or prevent meshing altogether. In this section we will see how to detect errors
in the imported geometry and how to correct them.

na NOTE: Importing the same file with different versions of GiD might produce slight
variations in the results. For this study we recommend using, from now on, the file
“‘imported48.gid”, which contains the original IGES file translated into GiD format.

2.1. Meshing by default

1. Select Mesh->Generate Mesh.

2. A window comes up in which to enter the maximum element size for the mesh to be

generated. Leave the default value provided by GiD unaltered and click OK.

3.  When the GIiD finishes the meshing process, an error message appears (see Figure
7). This error is due to a defect in the imported geometry. As the window shows, there

have been errors meshing surface number 124 and 149.

% MeshErrors

Sufaces l

2wrong surfaces

Mum  Description

Signal Close

Figure 6. Dialog window warning of an error found when meshing surface 124.
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4. In this part of the tutorial we focus on repairing surface number 124; the other surface
(number 149) can be corrected by following the same steps a second time. (It is

apparent that the two problems are similar because they are symmetrical surfaces.)

5. To locate surface 124, select the line “124 couldn’t map this point” in the dialog box
and press the Signal button (the same effect is obtained by double-clicking over the
message with the left mouse button).

ua NOTE: If user clicks the right button over a message in the Mesh Errors window, three
options are displayed: “Signal problematic point”’, “More help...” or “List...” The first option is
the same as the Signal button, while the “List...” option presents a list of the problematic
geometrical entities to make selection easier when performing some common procedures (like
sending the entities to a separate layer, erasing the entities, etc...). The “More help...” option
gives advice about to correct the geometrical model so the mesh can be generated.

ua NOTE: The Mesh Errors window can be recovered while dealing with the model by
selecting the “Show errors...” option in the Mesh menu.

Figure 7. Signaling the surface number 124.

ua NOTE: The identifiers of the entities vary each time the instruction Mesh->Generate
Mesh is executed.
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2.2. Correcting surfaces

1. With the View>Zoom=>In' option on the mouse menu, magnify the zone around
surface 124.

Figure 8. An enlargement of the zone around the surface 124.

2. Select Label>All from the contextual menu. On inspection we see a blur of numbers
due to a high concentration of entities at one end of the surface. Magnify this zone
even further (Figure 9).

' This option is also found in the GiD Toolbox.
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Figure 9. A second enlargement of the blurred zone

3. Several line segments are superimposed over each other, thus creating an incorrect
surface boundary. Select Geometry>Edit>Divide>Lines-> Near point and then
select point 17 (to select it, go to Contextual in the mouse menu, then select the
option Join C-a). Point 17 is the point at which to make the cut.

4. Then select line 2869. Press ESC. After the cut is made, the result will be as illustrated
in Figure 11.
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i

Figure 10. The zone after cutting line 2869 at point 17.

5. Now that the lines are precisely connected, a local collapse may be executed. Select
Geometry->Edit->Collapse->Lines. Then select the lines that appear on the screen.

Figure 11. The situation after collapsing the lines



GID USER MANUAL 169

6. After the collapse, the surface boundary is correct and the surface may be drawn with
the new boundary. The labels are no longer needed, so click Label>Off in the
contextual menu.

7. Select Geometry=>Create>NURBS surface>Trimmed. Select surface 124. Then
select the lines defining the recently repaired boundary. Press ESC.

Figure 12. Surface 123 with its new boundary.

8. Select Geometry->Delete->Surfaces. Select surface 124 and press ESC.

Figure 13. The surface to be eliminated.

9. Correct surface 149 by going through the same steps as with surface 124.
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10. To begin the second example in this section, mesh the geometry again with
Mesh->Generate Mesh.

11. A window comes up in which to enter the maximum element size for the mesh to be
generated. Leave the default value provided by GiD and click OK.

12. The mesh generating process may be carried out with no further errors found.

i Dialog window

E hesh Generated. Press 'OK' to see it

MNum. of Triangle elements=11932 ;l
Mum. of nodes=6187

Cancel

Figure 14. Window with information about the meshing process.

13. The imported piece is now meshed. (Figure 16)

Figure 15. A mesh of the imported geometry.
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3. THE CONFORMAL MESH AND THE NON CONFORMAL MESH

In the previous section, after correcting some errors, we were able to mesh the imported
geometry, thus obtaining a non-conformal mesh. A conformal mesh is one in which the
elements share nodes and sides. To achieve this condition, contiguous surfaces (of the piece)
must share lines and points of the mesh. Most calculating modules require conformal meshes;
however, some modules accept non-conformal meshes. A non-conformal mesh normally
requires less computation time since it generates fewer elements.

3.1. Global collapse of the model

1. The option Mesh->View mesh boundary shows the boundary of all the surfaces of
the conformal elements.

2. After generating the mesh, select Mesh->View mesh boundary. This will result in the
image pictured in Figure 17.

- I|" ' s
—_— ! . L"'—-JI H'\-u.
'\——._.__\_\_\____‘_\_—_ “M‘“-"-.H_‘
-—___\\i_- /
T

Figure 16. Visualization of the boundary of the generated mesh.

3. Visualization of the boundaries shows that in the interior of the piece some surfaces
are isolated.

4. To generate a conformal mesh, first execute a global collapse of the model.
5. The GiD collapse depends upon the Import tolerance. Two entities are collapsed
(converted into one) when they are separated by a distance less than the Import

tolerance parameter. To test this, enter a new value for the Import tolerance
parameter.
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W Preferences

Graphical | Meshing  Exchange lFDnt"
rlmport

¥ Automatic collapse after import

¥ Automaticimport tolerance walue

Importtolerance: |0.0088039

Collapse:
= Ignoring layers

" Each layer separately

¥ |IGES: Curve on sudace from 30

rExpont
¥ IGES: B-Rep output style

Beset Close

Figure 17. The Preferences window.

IMPORTING FILES

Go to Utilities, open Preferences, and bring up the Exchange card. Enter 0,15 for the
Import tolerance value. Click Accept.

Select Geometry—>Edit->Collapse>Model.
Select Mesh->Generate and then visualize the results with Mesh>View mesh

boundary.

—— |
_\_\-_-‘_"\—\_

Figure 18. The mesh after the collapse.
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9. Some of the contiguous surfaces in the interior of the model have now being joined.
However, there are still some surfaces that prevent the mesh from being completely
conformal. These surfaces must be modified manually.

3.2. Correcting surfaces and creating a conformal mesh

1. With the option View->Zoom->In, magnify the zone illustrated in Figure 20.

[\RHH
"—\—\_\_\_\_\_\-‘_—_
/ il [ RR‘H“HHEH
\ '“*—-__,__;
———_—"“H-—-,_,_____q___

Figure 19. Zone in the mesh to zoom in.

2. Select View->Mode->Geometry to visualize the geometry of the piece.

Figure 20

3. An image like that shown in Figure 21 appears. There is a rectangular surface that
does not fit within the boundaries of a rounded-corner surface (a hole, in this case). We
will suppose that the problematic surface is planar. This way, it can be erased and
recreated in order to fit the rounded-corner boundary.
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4. Select Geometry->Delete->Surfaces. Select the problematic surface and press ESC.
Select Geometry->Delete>Lines. Select the lines forming the problematic surface
and press ESC?.

5. Use the option Geometry—->Delete>Points to erase the points that do not belong to
any surface.

6. With Geometry—>Create>NURBS surface>By contour, create a new surface. The
result is shown in Figure 22.

Figure 21

7. Visualize the mesh again using Mesh->View mesh boundary and magnify the zone
indicated in Figure 23.

/\“‘“:aa

""——..,_\_‘_\_\___\-‘_—_
h_—_\""—\—..\_\_\_h
/ 1/ e
\ _\-H-‘"——\.e'\—\_;
______HHH ;
—
Figure 22

8. Select View->Mode->Geometry.

9. In this example, the situation involves a contour of four lines that does not correspond
to any real surface (of the piece). These lines were too far apart to be collapsed
(Figure 24).

2 In this case, all the visible lines may be selected since the program will only eliminate those which do not
have entities covering them, that is, those which belong to the problematic vertices.
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Figure 23
10. Select Geometry>Create>NURBS surface>By contour. Select the lines. Press
ESC.

11. Magnify the zone indicated in Figure 25.

A EN

“'——\..._\_L_____H
/ . H‘"“‘"-ﬁ.h
K f -\_\“‘-—-\""\-\.__‘_
e
\ ;
_______‘Hi j
Figure 24

12. There are two surfaces that overlap each other at one end. (Figure 26)
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Figure 25. The magnified zone with two overlapping surfaces.

13. In this case the best solution for correcting the boundary is to trim the overlap. Select
Geometry-> Create>NURBS Surface-> Trimmed.

14. Select the surface to be trimmed. Then select the new boundary (Figure 27).

Figure 26. The surface to be trimmed and the new boundary.

15. Select Geometry>Delete>Surfaces. Select the original surface (Figure 28). Press
ESC.
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Figure 27. The original surface to be deleted.

16. Use Geometry->Delete>Lines and Geometry->Delete>Points to select the lines
and points that belong to the surface that has been trimmed and which no longer
belong to any surface (Figure 29).

Figure 28. Lines and point that no longer belong to any surface.



178 IMPORTING FILES

17. Select Mesh->Generate Mesh. Then visualize the result using the option
Mesh->View mesh boundary.

——
Y Ty
]
!

—— |
_\_\-_-‘_"\—\_

Figure 29. The mesh visualized with the option Mesh2View mesh boundary.

18. A conformal mesh has been achieved.
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3.3. Creating a non-conformal mesh

Im NOTE: Non-conformal meshes may be used with some calculating modules, i.e.
stamping a plate. Using non-conformal meshes significantly reduces the number of
elements in the mesh. This cuts down on computation time.

1. Select View>Mode->Geometry.

2. Select Geometry>Edit>Uncollapse->Surfaces. Select all the surfaces in the model.
Press ESC. A sufficient number of lines is created so that no surface (of the object)
shares lines with any contiguous surface.

3. Select Mesh->Generate Mesh. When the mesh has been generated, a window
appears with information about the mesh (Figure 31). The result is a non-conformal
mesh composed of far fewer elements than the meshes generated in the previous
section: about 5000 elements instead of the 20.000 needed to generate the conformal
mesh.

@ Dialog window

i Mesh Generated. Press 'OK'to see it

Murn. of Triangle elements=4286 =
Murn. of nodes=4066

Cancel

Figure 30. A window containing information about the generated mesh.

4. Visualize the result using Mesh->View mesh boundary.

Figure 31. The mesh visualized using Mesh 2>View mesh boundary.
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3.4. Optimizing a non-conformal mesh

na NOTE: By using Chordal Error, the geometry may be discretized with great
precision. The chordal error is the distance between the elements generated by the
meshing program and the profile of the real object. Entering a sufficiently small chordal
error results in small elements in zones where there is greater curvature. Accordingly, the
approximation of the mesh may be improved in zones with greater curvature by using the
option “Chordal Error.”

“Chordal Error” generates an increased number of elements in zones where there is
curvature. One way of obtaining accurate meshes with few elements is using structured
elements in zones where there is curvature. The option Allow automatic structured,
located in Preferences, may be combined with the option of limiting the chordal error, thus
achieving an accurate mesh with fewer elements. It only makes sense to use Allow
automatic structured when working with a non-conformal mesh.

na NOTE: The option Allow automatic structured generates highly distorted elements
that might, with some calculating modules, lead to erroneous results. In the case of
stamping a plate, we recommend using Allow automatic structured with the calculating
modules.

1. Open Utilities=> Preferences.

2. On the Meshing card, activate the option Allow automatic structured and enter the
value of 0,9 in the box labeled Unstructured size transitions. Click Accept. The
option Unstructured size transitions defines the size gradient of the elements (the
value ranging from 0 to 1). The greater the value, the faster the variation of the element
sizes in space and so there will be fewer elements in the mesh.
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Preferences

General | Graphical Meshing | Exchange | Fonts | P
Surface mesher
’V @ RFast ¢ RSuf C RJump

rAutomatic correct size
© MNone & MNommal € Hard

rUnstructured size transition

slower

rStructured mesh
v Allow automatic structured

¥ Syrnmetrical structured tiangles

W Syrmmetrical structured tetrahedra,

rOther

Smocothing:  |Normal h

IV Mesh until end

v Mo mesh frozen layers
Mesh ahways by default: j M ﬁ

Fieset Close

Figure 32. The Preferences window.

3. Select Mesh>Unstructured-> Sizes by Chordal error and set the values as shown in
Figure 34.

Assign sizes by chordal error H

Chardal Eerrj'D_D'ﬁi

baxirmum meshing size:|15

inimurm meshing size:|D.1| *
Qi Cancel w

Figure 33. Defining unstructured size by chordal error.

4. Select Mesh->Generate Mesh.
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Once the process of generating the mesh is finished, a window appears with

5. A window comes up in which to enter the maximum element size. Leave the default
value unaltered and click OK.
information about the generated mesh. Click OK to visualize the mesh.

6.
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Figure 34. An optimized non-conformal mesh. Structured elements
are present on the curved surfaces.
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GiD PROBLEM TYPE: AN EXAMPLE

DEFINING A PROBLEM TYPE

This chapter takes you through the steps involved in defining a problem type using GiD. A
problem type is a set of files configured by GiD so that the program can prepare data to be
analyzed.

A simple example has been chosen which takes us through all the associated configuration files
while using few lines of code. Particular emphasis is given to the calculation of the centers of
mass for two-dimensional surfaces — a simple formulation both conceptually and numerically.

The tutorial is composed of the following steps:

e  Starting the problem

e Creating the materials definition file

e Creating the general configurations file

e Creating the conditions definition file

e Creating the data format file

e Creating the calculating program file and the execution files

e  Executing the calculating module and visualizing the results using GiD
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By the end of the example, you should be able to create a calculating module that will interpret
the mesh generated in GiD Preprocess. The module will calculate values for each element of
the mesh and store the values in a file in such a way as they can be read by GiD Post-process.
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1. INTRODUCTION

Our aim is to solve a problem that involves calculating the center of gravity (center of mass) of a
2D object. To do this, we need to develop a calculating module that can interact with GiD.

1.1. The problem: center of mass

The center of mass (xcm,ycm) of a two-dimensional body is defined as

:”Sp(x,y).x-ax-ay y =”sp(x,y)'y~8x-8y
I WC RS O] e py-ax-ay

X

where p(x,y) is the density of the material at point (x,y) and S is the surface of the body.

If we consider the N gravitational forces as p; =g m;, each one concentrated on point (x;y;), the
new center of mass will be modified as follows:

_Usp-x-ax-ﬁy+ﬁ:mi-xi _jjsp-y-ﬁx-6y+izji:m[-yi

- N Yem = N
J-'Lp-éx-fiy+2mi ”Sp'ﬁx-éy+2mi
i=1 i=1

Xem

To solve the problem numerically, the integrals will be transformed into sums:

N
ZpelmVelm.ydm +zmi .yi
_ elm i=1

N
z pe]m Velm ) xelm + zmi ) xi
_ elm i=1
- N
20,V ant 2
elm elm !
elm i=1

N
z pelm V‘-’l’" + Zl i
i=

elm

Xem Yem

Each of the N elements is treated as concentrated weight whose mass N1 is defined as the
product of the (surface) density and the surface of the element.
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1.2. Interaction of GiD with the calculating module

GiD Preprocess makes a discretization of the object under study and generates a mesh of
elements, each one of which is assigned a material and some conditions. This preprocessing
information in GiD (mesh, materials, and conditions) enables the calculating module to generate
results. For the present example, the calculating module will find the distance of each element
relative to the center of mass of the object.

Finally, the results generated by the calculating module will be read and visualized in GiD Post-

process.

GiD

Preprocess

Postprocess

P SOLVER

INPUT

FILE

]

OUTPUT
FILE
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GiD must adapt these data to deal with them. Materials, boundary and/or load conditions, and
problem data in general must be defined.

GiD configuration is accomplished through text formatted files. The following files are required:

a) .prb: configuration of the general parameter
.mat: configuration of materials and their properties
.cnd: configuration of the conditions imposed on the calculation

b) .bas: (template file) the file for configuring the format of the interchange that mediates
between GiD data and the calculating module. The file for interchanging the data
exported by GiD has the extension .dat. This file stores the geometric and physical
data of the problem.

c) .bat: the file that can be executed in batches called from GiD. This file initiates the
calculating module.

The calculating module (in this example cmas2d.exe) solves the equations in the problem and
saves the results in the results file. This module may be programmed in the language of your
choice.
GiD Post-process reads the following files generated by the calculating module:
a) project_name.flavia.res: results file.

Each element of the mesh corresponds to a value.
b) project_name.flavia.msh: file containing the post-process 2D mesh.

If this file does not exist, GiD uses the preprocess mesh in the postprocess.
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Diagram depicting the files system:

cnd

Praprocass GiD

project_name.dat

Results file

project_name flavia.res

Postprocess

mesh file
(new format)

profect_name. flavia, msh

Postprocess mesh files (old format)

3D N 2D

project_name flavis bon
N

project_name flavia.dat

project_name flavia.msh

Postprocess GID

187
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2. IMPLEMENTATION

2.1. Creating the Subdirectory for the Problem Type

Create the subdirectory "cmas2d.gid". This subdirectory has a .gid extension and will contain all
the configuration files and calculating module files (.prb, .mat, .cnd, .bas, .bat, .exe).

na NOTE: In Windows systems, if you want the problem type to appear in the GiD
Data->Problem type menu, create the subdirectory within "Problemtypes”, located in the GiD
folder — for instance, C:\GiDWin\Problemtypes\cmas2d.gid
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2.2. Creating the Materials File

1. Create the materials file "cmas2d.mat". This file stores the physical properties of the
material under study for the problem type. In this case, defining the density will be
sufficient.

2. Enter the materials in the "cmas2d.mat" file using the following format:

MATERIAL: Name of the material (without spaces)
QUESTION: Property of the material. For this example, we are
interested in the density of the material.
VALUE: Value of the property

END MATERIAL

3. In GiD, the information pertaining to the "cmas2d.mat" file is managed in the materials
window (Figure 1), located in Data->Materials.

cmas2d.mat a |
MATERIAL: Air bi[l Materials §|

QUESTION: Density

1. Iy -
e L i EOXa
Densit_l,lh.l:ﬂ

MATERIAL: Steel
QUESTION: Density
VALUE: 7850

END MATERIAL

Agzign | Draw | Unazszign | |mpu:urt.-"E:-cpu:urt|

MATERIAL: Concrete

QUESTION: Density Cloze
VALUE: 2350 -

END MATERIAL

Figure 1. The GiD Materials window, for assigning
materials
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2.3. Creating the General File

1. Create the "cmas2d.prb" file. This file contains general information for the calculating
module, such as the units system for the problem, or the type of resolution algorithm
chosen.

2. Enter the parameters of the general conditions in "cmas2d.prb" using the following
format:

PROBLEM DATA

QUESTION: Name of the parameter. If the name is followed by the #CB#
instruction, the parameter is a display-type menu. The options in the menu
must then be entered between parentheses and separated by commas.
For example, Unit System#CB# (SI,CGS,User) .

VALUE: The default value of the parameter.

END GENERAL DATA

3. In GiD, the information in the "cmas2d.prb" file is managed in the materials window
(Figure 2), which is located in Data->Problem Data.

Cmas2d.prb (il Problem Data E|

PROBLEM DATA @
QUESTION: _
Unit System#CB# (SI,CGS,User) rit System 51 —

VALUE: ST . :
QUESTION: Title Title | Default_tite

VALUE: Default title
END GENERAL DATA

Figure 2. The GiD Problem Data window, for
configuring of the general conditions of the cmas2d
module
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2.4. Creating the Conditions File

1. Create the "cmas2d.cnd" file, which specifies the boundary and/or load conditions of
the problem type in question. In the present case, this file is where the concentrated
weights on specific points of the geometry are indicated.

2. Enter the boundary conditions using the following format:

CONDITION: Name of the condition
CONDTYPE: Type of entity to which the condition is to be applied. This
includes the parameters "over points," "over lines," "over surfaces," and "over
volumes". In this example the condition is applied "over points."
CONDMESHTYPE: Type of entity of the mesh to which the condition is to be
applied. The possible parameters are "over nodes", "over body elements" or
“over face elements”. In this example, the condition is applied on nodes.
QUESTION: Name of the parameter of the condition
VALUE: Default value of the parameter

END CONDITION

3. In GiD, the information in the "cmas2d.cnd" file is managed in the conditions window
(Figure 3), which is found in Data—> Conditions.

cmas2d.cnd li[l Conditions

CONDITION: Point-Weight Y

CONDTYPE: over points . . J
CONDMESHTYPE: over nodes Point-w/eight M

QUESTION: Weight
VALUE: 0 EUE@htD

END CONDITION

| Entities | Dirava | Unaz=zign |

Cloze

Figure 3. The GiD Conditions window, for
assigning the cmas2d boundary and load conditions
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2.5. Creating the Data Format File (Template file)

1. Create the "cmas2d.bas" file. This file will define the format of the .dat text file created
by GiD. It will store the geometric and physical data of the problem. The .dat file will be

the input to the calculating module.

na NOTE: It is not necessary to have all the information registered in only one .bas file. Each

.bas file has a corresponding .dat file.
Write the "cmas2d.bas" file as follows:

2. The format of the .bas file is based on commands. Text not preceded by an asterisk is
reproduced exactly the same in the .dat file created by GiD. A text preceded by an

asterisk is interpreted as a command.

Example:

.bas file .dat file

%$%%% Problem Size $%%% %$%%% Problem Size $%%%
Number of Elements & Nodes: 9 Number of Elements & Nodes:
*nelem *npoin 5379 4678

The contents of the "cmas2d.bas" file must be the following:

.bas file

General Data File

*nelem *npoin

In this first part of the "cmas2d.bas" file, general information on the project is obtained.

*nelem: returns the total number of elements of the mesh.
*npoin: returns the total number of nodes of the mesh.

Coordinates:
Node X Y
*set elems (all)
*loop nodes
*format "%$51%14.5e%14.5e"
*NodesNum *NodesCoord(l,real) *NodesCoord(2,real)
*end nodes
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This command provides a rundown of all the nodes of the mesh, listing their identifiers and
coordinates.

*loop, *end: commands used to indicate the beginning and the end of the loop. The command
*loop receives a parameter.

*loop nodes: the loop iterates on nodes
*loop elems: the loop iterates on elements
*loop materials: the loop iterates on assigned materials

*set elems(all): the command to include all the elements of the mesh when making the loop.

*format: the command to define the exit format for numerical expressions. This command must
be followed by the numerical format expressed in C.

*NodesNum: returns the identifier of the present node

*NodesCoord: returns the coordinates of the present node

*NodesCoord (n, real): returns the x, y or z coordinate in terms of the value n:
n=1 returns the x coordinate
n=2 returns the y coordinate
n=3 returns the z coordinate

Connectivities:
Element Node (1) Node (2) Node (3) Material
*loop elems
*format "$101%101%$101%101%1041i"
*ElemsNum *ElemsConec *ElemsMat
*end elems
This provides a rundown of all the elements of the mesh and a list of their identifiers, the nodes
that form them, and their assigned material.

*ElemsNum: returns the identifier of the present element
*ElemsConec: returns the nodes of an element in a counterclockwise order

*ElemsMat: returns the number of the assigned material of the present element

Begin Materials
N° Materials= *nmats

This gives the total number of materials in the project

*nmats: returns the total number of materials
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Mat. Density

*loop materials

*format "%$41%13.5e"

*set var PROPI1 (real)=Operation (MatProp (Density, real))
*MatNum *PROP1

*end

This provides a rundown of all the materials in the project and a list of the identifiers and
densities for each one.

*MatProp (density, real): returns the value of the property "density" of the material in a "real"
format.

*Operation (expression): returns the result of an arithmetic expression. This operation must be
expressed in C.

*Set var PROP1(real)=Operation(MatProp(Density, real)): assigns the value returned by
MatProp (which is the value of the density of the material) to the variable PROP1 (a "real"
variable).

*PROP1: returns the value of the variable PROP1.

*MatNum: returns the identifier of the present material

Point conditions

*Set Cond Point-Weight *nodes

*set var NFIX (int)=CondNumEntities (int)
Concentrate Weights

*NEFIX

This provides the number of entities that have been assigned a particular condition.

*Set Cond Point-Weight *nodes: this command enables you to select the condition to work with
from that moment on. For the present example, select the condition "Point-Weight".

*CondNumEntities(int): returns the number of entities that have been assigned a certain
condition.

*Set var NFIX(int)= CondNumEntities(int): assigns the value returned by the command
CondNumeEntities to the NFIX variable (an "int" variable).

*NFIX: returns the value of the NFIX variable.
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Potentials Prescrits:

Node Tipus

Valor/Etiqueta
*Set Cond Point-Weight *nodes
*loop nodes *OnlyInCond
*NodesNum *cond (1)
*end

This provides a rundown of all the nodes assigned the condition "Point-Weight" with a list of
their identifiers and the first "weight" field of the condition in each case.

*loop nodes *OnlylnCond: executes a loop that will provide a rundown of only the nodes that
have been assigned a condition.

*cond(1): returns the number 1 field of a condition previously selected with the *set cond
command. The field of the condition may also be selected using the name of the condition, for

example cond(weight).
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cmas2d.bas

General Data File

*nelem *npoin
$%%%%%%%%%%%%%%%%%% Mesh Database $%%%%%5%%5%%5%%5%%5%5%5%5%5%%5%%5%5%%%%%%%%
Coordinates:

Node X Y

*set elems (all)
*loop nodes
*format "%51%14.5e%14.5e"
*NodesNum *NodesCoord(l,real) *NodesCoord(2,real)
*end nodes
Connectivities:
Element Node (1) Node (2) Node (3) Material

*loop elems
*format "%101%10i%101%10i%10i"
*ElemsNum *ElemsConec *ElemsMat
*end elems
Begin Materials
N° Materials= *nmats
Mat. Density
*loop materials
*format "%41%13.5e"
*set var PROP1 (real)=Operation (MatProp (Density, real))
*MatNum *PROP1
*end
Point conditions
*Set Cond Point-Weight *nodes
*set var NFIX (int)=CondNumEntities (int)
Concentrate Weights
*NEFIX
Potentials Prescrits:

Node Tipus

Valor/Etiqueta
*Set Cond Point-Weight *nodes
*loop nodes *OnlyInCond
*NodesNum *cond (1)
*end
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2.6. Creating the Execution file of the Calculating Module

1. Create the file "cmas2d.c". This file contains the code for the execution program of the
calculating module. This execution program reads the problem data provided by GiD,
calculates the coordinates of the center of mass of the object and the distance
between each element and this point. These results are saved in a text file with the

extension .flavia.res.

2. Compile and link the "cmas2d.c" file in order to obtain the executable cmas2d.exe file.

The calculating module (cmas2d.exe) reads and generates the files described below.

cmasZd.exe

project_name.dat

[ I

o

READS the .dat file

This file stores the geometric and
phiysical data of the preblem.

CREATES the flavia.res file

This file is the results file. It contains
the distance of each element
relative to the center of masses of the

preject_nameflavia.res object. This file will be used

[ I

i

by the GiD posiprocess.

CREATES the flavia dat file

Thig file contains the postprocess 20
mesh. If this file does not
exist, GiD uses the preprocess mesh in

project_nameflavia.dat the postprocess.

.-

-

project_name boh

B,

[

project_name.err

CREATES the .boh file
The koh file contains the exact

coordinates of the center of
masses. Thig file is not used by GiD.

CREATES the .err file

This file is created only if an error
OCCUrES,

Lw NOTE: The "cmas2d.c" code is explained in the appendix.
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2.7. Creating the Execution File for the Problem Type

Create the "cmas2d.bat" file. This file connects the data file(s) (.dat) to the calculating module
(the cmas2d.exe program). When the GiD Calculate option is selected, it executes the .bat file
for the problem type selected.

When GiD executes the .bat file, it transfers three parameters in the following way:
(parameter 3) / *.bat (parameter 2) / (parameter 1)

parameter 1: project name
parameter 2: project directory

parameter 3: Problem type location directory

Im NOTE: The .bat file as used in Windows is explained below.

del %2\%1.boh
del %2\%1.flavia.res
del %2\%1l.flavia.dat

This deletes results files from any previous calculations to avoid confusion.

rem OutputFile: $2/$1.boh

A comment line such as "rem OutputFile: file name.log" means that the contents of
the file indicated will be shown if the user clicks Output View in Calculate >Calculate window
(Figure 4).

In this example the .boh file is shown. This file contains the coordinates of the center of mass.

Bil Process window E|
Project  Starttime  UID

[=
< f

Output view | kil |

Figure 4. The Process window.

Skart remote| Remate... | Clage |
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rem ErrorFile: $2/$1l.err

A comment line such as "rem ErrorFile: file name.err" means that the indicated file
will contain the errors (if any). If the .err file is present at the end of the execution, a window
comes up showing the error. The absence of the .err file indicates that the calculation is
considered satisfactory.

GiD automatically deletes the .err files before initiating a calculation to avoid confusion.

$3/cmas2d.exe $2/51

Executing the cmasZ2d.exe file.

cmas2d.bat

@ECHO OFF

del %2\%1.boh

del %2\%1l.flavia.res

del %2\%1.flavia.dat

rem OutputFile: %2\%1.boh
rem ErrorFile: %2\%l.err
%3\cmas2d.exe %2\%1
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3. EXECUTING THE CALCULATING MODULE

In order to more easily understand the way the calculating module works, simple problems with
limited practical use have been chosen. Although these problems do not exemplify the full
potential of the GiD program, the user may intuit their answers and, therefore, compare the
predicted results with those obtained in the simulations.

3.1. Executing the calculation for an object made of homogeneous material

1. From the Files menu, select Read. Select the file “ToMesh2d.gid” and click Open.

D:

Figure 5. Contents of the "ToMesh2d.gid" file.

2. Choose the option Data>Problem type->Cmas2d.

3. Choose Data->Materials. The materials window is opened (Figure 6). From the
Materials menu in this window, choose the option Air.
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Gl Materials [E|
i | BOKD
Denzity |1.01

Az=ign | Diraw | Unagzign | Imp-:urts'E:-:pu:urt|

Cloze

Figure 6. The Materials window

4. Click Assign>Surfaces and select all the surfaces. Press ESC when this step is
finished.
5. Choose the Mesh->Generate option.

6. A window appears in which to enter the maximum element size for the mesh to be
generated. Enter 2 and click OK. The mesh shown in Figure 7 will be obtained.

at iy
S
e

v

Figure 7. The mesh of the object

7. Now the calculation may be initiated. Choose the Calculate option from the Calculate
menu, thus executing the calculating module.

8. Wait until a box appears indicating that the calculation has finished (Figure 8).
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§ill Process info [x]

Process "ToMesh2D' started at
Mon Oct 24 12:41:31 has finished.

Poztprocess

Figure 8. Process information box

AT

Choose the option Files>Postprocess.

10. From the Windows menu, choose the View Results option (Figure 9). A window
appears from which to visualize the results. By default, no result is visualized on
entering the postprocessing component.

11. From the View combo box in the View Results window, choose the Contour Fill
option. A set of available result are displayed.

Gilll View Results & Deformation E| (il View Results & Deformation E|
View results l tain Mesh I Reference mesh ] Wiew results ] Main Mesh ] Reference mesh ]
Wiew. Mo Resul | Step: Wiew: |Contour Fil | Step
Analysis: [LOAD ANALYSIS | |1 [~ Analysis: [LOAD ANALYSIS =] [1 ~]

el 1 C-DIS TANCE

‘ —  <Moresult is dravns

et factaor: Ii

Apply Cloze Aply Close

Figure 9. The View Results window .

12. Now choose the MC-DISTANCE result and click Apply. A graphic representation of
the calculation is obtained (see Figure 10).
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Figure 10. Visualizing the distance (MC-DISTANCE) from the center of mass of the object
to each element, for an object of homogeneous material

13. The results shown on the screen reproduce those we anticipated at the outset of the
problem: the center of mass of an object made of homogeneous material coincides
with its geometric center. The .boh file will provide the exact coordinates of this point.
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3.2. Executing the calculation for an object made of heterogeneous material

1. Choose the Files>preprocess option.

2. Choose the Data>Materials option. The Materials window is opened. From the
Materials menu in this window, choose Steel (Figure 11).

‘Steel j ‘-@ 6 ﬁ @
Drenzity | 7850

Agzign ‘ Ciraw | nazzign | |I'I'||JD[L-"EH|JDI[|

LCloze

Figure 11. The Materials window, with "Steel" selected

3. Click Assign>Surfaces and select the surface indicated in Figure 12. Press ESC
when this step is finished.

D:

Figure 12 Assigning the material "Steel" to the surface indicated

4. Choose the Mesh->Generate option.
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5. A window appears in which to enter the maximum element size for the mesh to be
generated. Enter 2 and click OK.

6. Choose the Calculate option from the Calculate menu, thus executing the calculating
module.

7. Choose the Files>Postprocess option.
8. Visualize the new results.

O air
[ ] steel
Figure 13. Visualizing the materials Figure 14. Visualizing the distance (MC-
making up the object DISTANCE) from the center of mass of the object
to each element, for an object of heterogeneous
material

9. As anticipated, the center of mass is displaced toward the material with greater
density.
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3.3. Executing the calculation for an object of heterogeneous material and subject to
external point- weight

1. Choose the Files=>preprocess option.

2. Choose the Data->Conditions option. A window is opened in which the conditions of
the problem should be entered (Figure 15).

3. Since the condition to be entered acts over points, select over points from the Type
menu in the Conditions window.

bill Conditions

- ]
Piirit-wsight ~
‘weight |Sef]

gssign| Entitizz ‘ Diraw | Uhazsign |

LCloze

Figure 15. The Conditions window

4. Enter the value 5e6 in the Weight box. Click Assign and select the point indicated in
Figure 16. Press ESC when this step is finished.

_IFes

RN

Figure 16. The point subject to external weight

5. Choose Mesh>Generate mesh.



GID USER MANUAL 207

6. A window appears in which to enter the maximum element size for the mesh to be
generated. Enter 2 and click OK.

7. Choose the Calculate option from the Calculate menu, thus executing the calculating
module.

8. Choose the Files>Postprocess option.
9. Visualize the new results.

Figure 17. Visualizing the distance (MC-DISTANCE) from the center of mass to each element,
for an object of heterogeneous material subject to point weight

10. Now the condition is external point-weight. As anticipated, the new center of mass is
displaced toward the point under weight.



208 DEFINING A PROBLEM TYPE

4. APPENDIX

4.1. The program code for the calculating module

1. The structure of the program that calculates the center of mass (cmas2d.c) is the

following:

L 2 READS the .dat file
coordinates —+ =[], ¥I[]
conectvibes +H[] []

= . densities —+ rha []
Project nameaat  oocditions — nodz [1
condition value —+wval [1
void input (}
CREATES the e file
This file is ereated only if an efror coours:
- out of memarny
~ _ - element with no materia
praject_name.en
CALCULATION
main woid calculate () of the
CENTER of MASSESS
T, CREATES the .boh file
t contains the exact coordinates
- of the center of masses.
preject_name. toh
b, CREATES the flavia.dat file
void outout () .~ ;B iﬂt’;::ar':al ns the postprocess
projest_name.favia dat
I CREATES the flavia.res file
't contains the distance of each
elament relative to the center of
e masses of the ohject.
project_name.flavia.res

ma NOTE: In this example, a code for the program will be developed in C. Nevertheless,
any language of choice may be used.
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2. The code of the program that calculates the center of mass (cmas2d.c) is as follows:

The cmas2d.c file
#include <stdio.h>
#include <stdlib.h>
#include <fentl.h>
#include <string.h>
#include <math.h>

#define MAXMAT 10000
#define MAXCND 10000

char projname[1024];

int i, ielem, inod, icnd;

double *x, *y

int *N, *imat;

int nodc[MAXCND];

double rho[MAXMAT], wval[MAXCND];
int Nelem, Nnod, Nmat, Ncnd;
double x CG, y CG

void input (void);
void calculate (void) ;
void output (void) ;

Declaration of variables and constants used in the program.

void main (int argc, char *argvl[])
{
void input (void);
void calculate (void) ;
void output (void) ;

strcpy (projname, argv([l]);
input () ;

calculate () ;

output () ;

The main program.
The main program is called from the cmas2d.bat file and has as its parameters the name of the
project. This name is stored in the projname’ variable.

The main program calls the input (), calculate () and output () functions.
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The input function reads the .dat file generated by GiD. The .dat file contains information about
the mesh. The calculate function read and processes the data and generates the results. The
output function creates the results files.

void input ()
{
char filedat[1024], saul[1024], sau2([1024];
FILE* fp;
Int aux,Jj;

Void jumpline (FILEY*);
Strcpy (filedat, projname);

Strcat (filedat,".dat");
fp = fopen(filedat, "r");

The input() function.

The first part of the input function links the project name with the .dat extension, thus obtaining
the name of the file that is to be read. This file is opened in order to be read.

The jumpline(FILE*) function is declared. This function reads 80 bytes of the file that it
receives as a parameter. It will also be used to jump lines of the text when reading the .dat file.

for (i=0; 1i<6; i++)
jumpline (fp);
fscanf (fp, "%d %d", &Nelem, &Nnod);

The first six lines of the .dat file are jumped over since these are lines of information for the user
(see .bas file). Then the total number of elements and nodes of the project are read and stored
in the variables Nelem and Nnod respectively.

x=(double *) malloc((Nnod+1l) *sizeof (double)); if (x==NULL) {error=1;}
y=(double *) malloc((Nnod+1l)*sizeof (double)); if (y==NULL) {error=1l;}
N= (int *) malloc((Nelem+l)*3*sizeof (int)); if (N==NULL) {error=1l;}
imat=(int *) malloc((Nelem+1l) *sizeof (int)); if (N==NULL) {error=1;}

if (error)
{
strcpy (fileerr, projname);
strcat (fileerr,".err");
ferr = fopen(fileerr, "w");
fprintf (ferr, "\n \n \n ***** ERROR: Not enough memory. ***** \n");
fprintf (ferr, " (Try to calculate with less elements)\n");
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exit (1) ;
}

for (i=0; 1i<6; i++)
jumpline (fp);

Space is reserved for storing the coordinates of the nodes (pointers %, y), the connectivities
(pointer N), and the materials corresponding to each element (pointer imat).

In case of error (insufficient memory), a file is created with the extension .err. This file contains
information about the error and the program is aborted.

The next six lines are jumped over.

/* reading the coordinates */
for (inod=1; inod<=Nnod; inod++)
fscanf (fp, "%d %$1f %$1f", &aux, &x[inod], &ylinod]);

for (i=0; 1i<6; 1i++)
jumpline (fp);

The coordinates of the nodes are read and stored in the x and y variables. The node identifier
indexes the tables of coordinates.

/* reading connectivities */
for (ielem=1; ielem<=Nelem; ielem++) {
fscanf (fp, "%d", &aux);
for (j=0;3<3;j++) fscanf (fp, "%d", &N[ (ielem-1)*3+3]);
fscanf (fp, "%d", &imat[ielem]);
if (imat[ielem]==0)
{strcpy(fileerr, projname);
strcat (fileerr,".err");

ferr = fopen(fileerr, "w");
fprintf (ferr,"\n \n \n **ERROR: Elements with no material!!**\n");
exit (1) ;

}

The connectivities are read and the N variable is saved. This variable is a Nelem x 3- size
table with two fields. The nodes (3 nodes) forming the element are saved in the first field. The
element identifiers are saved in the second.

All the elements are checked, ensuring that they have been assigned a material. If the identifier
of the material is 0 (meaning that no material has been assigned to the element), an .err file is
created containing information about the error and the program is aborted.
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/* reading density of each material */

for (i=0; 1i<5; i++)

jumpline (fp);
fscanf (fp, "%s %s %d",saul, sau2, &Nmat );
for (i=0; 1<3; i++)

jumpline (fp);

&wval[icnd]);

for (i=1; i1<=Nmat; i++)
fscanf (fp, "%d %$1f", &aux, &rho[i]);
for (i=0; 1i<4; i++)
jumpline (fp);
/* reading conditions*/
fscanf (fp, "%d", &Ncnd);
for (i=0; i<6; i++)
jumpline (fp);
for (icnd=1; icnd<=Ncnd; icnd++)
{
fscanf (fp, "%d $1f", &nodclicnd],
jumpline (fp);
}
fclose (fp);

Reading the remaining information in the .dat file.

The total number of materials is read and stored in the Nmat variable.
The density of each material are read and stored in the rho table. The material identifier

indexes the densities.

The total number of conditions is read and stored in the Ncnd variable.

The nodes associated with a condition are read and stored in the nodc table indexed by the
condition identifier. The value of the condition is stored in wval, another table indexed by the

condition identifier.
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void calculate ()
{
double v,auxl,aux2,aux3;
int nl, n2, n3;
int mat;
double x CGi, y CGi;
double x num=0, y num=0, den=0;

The calculate() function. This is the function that calculates the center of mass.
Declaration of the local variables used in calculate().

for (ielem=1; ielem<=Nelem; ielem++)
{
nl= N[0+ (ielem-1)*3];
n2= N[1+(ielem-1)*3];
n3= N[2+(ielem-1) *3];

/* Calculating the volume (volume is the area, provided we
are dealing with 3D surfaces) */

v=fabs (x[nl]l*y[n2]+x[n2]*y[n3]1+x[n3]*y[nl]l-x[nl]l*y[n3]-x[n2]*y[nl]-
x[n3]1*y[n2])/2;
/* The geometric center of the element is calculated */

x CGi= (x[nl]+x[n2]+x[n3])/3;
y_CGi= (y[nll+y[n2]+y[n31)/3;

/* sums are calculated*/
mat= imat[ielem];

x_num+= rho[mat]*v*x CGi;
y_num+= rho[mat]*v*y CGi;

den+= rho[mat]*v;

}

Main loop of the calculating function.
The identifiers of the nodes of the present element are saved in n1, n2, n3.
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This loop makes a rundown of all the elements in the mesh. The volume is calculated for each
element. (Here, the volume is the area, provided we are dealing with 3D surfaces.) The volume

calculations are stored in the ~ variable.

The geometric center of the element is calculated (coinciding with the center of gravity) and the

coordinates are stored in the x_Cgi and y Cgi variables.
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The numerator sums are calculated. When the loop is finished, the following sums are stored in
the x_num and y num variables:

x_num= Z pelm Velm ) x@l’”

elm

y_num = Zpelm Velm *Veim
elm
The denominator sum is calculated. When the loop is finished, the following sum is stored in the

den variable:
den = Z pe]m Velm
elm

/* point weights */
for (icnd=1; icnd<=Ncnd; icnd++)
{
inod= nodc[icnd];
x_num+t= wval[icnd]*x[inod];
y_num+= wval[icnd]*y[inod];

den+= wval[icnd];
}
Then, the calculations associated with point-weights are run using a loop that makes a rundown

of all the conditions.

The results are added to the x_num, y num, and den variables, as seen in the formulae:

N

= . + X

x_num lzpe[m Velm X i Zlml X;
elm i=

N
y_num = Zpelm Velm “Veim T Zmi Vi
=1

elm i

The value of point-weights is added to the variable den .

N

— + .

den Z pelm Velm z ml
elm i=1
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x_CG= (x_num/den);
y CG= (y num/den);

}

Finally, the result of dividing the x_num and y num variables by the den variable is stored in

the x CG and y CG variables.
N

Z pelm Velm ’ x@l’" + Zmi ) xi

elm i=l1

x_CG = (x_num/den) = x _CG= ~
Zpdm Velm + Zmi
elm i=1
N
ZpelmVelm.yelm +Zmi i
y_CG =(y_num/den) > y CG= 4 =l

N
Zpelm Velm + Zm[
elm i=1

void output ()
{
char filedat[80];
FILE *fp, *fptest;
float raiz;
double pot;

The output() function.
The output() function creates three files: .flavia.dat, .flavia.res, and .boh.

The project mesh is stored in the .flavia.dat file. The mesh is a 2D surface.

The results to be visualized in GiD Post-process are stored in the .flavia.res file. It is this file
that stores the data which enables GiD to represent the distance of each point from the
corresponding center of mass.

The numerical value of the center of mass is saved in the .boh file. The accuracy of this value is
directly proportional to the element size.
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strcpy(filedat, projname);

strcat (filedat, ".boh");

fptest = fopen(filedat, "w");

fprintf (fptest, "FILE: %s\n", projname);

fprintf (fptest, "CMAS2D\n2D routine to calculate the mass center
of an heterogeneus object. \n January 2000\t
Rienzi Gianfranco\t\t\t\tCIMNE\n") ;

fprintf (fptest, "\n\n\t====> mass center: $1f $1f \n", x CG, y CG);

Creating the .boh file.

The .boh extension is added to the project name and a file is created that will contain the
numerical value of the position of the center of mass, which in turn is stored in the x_CG and y
y_CG variables of the program.

/* writing .flavia.dat */
strcpy (filedat, projname);
strcat (filedat,".flavia.dat");
fp = fopen(filedat, "w");
fprintf (fp, "FILE: %s\n", projname);
fprintf (fp, "\n");
fprintf (fp, "CMAS\n");
fprintf (fp, "Routine to calculate the mass center of an object.\n");
fprintf (fp, "\t\t\t\t\tCIMNE\n");
fprintf (fp, "2000 G. Rienzi\n");
fprintf (fp, " %$6d %$6d 3\n", Nelem, Nnod);
fprintf (fp, "\t\tNODES\n");
for (inod=1; inod<=Nnod; inod++)
fprintf (fp, " %6d %14.6e %$14.6e \n", inod, x[inod], yl[inod]);
fprintf (fp, "\t\tCONECTIVITIES\n");
for (ielem=1; ielem<=Nelem; ielem++)

fprintf (fp, " %6d %6d %6d %6d %6d\n", ielem, N[0+ (ielem-1)*3],
N[1l+ (ielem-1)*3], N[2+(ielem-1)*3], imat[ielem]) ;
fclose (fp);

Creating the .flavia.dat file.
The .flavia.dat file contains information about a 2D surface. The .flavia.dat file has a particular
format which must remain intact if GiD is to read it. The format of this file is the following:

o There are 6 header lines for entering general information about the project. For this
example, enter the following information:

FILE: "project name"
CMAS
Program for calculating the center of mass
CIMNE
2000 G. Rienzi
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Then enter the number of elements and nodes in the mesh using the following format:
Number of elements (Nelem) number of nodes (Nnod) element type (3).
A type-3 element means it is a three-node triangle.
e The next line is for general information. For this example, enter the following text:
NODES
e Then list the coordinates of all the nodes using the following format:
Node identifier (inod) x coordinate (x [inod]) y coordinate (y [inod])
e The next line is for general information. For this example, enter the following text:
CONECTIVITIES
e To conclude, list the connectivities between nodes. For each element, list these variables:

Element identifier (ielem)

1% node (N [0+ (ielem-1) *3])
2" node (N[1+(ielem-1)*3])
3" node (N[2+ (ielem-1) *3])

material (imat [ielem])

/* writing

.flavia.res */

strcpy (filedat,

projname) ;

strcat (filedat,".flavia.res");

fp = fopen(filedat, "w");

fprintf (fp, "MC-DISTANCE 2 1 1 1 0\n") ;
for (inod=1; inod<=Nnod; inod++)

{

/* distance from the center of masses */

raiz= (x _CG-x[inod])*(x_CG-x[inod]) + (y CG-y[inod])*(y CG -
y[inod]);
pot = sqgrt ((double)raiz);
fprintf (fp, " %6d %$14.61f\n", inod, pot);
}

fclose (fp);
fclose (fptest):;
free(x);
free(y);
free(N);

free (imat) ;

Creating the .flavia.res file. The output data (results) are stored in this file.
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The format of the .flavia.res file is as follows:

o On the first line, enter the variables defining the type of result. The first parameter of the
line is the title appearing in the GiD post-process menu. For this example, the title MC-
DISTANCE has been chosen.

Then enter the values 2 1 1 1 0.

The first parameter is the type of analysis: 2 corresponds to a load analysis.

The second parameter is the number of steps in the calculation. In this example there is 1
step.

The third parameter is the type of result: 1 corresponds to a scalar result.

The fourth parameter is the position associated to the results: 1 means the results are
associated with nodes.

The fifth parameter is a description of each component: 0 means there is no description.

e To conclude, list the results (distance from the center of mass) in the following format:

Node identifier (inod) associated result (pot)

/* jumpline function */
void jumpline (FILE* filep)
{
char buffer[80];

fgets (buffer, 80, filep);
}

Executing the Jumpline function.
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x=(double *) malloc((Nnod+l)*sizeof (double)); if (x==NULL) {error=1l;}
y=(double *) malloc((Nnod+l) *sizeof (double)); if (y==NULL) {error=1l;}
N= (int *) malloc((Nelem+l) *3*sizeof (int)); if (N==NULL) {error=1l;}
imat=(int *) malloc ((Nelem+1l)*sizeof (int)) ; if (N==NULL) {error=1;}

if (error)

{
strcpy (fileerr, projname);
strcat (fileerr,".err");

ferr = fopen(fileerr, "w");
fprintf (ferr, "\n \n \n ***** ERROR: Not enough memory. ***** \n");
fprintf (ferr, " (Try to calculate with less elements)\n");
exit (1) ;
}
for (1=0; 1<6; i++)

jumpline (£fp);

/* reading the coordinates*/
for (inod=1; inod<=Nnod; inod++)
fscanf (fp, "%d %$1f %1f", &aux, &x[inod], &y[inod]);

for (i=0; i<6; i++)
jumpline (£fp);

/* reading connectivities */

for (ielem=1; ielem<=Nelem; ielem++) {
fscanf (fp, "%d", &aux);
for (3j=0;3<3;j++) fscanf (fp, "%d", &N[(ielem-1)*3+31);
fscanf (fp, "%d", &imat[ielem]);
if (imat[ielem]==0)
{
strcpy(fileerr, projname);
strcat (fileerr,".err");

ferr = fopen(fileerr, "w");
fprintf (ferr, "\n \n \n **ERROR: Elements with no material!!** \n");
exit (1) ;
}
}
for (i=0; 1i<5; 1i++)

jumpline (£fp);
fscanf (fp, "%s %s %d",saul, sau2, &Nmat );
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mat= imat[ielem];
x num+= rho[mat]*v*x CGi;
y num+= rho[mat]*v*y CGi;

den+= rho[mat] *v;

}

/* point weights */
for (icnd=1; icnd<=Ncnd; icnd++)
{
inod= nodc[icnd];
x num+= wval [icnd] *x[inod];
y numt+= wval[icnd] *y[inod];

den+= wval[icnd];

}

x_CG= (x_num/den);
y CG= (y num/den);
}

void output ()
{
char filedat[1024];
FILE *fp, *fptest;
double raiz;
double pot;
strcpy (filedat, projname);
strcat (filedat, ".boh") ;
fptest = fopen(filedat, "w");
fprintf (fptest, "FILE: %$s\n", projname);
fprintf (fptest, "CMAS2D\n2D routine to calculate the mass center of an
heterogeneus object.\nJanuary 2000\tRienzi Gianfranco\t\t\t\tCIMNE\n") ;
fprintf (fptest, "\n\n\t====> mass center: %$1f %$1f \n", x CG, y CG);

/* writing .flavia.dat */
strcpy (filedat, projname);
strcat (filedat,".flavia.dat");
fp = fopen(filedat, "w");
fprintf (fp, "FILE: %s\n", projname);
fprintf (fp, "CMAS\n");
fprintf (fp, "Routine to calculate the mass center of an object.\n");
fprintf (fp, "\t\t\t\t\tCIMNE\n");
fprintf (fp, "2000 G. Rienzi\n");
fprintf (fp, "\n");

fprintf (fp, " %6d %6d 3\n", Nelem, Nnod);
fprintf (fp, "\t\tNODES\n");

for (inod=1; inod<=Nnod; inod++)
fprintf (fp, " %6d %14.6e %14.6e\n", inod, x[inod], yl[inod]);
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