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1 Solve problems

1

Questions about GiD setup. You can get more information in http://www.gidhome.com/support/installation

1.1 Message 'There is no disk in the drive' on Windows

In some Windows versions when starting GiD it could appear a message like 
'There is no disk in the drive. Please insert a disk into drive' for some units.
It happen only is GiD was not registered with a password and try to find it in all units, then only asking for the unit could 
raise the unwanted message box.
A way to avoid this window is to change a setting on Windows: to do it start regedit.exe and modify the key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows\ErrorMode
changing its value=0 by 2

1.2 Problems installing GiD on Windows

Setup can fail if the current user does not have administrator privileges.

1.2.1 Saving Preferences on Windows Vista

If you are experiencing problems on saving preferences on windows 7 you can disable the Users Accounts Configuration 
(UAC) in Windows:
go to Control Panel->Users Accounts->Change Users Accounts Configuration (UAC)
And set it to the lower level, Not notificate never.
After that you will need to restart the computer to changes take effect.

1.3 Problems installing GiD on Linux

1.3.1 Ubuntu

If GiD install/.tgz does not run on some ubuntu versions perhaps you are not able to execute the installation program of 
GiD nor the kernel-2.6 packed (.tar.gz) version on the latest ubuntu distribution.

Check if the distribution you are using is a 64-bit one with
uname -a:
..... x86_64 ...

If you have used the Wubi installation program, by default it installs the 64-bit distribution on a machine which is able to 
run 64-bit applications, which are all the machines by now.

It seems that the default 64-bit installation of ubuntu (and kubuntu, xubuntu) does not include the 32-bit support to 
execute 32-bit applications.

The installation programs of GiD are 32-bit applications, including the 64-bit version.

As explained here: http://ubuntuforums.org/showthread.php?t=583454 just by doing:
apt-get install ia32-libs lsb-core
(or through the synaptic package manager)
You will be able to run the 32-bit installers of GiD and the 32-bit version of GiD on the 64-bit ubuntu.

1.3.2 MEPIS

The dynamic version of GiD failed on MEPIS kernel 2.6.15 because some libc symbols could not be resolved.

This problem could be avoided updating the g++ package to the 4.2 version:

sudo apt-get install g++-4.2

1.4 Wrong graphics on MS Windows

The screen show something wrong: the screen is not painting or show some garbage, etc

Tipically, these type of problems are caused by the graphics acceleration card.
Search in the web page of your card if there are actualized drivers for your graphic card.

A possibility to avoid the problem is the following:
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Go to the GiD menu Utilities->Preferences... 
and in the "Graphical->System" tab select the "Safe visualization mode"

Some problems could be solved also setting "Selection lines by software (emulateFronBuffer)"

Another method to do it:
Try to start "Repair GiD" (from the start menu) and use 'Activate Software OpenGL'

If the problem persists, try to deactivate the graphic hardware acceleration on Windows
(Screen properties->Advanced options->Solve problems)
Also can try a different colour resolution (select 32 bits of colour for example) 

Check also See Support of 3D graphic cards -pag. 19-.

1.5 Wrong graphics on Linux

Try to deactivate visual effects if they exists in you Linux distribution
e.g. with Ubuntu 8.04 the gnome desktop environment has this visual effects activated by default
In order to deactivate them, go to: 
System->Preferences->Appearance - Visual effects
and set to None

Maybe the problem is because the use of graphical acceleration, to avoid it:

Go to the GiD menu Utilities->Preferences... 
and in the "Graphical" tab select the "Safe visualization mode"

Some problems could be solved also setting "Selection lines by software (emulateFronBuffer)"

Another method to do it:
instead the normal starting script
gid
try to use this alternative starter (to use our generic mesa graphic library)
gidx

1.6 GiD doesn't detect the USB memory stick

When oppening the "Help -> Register GiD ...", if some USB memory stick is plugged, a "Sysinfo selection" window must be 
opened to ask the user which device can be registered.

in some Linux distributions (e.g. Suse 10.x) the USB device is not detected, and this "Sysinfo selection" is not opened.

This is because /proc/bus/usb is not automatically mounted, it can be manually mounted (as root user) with
mount -t usbfs none /proc/bus/usb

Note: It's possible to automatize it adding to the /etc/fstab file something like this:
usbfs /proc/bus/usb usbfs noauto 0 0

Note: e.g. OpenSuSE 10.2 does not have this support by default and the kernel should be recompiled or a patch should be 
applied. More information can be found here: http://en.opensuse.org/SDB:VMware_-_USB_support

Note:  e.g. Ubuntu 8.04.1 does not mount /proc/bus/usb automatically, so it should be done by hand or added to the 
/etc/fstab file, as explained above.

1.7 Upper Menu locked (Windows only)

With the OS Microsoft Windows, sometimes exists a conflict with the menu bar, and they remain blocked. 
It is possible to unlock the menu bar without restarting GiD, by using the keyboard shortcuts 
(e.g. Alt+f, to invoke the Files menu).

1.8 The password is not remembered

The password is valid, but is not remembered and for next sessions GiD is asking again for the password:

This problem is because the program doesn't has permission to write the password in the file \scripts\TemporalVariables
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You must start GiD once with adminitrator privileges, and enter the password, then it will be saved in this file for next 
times.

To start GiD with adminitrator privileges: 
On Windows Vista/7 

click the right mouse-button over the starting icon of GiD, and in the contextual menu select something like 'Start as 
administrator'

On Linux 
use the 'sudo' command (SuperUserDO), 
e.g. 
sudo gid 
(the administrator password will be asked)

1.9 Reset all user preferences

Solve problems>Reset all user preferences

User preferences
Each user has its own copy of some GiD settings (like preferences variables, or window sizes). 
This settings are automatically saved when exiting GiD, and loaded when starting.

This information is saved in a file named 'gid.ini' (Windows) or '.gidDefaults' (Linux) that is stored in a different place 
depending on the platform
e.g. 
Windows 10/ 8 / 7 / Vista: C:\Users\<current user>\AppData\Roaming\GiD\gid.ini
Windows XP: C:\Documents and Settings\<current user>\Application Data\GiD\gid.ini
Linux / Mac OS X: $(HOME)/.gidDefaults

And by default some Windows folders like "AppData" are hidden. (and for Linux filenames starting by . are hidden)

Reset user preferences
The easiest way to delete this user settings file, without need to find it on disk, is to start once as 'Repair GiD'
and then a window will appear: set the 'Reset preferences' checkbox and press Ok

If the user defaults is deleted the next time that GiD start it will use its own default values.
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Questions about general aspects of GiD.

2.1 What GiD is

GiD is a general purpose pre-postprocessor for computer analysis. All the data, geometry and mesh generation can be 
performed inside. Also, the visualization of all types of results can be performed. It is easy customizable and adaptable by 
the final user.
It can be adapted to an analysis by the creation of a 'problem type'. In this problem type, it is explained to GiD how are the 
boundary conditions, materials and al the information needed for the analysis. It is also shown to GiD how is the format of 
the input file of the analysis program.
There is a second level of adaptation where, by the means of the TCL/TK scripting language, it is possible to change the 
look and fell of the program and add some functionality to it (until a certain point).
You can get more information in http://www.gidhome.com/whats-gid

2.2 What is a 'problem type'

To write data from GiD to a calculations program, it is necessary to create a 'problem type' for it.

A 'problem type' is basically a collection of text files, copied inside a common directory with .gid extension. This files define 
your material fields, conditions, the template to write your calculation file, etc.
It is quite easy write a simple 'problem type'. The first step is to check one of the examples that are included in the GiD 
distribution like 'problem_type_solid1.gid'. Studying it and modifying accordingly to suit your needs you will get a GiD that 
can write the files that your calculations code can read. 

Check also in the Help menu the 'Customization manual' and the 'Defining a problemtype' tutorial chapter of the 'User 
manual'.

Some problemtypes can be downloaded from the 'Data->Problem type->Internet retrieve' GiD menu, or from the GiD web 
page http://www.gidhome.com/gid-plus/modules

2.3 How to get more information

There is a lot of GiD information that can be accessed from www.gidhome.com

GiD help (reference manual). It's installed by default with GiD. 
(An online manual can be found inside Support->Manuals of the Web Page)
GiD user manual (a collecion of tutorials to begin to learn GiD)
It exists an user forum: inside Support->Forum
Can search information related to some keyword using the search box of the web page
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Questions about geometry, NURBS and modeling operations.

3.1 Which the interfaces with CAD systems are

 For CAD geometries:
IGES (input and output)
STEP (ap 214, but ap 203 could also be work, input and output)
VDA (input)
DXF (input and output)
PARASOLID [*.x_t, *.x_b] (input)
ACIS [*.sat] (input and output)
Rhinoceros (input and output)
Shapefile (input)

For meshes:
GiD format
NASTRAN
STL
Vtk (in postprocess. In preprocess only Vtk voxel images are imported extracting iso-surfaces)
Ply
Obj
VRML
3D Studio
CGNS

...

Other information can be entered by the means of a batch file, and exported through a .bas template.

3.2 Support of Super-surfaces by GiD

It is not possible to do it inside GiD, and standard exchange formats like IGES doesn't support this 'polisurfaces'

In Preferences->Meshing->Unstructured, the 'Skip entities automatically' allow the mesher tocreate elements with nodes 
on different surfaces. 
In the Mesh->Mesh criteria menu the user can also expliciltly select some lines to be jumped or not, then from the meshing 
point of view it's like a 'super-surface'

3.3 Creation of multiple volumes at the same time

Gid have a function to create automatic 6-sided volumes (Geometry Create Volume Automatic Struct).
In the current version, several volumes can be created simultaneously, selecting all the boundary surfaces. GiD 
automatically detects the holes.
To add manually a hole to a volume, invoke the menu: Geometry->Create->Volume->Hole, then select the outer volume 
and then select the volumes of the hole.
Option Search in volume creation permits to select one surface and GiD tries to find one volume that contains this surface.

3.4 How to create 2D contacts

 To create a 2D contact the process is:
Create one side lines and put them in one layer.
Set another layer as active
Create another line that exactly duplicates the first one. Points must be also duplicated (Typically using copy with 
translation 0 and with flag 'Collapse' unset).
Set another layer as active
Create a contact surface selection the two lines or more at the same time (if using copy, it has the option 'Create 
contacts').
Several element types can be generated in the contact (degenerated elements):
2-noded elements (by default).
No elements (useful to force the same mesh in both sides)



8How to create 2D contacts

Quadrilateral elements

Layer in this process have only been set for viewing and selecting purposes. In fact, they are not necessary.
If 2-noded elements are meshed, later it is easy in the .bas file to list them by pairs.
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Questions about mesh generation of any element types.

4.1 Possibility to extract information about boundary edges and faces

Mesh generation and data (boundary conditions, materials, etc)>Possibility to extract 
information about boundary edges and faces
 If you need the boundary edges or the faces of surface elements or volume elements you can do it in several ways:

Give a mesh criteria of type "mesh" to the lines or surfaces that are the boundaries of your surface or body. After 
generation, you will have linear or triangle or quadrilateral elements apart from the main ones.
Assign a condition "over face elems" to the line or surface that is the boundary. You can then list the element faces 
with this condition in the '.bas' file with the order *globalnodes or *localnodes.

4.2 Allow geometric information to be incorporated into the customization files

Do you have any plans to allow geometric information to be incorporated into the customization files, so that mesh 
optimisation can be coupled to the solver?

There is now one feature in GiD (field #FUNC# in conditions definition) that allows to write the number of every geometric 
entity for every element in the mesh. Then, you can get the geometry with any command like write ASCII or whit the 
order *tcl inside the bas file, and you have the relationship.
To do remeshing, it is available to read a background mesh file (of triangles or tetrahedras), containing the description of 
the new mesh sizes desired.
To do optimisation of shapes is a more difficult problem. We are thinking on several ways to do it. One of them would be 
that the solver gave, as output, one description of the desired movement of the mesh and then, apply this movement to 
the geometry. We would appreciate any feedback that you can give to us.

4.3 Generation of 10-noded tetrahedra using GiD

Can GiD generate 10-noded tetrahedra?

The current version supports 10-noded tetrahedra.

4.4 Possibility to mesh complex structured volumes using GiD

Can GiD mesh complex structured volumes?

Structured meshes can be done with complex surfaces but not with complex volumes (they can only have 6 faces or 
surfaces). Probably, in the near future we will add the same capabilities to the volumes that we have now for the surfaces.
The most powerful part of GiD for CFD analysis is the tetrahedra mesh generation. It permits to concentrate elements near 
the object of study (ship, plane or any other), and let them grow fast or slow.

4.5 Methods to define element sizes

The easiest meshing is defining a global size and small elements for features are automatically calculated.
User can define a cordal error (geometry - mesh error)
User can manually define sizes over geometrical entities. This sizes can be automatically corrected to allow meshing 
checking Preferences->Meshing->Automatic correct sizes.
The transition between sizes is controlled by a factor that the user can define (Preferences->Meshing->Size transition).

4.6 Generation measurements

Tests of tetrahedra generation

Million tetrahedra Fina memory GB CPU time (hours)
11 2 ?
22 3.4 ?
43 7 4

GiD 10.0 Linux x64
Machine Intel Quad core 32 GB RAM
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Model 56 volumes (7 did'nt mesh!!)
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Questions related with customization of GiD.

5.1 Repeating a condition

Question: I assign X condition on some nodes and then assign Y condition on some nodes(include some nodes I select 
when assign X condition),then I write a calculate file,those nodes I select both when I assign X condition and Y condition 
only have Y condition value,but the X condition is lost.Could you tell me the reason?

Response: If you desire to apply a same condition (same name with different values) more of one times to a entity, this 
condition must be declared as CANREPEAT: yes in the *.cnd file.
If CANREPEAT: no (default), then the second same condition replaces the first:

Sample *.cnd:

CONDITION: Face-Load
CONDTYPE: over lines
CONDMESHTYPE: over face elements
CANREPEAT: yes
QUESTION: X_preassure
VALUE: 0 
HELP: 2D case, X force for length unit
QUESTION: Y_preassure
VALUE: 0
HELP: 2D case, Y force for length unit
END CONDITION

Inside the bas file also exist a *CanRepeat keyword:
If command *CanRepeat is added after *nodes or *elems in *Set cond, one entity can be several times in the entities list 
of the loop. If command *NoCanRepeat is used, entities will be just once in the entities list.
By default, *CanRepeat is off except for the case of one condition that have the *CanRepeat flag already set.
Sample *.bas:
*Set Cond Face-Load *elems *canrepeat 
*# if canrepeat is missing, it is assumed by default in this case, 
*# because Face-Load have CANREPEAT: yes 
*loop elems *OnlyInCond
Elem number=*elemsnum, Nodes of the loaded face= *globalnodes Px=*cond(X_preassure) Py=*cond(Y_preassure) 
*end elems
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Questions about GiD postprocess.

6.1 How to read postprocess information using GiD

GiD reads several files with postprocess info in a GiD-defined format.
As the information is really in a very easy format, your code (or one interface program), should write the results of your 
analysis in GiD postprocessing format. It is very easy to do it. Some people have modified their code for GiD in 2-3 hours. 
The GiD postprocessing format is defined in the reference manual and in the interactive help.

We also provide source code of the 'gidpost' library, to be linked to your C/C++/FORTRAN program, in order to write 
posprocess results files (ASCII and compressed binary)
Find all information inside Support->Tools of the web page www.gidhome.com

Some externals result formats can be also imported in postprocess:
FEMAP
TECPLOT

6.2 Display results on Gauss points

Can GiD display results on Gauss points?

With version 6 or newer it is possible to visualize results in Gauss points, both in automatically calculated and introduced 
by the user.
Gauss points are several points inside every element, that are used to perform the integration quadrature necessary for the 
FEM. For this reason, the main variable of the problem is obtained in the nodes and the variables that need an integration 
of this, are obtained in these Gauss Points.
Current version can already read and display data in the Gauss points. The standard possibilities are:

Linear (beam) elements: any number of points inside, equally distributed.
Triangle: 1,3,6 GP in standard positions.
Quadrilaterals: 1,4,9 GP in standard positions.
Tetrahedra: 1,4,10 GP
Hexahedra: 1,8,27 GP

Note:  Standard positions means the positions of the quadrature of Gauss-Legendre. If your positions of the points is 
different, it is also possible to introduce user-defined positions.
One Smoothing algorithm is the one that, given one variable defined on Gauss Points, calculates the value of this variable 
in every node of the mesh. The easiest way to do this is, for every element, transport with the shape functions the values 
to the nodes, and do the mean or one weighted mean of the several values calculated for every node.

6.3 Possibility to visualize in the additional nodes for higher degree elements

For higher degree elements, can results be visualized in the additional nodes?

Current version can read second degree elements. 
It exists a preference option to display them fastly as linear.

6.4 what happens with headers in the postprocessing .res files

The name of the result must be 15 characters long. If it is shorter, the remaining space until 15 can be blanks.

6.5 Procedure to visualise a 3D velocity field with streamlines

Could you provide me with a simple procedure to visualise a 3D velocity field with streamlines?

The easiest way to define a stream line in a 3D mesh is to select a point by giving its coordinates. The stream line that 
goes through this point is drawn. In the contextual menu there are other ways to select several points at once. Tipically, a 
cut is made in the middle of the volume mesh and the points are selected in the cut.
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Questions about exporting files.

7.1 How to export the mesh and the boundary conditions, materials and so on

 It is possible to export the mesh and the boundary conditions just by pressing one button (Files->Export->Write ascii). 
The problem is the output format. Every calculations program has its own input format and GiD is not prepared to know all 
these formats. The solution is one of:

Output from GiD in one format and make external conversion to another one.
Define or modify one GiD 'problemtype' to suit your needs. In this way, GiD will know what information should the user 
enter (boundary conditions, materials, ...), and GiD would write the calculations file in the exact format you need. We 
include several examples of problemtypes with the GiD instalation, to help people to develop their owns.
There are already interfaces with LS-DYNA3D, NASTRAN, Abaqus, and a basic one to SAP2000, ANSYS, Fluent and 
OpenFOAM. Contact CIMNE for further information.

The second solution is the recommended one. Many times, a slight modification in the 'problemtype' code by the user, can 
be made in minutes and obtain very easily the desired files. To do so, check the customization part in the help and check 
the 'problemtypes' given as a example.
To export only the mesh (not condions, etc), it exist a standard directory /templates with some simple templates *.bas 
(see customization)to write the mesh in several formats: STL, VRML, NASTRAN, DXF. A user can add more user-defined 
templates to this directory.

7.2 Export to SAP90-SAP2000

In exists a simple GiD-SAP2000 problemtype.

There is one special old 'problemtype' to connect GiD and SAP90. It is not included in the GiD distribution. It can be 
obtained as a technical publication (one book). 
Contact CIMNE cimne@cimne.upc.edu for more information.

The simple DXFSAP2000 template can be used to transfer the mesh to SAP2000.

7.3 Possibility to work using finite volumes in GiD

Does GiD works for finite volumes?

Yes, It can work with either finite differences, finite elements, finite volumes, meshless methods and others. In fact, as GiD 
only deals with the geometric and mesh part, it does not mind the type of analysis that will be made as long as it needs a 
mesh.

7.4 How to print in the calc file the number of the layer which an element belongs to

How I could print in the calc file the number of the layer which an element belongs to?

Now, it is available inside the bas file the layer information: *ElemsLayerNum *NodesLayerNum, *Loop Layers, 
*LayerNum, *LayerName, *LayerColorRGB, etc
In old versions, the layers information cannot be directly dumped into the output file. Tipicallly, it is necessary to assign a 
material or a condition to the elements that reflects this property. There are bassically two options:

User assigns a condition or material to the elements with a field that reflects the property that you are working with.
Perform the last step automatically.

To do it automatically use the following:
TCL function 'BeforeWriteCalcFileGIDProject', is executed just before writing the calculations file. You can define this 
function in your 'problemtype'.tcl file and make it assign a condition to the entities depending on the layers.
TCL function 'AfterWriteCalcFileGIDProject' is executed just after writing the calculations file. You can clean up this 
condition if you wish.
TCL command '.central.s info layers' gives you the layers of the project. 
TCL command '.central.s info layers -entities Elements' returns the elements belonging to a layer.
.central.s process escape escape data conditions assign cond CND change VALUE layer:LAYER1
would assign to condition CND with value VALUE all the entities belonging to layer LAYER1.
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Specific questions about GiD in the different operating systems.

8.1 OS versions GiD supports

What OS versions does GiD support?

Main currently versions are for: 

Windows (10/8/7/Vista/XP/2000/NT/ME/98/95). 32 and 64 bits
Linux (several kernels, 32 and 64 bits)
Mac OS X 64 bits (El Capitan, Yosemite, Mavericks)

Old versions
Mac OS X 64 (Lion, Mountain Lion) and 32 bits (Snow Leopard)
Silicon Graphics
Sun (Solaris)
HP
Digital alpha UNIX 

Maybe in the future we will have more versions for several machines. Everything depends on the interest of the people.

8.2 Hardware requirements

Which are the hardware requirements?

GiD works in any standard PC. Normally, the critical issue is the RAM memory. It must be related to the size of the mesh to 
be generated. As a rule about 1GB by million of elements.

An spaceball can be interesting to easily rotate and move the view.

8.3 How to make GiD x32 use more than 2GB on Windows XP or Vista

This only works for Microsoft Windows XP or Vista, and for GiD x32 version 7.5.x and newer.
In a standard Microsoft Windows machine, each program only can work with 2GBytes of memory, although there is more 
installed. So if you have a machine with lots of memory, more than 2GB, and running Windows XP, you can enable your 
system so that a program, if it is able to, sees and uses more than this 2GB of memory. In a Microsoft Windows XP 32bit 
environment, the program will be able to use upto 3GB of memory, and on a 64bit environment, up to 4GBytes, althought 
the program is 32bit.
MS Windows XP:
Should be configured by adding the flag /3G to the Boot.ini file. To do this just open the Control panel, click on the System 
icon, on the Advanced options panel, then press the Configuration button of the Start and recuperation section. In this 
window click on the Edit button inside the System start section and the Notepad will pop-up with the Boot.ini file opened. 
In this file there should be a line like this:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
just add the /3GB flag at the end, like:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /3GB
Now the file must be saved, and MS Windows restarted
More information can be found at
http://www.gidhome.com/gid3gb/index.html

MS Windows Vista 
Use BCDEdit /set to set a boot entry. The option to set is 'increaseuserva'
increaseuservaMegabytes Specifies the amount of memory, in megabytes, for user-mode virtual address space. This 
variable can have any value between 2048 (2 GB) and 3072 (3 GB) megabytes in decimal notation. Windows uses the 
remaining address space (4 GB minus the specified amount) as its kernel-mode address space. 

Open a DOS console and write this:
BCDEdit /set increaseuserva 3072 
And restart the system
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How to make GiD x32 use more than 2GB 
on Windows XP or Vista

More info:
How to make GiD use more than 2GB on Windows XP?

Two steps must be followed to achieve this: configure Windows so that it lets a process use more than 2GB and enable the 
application to use more than 2GB.

   1.

      Configuring MS Windows XP: add the flag /3GB to the Boot.ini file. To do this just open the Control panel, click on the 
System icon, on the Advanced options panel, then press the Configuration button of the Start and recuperation section. In 
this window click on the Edit button inside the System start section and the Notepad will pop-up with the Boot.ini file 
opened. In this file there should be a line like this:

      multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

      just add the /3GB flag at the end, like:

      multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /3GB

      Now the file must be saved, and MS Windows restarted
   2.

      Enabling the application: set the IMAGE_FILE_LARGE_ADDRESS_AWARE in the .exe file of the application. This can be 
accomplished in two ways:
          *

            linking the program with the flag /LARGEADDRESSAWARE - go to the Properties of your MS VisualStudio 2003 
application project and look for the Linker section and the System branch. In the combo-box menu with label name Enable 
Large Addresses select the entry Support Addresses Larger Than 2Gigabytes (/LARGEADDRESSAWARE).
          *

            setting this bit directly in the executable - using the program editbin.exe located in C:\Program files\Microsoft 
Visual Studio .NET\Vc7\bin like this:

            c:\(...)\Vc7\bin> editbin.exe /LARGEADDRESSAWARE \Path\To\The\Program.exe

            Afterwards this bit can be checked with the dumpbin.exe utility:

            c:\(...)\Vc7\bin> dumpbin.exe /headers \Path\To\The\Program.exe

            Among other things a line like this one should appear:

               Application can handle large (>2GB) addresses

Note 1: The /3GB flag only works on MS Windows XP. Although MS Windows 2000 also accepts this flag, it only lets the 
application use 2GB.

Note 2: If a 32bit application with the bit IMAGE_FILE_LARGE_ADDRESS_AWARE set is run on MS Windows XP 64bits 
edition, it can address 4GB of memory instead of 3GB.

Note 3: Avoid signed comparisons with pointers, pointers casting to integers (instead of unsigned integers) and hard-wired 
addresses.

The editbin.exe utility
The dumpbin.exe utility
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Several devices that can be attached with GiD.

9.1 Support of 3D graphic cards

Does GiD support 3D graphic cards?

The 3D graphic cards status:
GiD can be accelerated by any 3D graphics card that supports OpenGL. 

There is a feature to disconnect the hardware acceleration of a graphics card that is not working properly. Check the 
'Repair GiD' option in the MS Windows start menu.
Note: To disconnect a 3D graphics card that is not working correctly in MS Windows, see the screen properties panel. In 
some cards, the acceleration is automatically disconnected selecting to display with 256 colors or true color.

This is non exhaustive list of some tested graphic cards:

Test of some Graphic cards with GiD

Cards that works well

Brand Model Operating system
NVIDIA GeForce 8600M GT, 8600 GT and GTS 

256Mb
Windows Vista x32 SP1 & Windows 
XP x32 SP3

NVIDIA GeForce 8800 GT 512Mb Windows Vista x64 SP1 & Ubuntu 
8.0.4 x64

NVIDIA Quadro4 750 XGL 128Mb Windows XP x32 SP3
NVIDIA Quadro FX 1500 Linux Ubuntu 8.0.4 x64

(deactivating compiz, desktop 
effects)

ATI Radeon X1300/X1550 and Movility 
Radeon X1300

Linux OpenSUSE 10.2 x64 & Ubuntu 
7. x_64 & Ubuntu 8.1 x32

Cards with some know bug related to GiD

Brand Model Operating system Know problem
ATI Radeon 9250 128Mb Windows XP x32 SP3 GiD 9.0.4: problem with 

cursor
GiD 9.1.1b: ok

NVIDIA GeForce 6600 Linux OpenSUSE 11.1 
x64

After selection is necess 
arysome manual redraw 
to see again entities in 
normal color

NVIDIA GeForce 9800 GT Windows Vista x64 
ultimate

GiD 8.2.0b: black screen

NVIDIA Quadro Fx1700 Windows XP 64 bit GiD 9.0.4: black screen
NVIDIA GeForce 8600 GT Windows Vista x64 GiD ???: black screen

9.2 Support of spaceballs using GiD

Does GiD support spaceballs?

GiD supports SPACEWARE spaceballs in all platforms.
To use it, just install the software given by SPACEWARE. To use it on Linux see Use the Spaceball on Linux with GiD -pag. 
19-.

9.3 Use the Spaceball on Linux with GiD

Being root, create this symbolic link:
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ln -s /dev/cuaX /dev/spaceball
with cuaX as the serial port where the SpaceBall is attached. And be sure that this cuaX serial port has READ/WRITE 
permisions for all the people ( User/Group/Others).

9.4 USB memory sticks valid to register GiD

GiD licence can be attached to an USB memory stick (portable licence) Licenses policy -pag. 21-

In general near all current memory sticks are valid to register GiD, only some old devices (specially mp3 players) are 
unable to register GiD

Can check here a non-exhaustive list with some valid and invalid USM memory sticks
Valid USB

9.5 USB memory stick licence in virtual machines

We have tested a usb memory stick registered for GiD with VirtualBox and VMware workstation on 'local' virtual machines.

To use it must do this:

virtualbox:
In the 'Settings' of your Virtual machine: enable the USB controller and select at least the 'USB 2.0 (EHCI) controler'.
Plug your registered usb stick
Start you virtual machine (you'll see that the guest OS installs some new drivers, for the USB support) 
and select the USB-stick from the VM virtualbox menu bar: Devices->USB->'Manufacturer/Product/USB description' 
(for example: Devices->USB->General USB Flash disk [0100])
When one of the usb entries is selected, it will be disconnected from the host and will be connected to the guest machine, 
(i.e. in your virtual machine the usb drive will appear with all its files)
Start GiD, it will find the registered USB. 
If the usb is not registered, you can find it under Help->Register GiD...

VMware workstation
In the 'Settings' of your Virtual machine: add the 'USB controller' and select USB compatibility 'USB 2.0'
Plug your registered usb stick
Start you virtual machine (you'll see that the guest OS installs some new drivers, for the USB support) 
and select VM->Removable Devices->'Manufacturer/Product/USB description'->Connect (Disconnect from Host)
(for example: VM->Removable Devices->General USB Flash disk->Connect (Disconnect from Host))
The usb stick will appear in your VMachine
Start GiD, it will find the registered USB. 
If the usb is not registered, you can find it under Help->Register GiD...

VMware ESXi
Sadly, VMware ESXi 4.0.0 does not support USB connection/forwarding to the virtual machine,but VMware ESXi 6.0.0 does 
support USB connection to the virtual machine:
To do so you've to follow almost the same steps as above:
Connect to you remote hypervisor (VM manager), we used the VMware vSphere Client
In the 'Edit Settings' of your Virtual machine: add the 'usb controller' and select USB controller type 'EHCI+UHCI'.
Plug your registered usb stick
Start you virtual machine (you'll see that the guest OS installs some new drivers, for the USB support)
From the icon bar, the icon

(Connect/Disconnect the USB devices to the virtual machine)
will pop-up a menu: Connect to USB device --> 'Manufacturer/Product/USB description'
(for instance: Connect to USB device --> General USB Flash disk ) 
The usb stick will appear in your VMachine
Start GiD, it will find the registered USB. 
If the usb is not registered, you can find it under Help->Register GiD...
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Questions on buying GiD.

10.1 Compatibility licences between GiD versions

Is the GiD version 14 license compatible with version 13 one?

No, as it is a complete new release, it is necessary to obtain a new license for version 14. 
All the following versions belonging to the GiD 14.x series will be password compatible with version 14.

There are special prices to upgrade from the previous version.

10.2 How much does GiD cost

To know the current prices check the GiD web page: http://www.gidhome.com inside Purchase Tab.

An unregistered version of GiD is totally free and can be used for small meshes (about 1000 nodes).
Go to the GiD web page to get a free evaluation password to use the professional version of GiD for one month.

10.3 Licenses policy

There are different kind of GiD licences:
Local licence:

GiD is licensed per one machine and platform basis. This means that every machine should have its own license and that if 
one machine has both, linux and Windows, two licenses are required. For every machine there can be as many users as 
desired using the program at the same time.

USB licence:
The licence is attached to an USB memory stick device. GiD client can run in the machine where this device is currently 
plugged. 
The same licence works for a Windows, Linux or Mac OS X machine.

Floating licence:
A sever machine with 'PasServer' installed can serve a limited number of floating licences to its GiD clients, than must have 
a net connection to the server.
The client machines must use a different operating system than the server machine.

There are two methods of payment: by FAX and by Internet & Credit Card. Both of them are good and secure. Probably, by 
internet is a little bit faster.
Also, you can buy the complete kit with the manuals, USB devices, etc. or just the license.
Our general considerations about licenses is that if during the first year of the purchase something happens, we give 
another license to install GiD again. We are confident with the people and we trust the costumer that the old license will no 
longer be used.


	1 Table of Contents
	1 Solve problems
	1.1 Message 'There is no disk in the drive' on Windows
	1.2 Problems installing GiD on Windows
	1.2.1 Saving Preferences on Windows Vista

	1.3 Problems installing GiD on Linux
	1.3.1 Ubuntu
	1.3.2 MEPIS

	1.4 Wrong graphics on MS Windows
	1.5 Wrong graphics on Linux
	1.6 GiD doesn't detect the USB memory stick
	1.7 Upper Menu locked (Windows only)
	1.8 The password is not remembered

	5 Customization
	5.1 Repeating a condition




