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1 Introduction

1

This courses are prepared to be followed using the version 13.0 of GiD. 
They are divided in GiD basic courses and GiD advanced courses. We strongly recommend to make the GiD basic courses 
before the advanced ones.

1.1 Installing GiD

To install GiD go to the GiD Convention USB unit, from now on we will assume it is 'D:', if you have auto-run function 
active, the file index.html will be opened automatically, if not, please double click on 'D:\index.html'.

Choose from the installer link MS Windows 32 or Linux 32.

Click on the option corresponding to your OS (Windows or Linux), and then follow the instructions of GiD installer to install 
GiD into your computer.

Even if your OS is x64 bits, we will use for this course the x32 bits version of GiD, because some calculation module we 
will use later on is only available for x32 bits (dynamic libraries loaded in GiD must be compiled for the same platform of 
GiD).
Note: A x64 bits OS can run applications of x64 and x32 bits.

On web page www.gidhome.com you can find two types of GiD versions:
Official versions of GiD are stable versions of the program. They don't include the newest capabilities but they have 
passed all the validation tests. 
Developer versions of GiD  are more modern versions of the program that have new capabilities. They have not 
passed the validation tests that a official version does. So, use them with care. Only download and install one of these 
versions if you know of a new capability very important for your needs or if you want to try the new improvements in 
the program. 

1.2 Registering GiD

GiD can work with no licence (unregistered), but in this way the user can only manage a model with a few number of nodes 
(around 1,000).

In case you want to try using a mesh with a higher number of nodes, a free password for one month can be downloaded 
from the web site (or a permanent one buying a licence)

 Password for GiD: http://www.gidhome.com/purchase/passwords

 Password for Compass problemtypes: http://www.compassis.com/compass/en/Passwords

NOTE: The USB memory sticks of the course are already registed with a one month password for GiD 13 (USB passwords 
are valid for both MS Windows, Linux and OS X platforms)

1.3 Installing Problemtypes

Following GiD terminology, a 'problem type' is a calculation module able to perform a simulation and which customizes GiD 
so as the user can apply to the model the material properties, boundary conditions and other information needed for the 
simulation process.

After the GiD installation process, it is needed to add the required 'problem types', to do is usually is only needed to copy 
the problemtype folder inside the /problemtypes gid folder.

It is possible to manually copy these problemtypes (e.g. from the USB GiD\problemtypes folder to our current GiD) or 
dowload them from Internet

If you don't have internet connection, you can simply copy the files from other location.
If you have internet connection, start GiD and go to menu: Data->Problem type->Internet retrieve. A window with 
the available problem type modules will appear, splitted in the different operating systems and platforms.
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There is a mark on the currently installed problemtypes. 
To get some new ones, select them and click "Retrieve module" to install them.

Once the problemtype has been downloaded, close the window and you can check it is present in the list of problem types 
installed in the Data->Problem types menu.

NOTE: The basic course requires for the 'Run a CFD simulation' chapter to install the CompassFEM (Tdyn) problemtype, 
that is copied inside the GiD/problemtypes folder of the memory stick (only the MS Windows x32 version). The example 
uses a coarse mesh that doesn't require any CompassFEM password.

1.4 Material location

The PDF documents and most of the models of the basic and advanced courses can be found in the GiD USB memory stick.
The same PDF documents and all models used in both courses can also be found at ftp://www.gidhome.com/pub/GiD_Conv
ention/2016, inside the corresponding folders.
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1 GiD basic courses

1

1.1 Basic GiD management

The philosophy of this course is to get familiarized with GiD: how to change the views of the model, how to manage the 
Layers, and other basic features. Some of this features are both in the preprocessing and the postprocessing parts of GiD, 
although the examples shown are from the preprocessing one.

Many times the text will make reference to 'entities'.  Almost all the options explained in this course are valid both for 
geometrical and mesh entities, although the examples used are often geometrical ones.

1.1.1 User interface

1.1.1.1 Starting GiD

When GiD is started for the first time a pop-up appears where you can choose OpenGL working mode and GiD theme.
If you are confident with your graphic card please choose Fast visualization mode. With this mode the model will be 
drawn quicker but some issues could appear. 
These courses have been done with the ClassicGiD theme.

These two options can be changed later in the preferences window (select Utilities->Preferences).

Change OpenGL option
This option can be changed in GiD Theme option inside Utilities->Preferences->Graphical->System branch. 

Also it's possible to change it by clicking on /  in the bottom right corner of GiD window.

Change theme
User can choose between Classic and Black themes, which change drastically the GUI appearance. User can also choose 
between some icon sizes in each theme.
These options can be changed in GiD Theme option inside Utilities->Preferences->Graphical->Appearance branch. 
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1.1.1.2 Preprocess and Postprocess modes

GiD basically works in two modes: preprocessing and postprocessing.

To change between both modes please select Files->Postprocess or Files->Preprocess (or clicking in the upper 

toolbar).

1.1.1.3 Warnline

In some of the operations made in GiD by the user, GiD gives information about what is expected to do by the user. This 
information is very useful the first times GiD is used as a guideline for the user.
The place were GiD shows this kind of information is the lower part of its main window.

1.1.1.4 Command line

Using GiD, sometimes the user is asked to introduce data with the keyboard. The 'Command line' must be used for this 
purpose. It is placed in the lower part of GiD window.

1.1.1.5 Status bar

The Status & Information bar located at lower part of GiD's Window, provides basic information at a quick glance.

From left to right you can find:
Zoom factor
Current number of nodes and elements (Click to acces to Status Window)
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Current renter mode (Click to change render)
Number of layers in Pre, number of sets in Post 
Mouse coordinates (Click to open "Coordinate window" in Pre and "Change result units" in Post)
Current Mode: Pre or Post

1.1.1.6 Mouse menu

Clicking the right mouse button on the main graphical window opens an on-screen menu with some visualization options. 
To select one of them, use the left or right mouse button; to quit, left-click anywhere outside the menu.

The first option in this menu is called Contextual. You can select from different options relevant to the function currently 
being used, e.g. when asking for a point they appear options like "Point in line", to select a point over a line, or "Arc 
center" to select the coordinates of the center of an arc.

Zoom, Rotate, Pan, Redraw and Render are the same options as in pre and postprocess mode.
Label in preprocess shows a label with the current entity number, depending if we are in preprocess, geometry and 
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mesh, or in postprocess.
Layer/Mesh (depending if we are in pre or postprocess mode) menu lets user to switch on/off layers.
Switch full screen changes GiD main window to full screen mode.
Image to clipboard creates an image fo the current visualization and placed in the clipboard.

1.1.1.7 Escape function

An important thing a GiD user should know as a general philosophy of use of the program is the Escape key functionality: 
In almost all the actions performed by the user, to declare the action as done the user should press Escape key (or press 
the center mouse button).

1.1.2 Change views of the model

In the View  menu user can find the options to change the point of view in which the model is shown. Many of these 
options are also accessible by the right mouse button menu, or the icons toolbar.

1.1.2.1 Zoom

To zoom in or out the model user can choose the corresponding options in the Zoom section of the View menu or the right 
mouse button menu. 
A user friendly way of zooming the model is to use the wheel of the mouse, or clicking the center button of the mouse 
while the Shift key is pressed.
To get a view which includes the whole model the Frame option must be selected.

The icons corresponding the zoom operations are the following ones:
Zoom in:

Zoom out:

Zoom frame:

1.1.2.2 Pan

To move the view of the model user must select the option Pan. This option is accessible from the View menu, the right 
mouse button menu, or moving the mouse while the Shift key and the right mouse button are pressed.
The corresponding icon for the pan option is the following one: 

1.1.2.3 Rotate

In  View->Rotate menu (also present in the right mouse button menu) there are the options to rotate the view of the 
model.
A user friendly way of rotating is to move the mouse while its left button and the Shift key are pressed.
The corresponding icon for rotating the model is the following one:

1.1.2.3.1 Set center of rotation

An interesting option for rotating the view of the model is to set the center of rotation. To change it:

1 . Select View->Rotate->Center from top menu or Rotate->Center from right button mouse menu. Then, the cursor 
changes into the selection mode.

2 . Select an existing point of the model.
3 . Now rotate the model and check that the center of the rotation is the one selected.

1.1.2.4 View management

There are several preloaded views in order to align the object axes with the screen axes. These views can also be selected 
clicking on icon.

When we are working it's possible to change to previous views using 

icons.
It's also possible to save in a file an specific view to use it later in order to take some snapshots of our model. In order to 
do that select View->View->Save... and to read it just select View->View->Read...
This option is useful to get the same perspective of the same model when we work on different sessions.
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1.1.3 Render modes

In the View menu user can find the Render options. They are also accessible from the right mouse button and the status 
bar.

1 . Select View->Render->Normal
2 . Select View->Render->Flat
3 . Select View->Render->Smooth

In Normal render mode, user can see the entities drawn in different colors, depending on the kind of entity: volumes in 
light blue, surfaces in pink, lines in blue, and points in black.
Flat render mode draws each geometrical entity using the colour of the layer it belongs to, and Smooth mode uses also 
this criterion, but lines are not drawn to represent the geometry in a smoother way. The following figure shows the 
visualization of the model changing render modes:

Render normal Render smooth

1.1.4 Creating images

We can take snapshots of our model. You can save images in several formats. The properties of the image (resolution, size, 
etc.) can be assigned in Page and capture settings option.

1 . Select Files->Page and capture settings...
2 . Check the Auto crop image option in order to cut the image in the model limits
3 . Click on Set Page button
4 . Click on Close button
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In order to save the image with the defined properties in Page and capture settings:

1 . Select Files->Print to file and the desired image formatthrought the menu bar 
2 . Choose the location where you want to save the image
3 . Choose a name for the file
4 . Click on Save button

NOTE: This action could also be done by clicking on through the icon bar. This icon can also be found in the "Page and 

capture settings" window. In this case the image format is choosen while saving the file in the "Files of type" combobox.

1.1.5 Preprocess

1.1.5.1 Load a model

In the Files menu user can find the typical operations for managing the GiD projects like save a project, open an existing 
project, import and export files, print or quit the program. Most of this options are also accessible from the icons toolbar. 
The corresponding icon is shown in the menu, next to the option.

1 . Click on Files->Open... and select the GiD model gid_model_basic_course.gid. GiD also can load a model just 
with drag & drop.The following model should be loaded:
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1.1.5.2 Geometry and Mesh modes

In the preprocessing part of GiD there are two basic modes the user can work with: geometry and mesh. Just in order to 
see how the mode can be changed we are going to generate a mesh with all the default parameters.

1 . Select Mesh->Generate mesh... The following window should appear.

2 . Click OK and wait for the mesh generation. Once the mesh is generated, a window pops up and show the user the 
result from the mesh generation. 

3 . Click on 'View mesh' option, and the following visualization of the model should appear:
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Now we are in 'mesh' mode. Changing the render mode user can see that the color of the mesh entities also follows the 
Layer colors.
Selecting View->Mode->Geometry  user can change to the geometry mode again. The icon in the toolbar switch 

between both modes.

1.1.5.3 Entities information

1.1.5.3.1 Labels

Using the option Labels present in the View menu (and also in the right mouse button menu), user can see the number of 
the entities of the model. Either for points, lines, surfaces or volumes user can choose between viewing the numbers of all 
the entities, or just the selected ones.

In the following figure the model can be seen with the number of some entities:
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1.1.5.3.2 List entities

User have also the option of viewing all the characteristics of a specific entity by selecting List in the Utilities menu (or 
clicking in the icons toolbar).

For example:
1 . Select Utilities->List->Surfaces in the top menu
2 . Select some surfaces of the model
3 . Press Escape

An example of the information got using this option is the following figure:
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1.1.5.3.3 Signal

In complex geometrical models sometimes it is hard to localize an specific entity. Using the Signal  option in the 
Utilities menu user can know graphically where the entity is, as GiD shows with a red lines cross its potition.

As an example we will signal the line number 290:
1 . Selec Utilities->Signal->Lines
2 . Write in the Command bar the number 290 and click ENTER. The result is shown in the next figure:
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The red lines are centered always onto the specific entity independently on the rotations or view movements.

1.1.5.4 Layers and groups

A really useful way for organizing the different parts of the model is using 'Layers'. 
Open the Layers window by selecting the Utilities->Layer and groups option or clicking in the upper icons toolbar. 

The following window should raise up:

As it can be read in the upper part of the window, if user double click on that part, the Layers window is integrated in GiD 
window. User can choose to work with the Layers and groups window integrated or not.

All the actions related with layers and groups can be accessed by clicking the right mouse button onto the Layers and 
groups window. Most of them can be also used by the corresponding icon in the upper part of the Layers window.
By moving the mouse over the icons of the upper part of the window and staying 2 seconds onto an icon, a help message 
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is shown in order to give the user information about the action associated with the icon.

1.1.5.4.1 Create a layer

GiD allows to create a hierarchical structure of Layers, so as a Layer can contain sub-layers. Let's create a Layer into 
another one as an example:

1 . Select (using the left button of the mouse) the 'Layer6'.
2 . Select the New child option in the right mouse button menu, or click in the upper part of the Layers and groups 

window. Automatically, a layer named 'Layer0' should appear, as shown in the following figure:

1.1.5.4.2 Rename a layer

To rename a Layer user should select the layer in the Layers and groups window and press F2  key, or select the 
Rename option in the right mouse button menu.

1 . Select the Layer0
2 . Rename it to 'Auxiliar'

Now the Layers window should look like the following picture:
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1.1.5.4.3 Change the color of a layer

By clicking on the colored square next to each layer name, the following window pops-up, allowing the user to change the 
color of the layer:

Window to change the color of the layer.

1.1.5.4.4 Send entities to a layer

User can send entities to a specific layer. As an example we are going to send to the layer 'Auxiliar' a part of the model:

1 . Select the layer 'Auxiliar' in the Layers window
2 . Select the option Send to from the right mouse button (or click icon)

3 . Select All and select the volume shown in red in the following figure:
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4 . Then press Escape to exit the selection mode. 
5 . Set the render mode to Flat. The color of selected volume has changed to the one of the layer 'Auxiliar', as shown in 

the following figure:
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1.1.5.4.5 Switch on/off

By clicking on the icon which is next to each Layer inside the Layers and groups window, user can switch on and off the 
corresponding layer. This is very useful in order to visualize just some specific parts of the model.

1.1.5.4.6 Freeze a layer

At the right side of the bulb, user can set an icon which is a lock . If the lock is closed , the layer is frozen. If a layer is 
frozen, GiD won't apply anything to the entities of that layer. For instance, if user select some entities to be deleted, if they 
are into a frozen layer they won't be erased.

1.1.5.4.7 Transparency

Next to the 'lock' icon of each layer is the transparency icon . By clicking there, the user can set a layer to be 

transparent or not. The following figure shows the model with the Layer11 set as transparent:
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1.1.6 Postprocess

1.1.6.1 Load results

There are two ways to load the results simulation information into GiD:
 If the model has been calculated inside GiD, and so the results are inside a GiD project, then just loading the GiD 
project and the changing to postprocess mode is enough. This can be achieved clicking on this icon: , or 

selecting the Files->Postprocess menu entry.
 If only a mesh and results file(s) is present then GiD should be started, and switched to postprocess mode before 
loading the file(s).

In this case we will use the first option.
1 . Switch to postprocess mode:  or Files->Postprocess

1.1.6.2 Entities information

1.1.6.2.1 Labels

Using the option Label present in the View menu (and also in the right mouse button menu), user can see the number of 
the entities of the model. Either for nodes, elements or results user can choose between viewing the numbers of all the 
entities, or just the selected ones.

1.1.6.2.2 List entities

User have also the option of viewing all the characteristics of a specific entity by selecting List in the Utilities menu (or 
clicking in the icons toolbar).

For example:
1 . Select Utilities->List->Nodes in the top menu
2 . Select some nodes of the model
3 . Press Escape
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An example of the information got using this option is the following figure:

1.1.6.2.3 Signal

Using the Signal option in the Utilities menu user can know graphically where the entity is, as GiD shows with a red lines 
cross its potition.

As an example we will signal the element number 150.
1 . Selec Utilities->Signal->Element
2 . Write in the Command bar the number 150 and press ENTER. The result is shown in the next figure:

1.1.6.3 Select and display style

Through the Select & Display Style window several options can be specified for volumes, surfaces and cuts. Among these 
options volumes, surfaces and cuts can be switched on and off, their colour properties can be changed, and their 
transparency too.
Other interesting options which can be changed are the style of the set and the width of the elements' edges.
From this window, volumes, surfaces or cuts can be deleted or their names can be modified.
The Select & Display Style window can be integrated inside GiD interface, just double click on the upper bar of the window. 
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To tear it off again, double click the upper bar again.
1 . Select Window->View style... using the menu bar or clicking on 

1.1.6.3.1 Rename a layer

To rename a layer user should select the layer in the Select and display window and press F2  key, or press the 
Rename button.

1 . Select the Layer6
2 . Rename it to Aux

Now the Layers window should look like the following picture:
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1.1.6.3.2 Change the color of a layer

By clicking on the colored square next to each layer name, the following window pops-up, allowing the user to change the 
color of the layer:

1.1.6.3.3 Send entities to a layer

User can send entities to a specific layer. As an example we are going to send to the layer 'Test' a part of the model:

Our model only has 2 layer. We will create a new layer with some elements.
1 . Press button Send to->New set.
2 . Select some elements.
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3 . Press Escape. 
4 . A window appears asking for a name. Enter 'Test'.
5 . Press Accept. 

A new layer is created with the selected elements. Now we can change the color of the new layer.
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1.1.6.3.4 Switch on/off

By clicking on the icon which is next to each layer inside the Select and display window, user can switch on and off the 
corresponding layer. This is very useful in order to visualize just some specific parts of the model.

1.1.6.3.5 Style and transparency

By selecting one set and clicking on one corresponding style icon at the St  column or clicking on , the style for the 
selected mesh is changed. Bear in mind that a boundary visualization of the surface of a sphere nothing will be visualized, 
as a sphere surface has no borders.
Mesh styles can also be changed clicking on the icon , placed in the left icon bar. This style affects all sets of the model.
Next to the style icon of each layer is the transparency icon . By clicking there, the user can set a layer to be transparent 
or not. 

1 . Select SLayer11 6 and change the style to Body
2 . Set it to transparent

The model shoul look like this:
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1.2 Geometry creation and edition

1.2.1 Description

This tutorial is focused in the use of the basic geometric tools of GiD.
We will explain how to create a CAD model of the Egyptian construction shown in the figure below.

Egyptian funerary complex perspective

Some simplifications of the geometry are allowed. In the following parts of the course some schemes describe the 
dimensions of the simplified shape of the model 

We want to create a volume of a portion of the air around a control volume. We use a 300x200x100 m box so that the 
faces of the box are relatively distant from the temple (e.g. imagine that we want to run a CFD simulation analysis of the 
airflow around the building). 

1.2.2 Simplified model

In this section we will use the GiD facilities (creation of lines, surfaces, copy tool, use of layers, etc.) to create the 
geometry of the Egyptian construction shown following scheme (dimensions are in meters).
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Plant scheme

Profile scheme

The width of all the walls is 2 meters.

Of course, there is not a single way to build this shape. We will use several tools in this course which may not be the 



25Simplified model

optimal ones, but the objective is to show as more tools as possible for the geometry creation using GiD.

NOTE:  Not all dimensions are specified in the scheme, the undetermined ones should be approximated based on the 
images.

1.2.3 Points and lines creation

We will start creating the wall lines located the ground (plane z=0)

To facilitate visualization and selection tasks we will separate entities in several layers with this tree structure: 

Final layers structure.

We will start creating the lines of the plant, in the z=0 plane.

Be sure the layer in use is the 'walls' one. The layer in use is marked with a 'check' between the name and the color of the 
layer. To set the 'walls' layer as the layer in use just double click onto the name of the layer. 
New entities will be created in the current 'layer to use'.

1.2.3.1 Line creation

1 Choose the Line  option, by going to Geometry->Create->Straight line or by going to the GiD Toolbox (the GiD 
Toolbox is a window containing the icons for the most frequently executed operations. For information on a particular 
tool, click on the corresponding icon with the right mouse button).

2 . Enter the coordinates of the beginning and end points of the auxiliary line. The coordinates of a point may be entered 
on the command line  either with a space or a comma between them (but not both). If the Z coordinate is not 
entered, it is considered 0 by default. After entering the coordinates of one point, press Return. Another option for 
entering a point is using the Coordinates Window, found in Utilities->Tools->Coordinates window...

For our example our coordinated origin will be set at the lower-left of the bounding box of the building, and we will create 
the lower line that starts at x=10 and ends at x=10+35=45 units, the coordinates are then (10,0) and (45,0) respectively. 
Besides creating a straight line, this operation implies creating the end points of the line.
Write then:

10,0<Return>
45,0<Return>

3 . Press <Esc> twice to indicate that the process of creating the line is finished. (Pressing the <Esc> key is equivalent 
to pressing the center mouse button).

4 . If the entire line does not appear on the screen, use the Zoom Frame option, which is located in the GiD Toolbox and 
in Zoom option in the mouse menu.

Figure 6. Creating a straight line

NOTE: When creating a line, after clicking the first point, you can press the Alt key to snap the dynamic line to the screen 
horizontal, vertical or 45º diagonals.

NOTE: The Undo option, located in Utilities->Undo, enables you to undo the most recent operations. When this option is 
selected, a window appears in which all the operations to be undone can be selected.
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1.2.3.2 Join NoJoin option

When generating geometry, very often it is needed to select some point: a new one (like the ones that have been defined 
in the previous steps for defining the lines), or an existing one. When an already existing point is wanted to be selected, 
user must go to Contextual->Join Ctrl-a in the mouse menu (right-click) 

Contextual menu when expecting a point

(or pressing <Ctrl>+a). The pointer will become a square, which means that you may click an existing point. User can 
change alternatively between both modes: (clicking an existing point or a new one) in the same selection process.

1 Choose the Line option, by going to Geometry->Create->Straight line or by going to the GiD Toolbox.
2 Press <Ctrl>+a to select an existing point (ensure the mouse pointer is square-like)
3 Click on the point on the left.
4 Press <Ctrl>+a again to select now new points (ensure the mouse pointer is now a cross)
5 Then enter the following points by coordinates (like in the previous steps):

10,33
0,33

6 Press <Esc> twice to indicate that the process of creating lines is finished. 

Now the model should look like the figure.

State of the model geometry at this point.

1.2.3.3 Relative coordinates

In GiD there are two ways of defining the coordinates of a point: absolutely (like all the coordinates we have entered since 
now in this course) or relatively to the last point entered (using @ symbol). We will now enter a point using this second 
option, which is very useful when points wants to be entered knowing some distance.
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1 Choose the Line option, by going to Geometry->Create->Straight line or by going to the GiD Toolbox.
2 Press <Ctrl>+a to select an existing point (ensure the mouse pointer is square-like), and select the point which is 

more at the left in the model.
3 Press <Ctrl>+a to select a new point (ensure the mouse pointer is a cross).
4 Enter the following relative coordinates: (@0,72)
5 Press <Esc> two times to leave the line creation mode.

ine created with a length of 72 meters, entered as a relative 
coordinate to its second point.

As it can be seen in the figure, the new point has been created at 16 meters (as the relative coordinates indicated) of 
distance from the first selected.

1.2.3.4 Copy tool

Another useful option for creation of geometry is using the different geometrical transformations GiD offer in the Copy and 
Move windows.

Now we are going to copy the upper point translated 55 m in x direction, and creating a line between the source and 
destination point by extrussion.

1 Use the Copy window, which is located in Utilities->Copy (you can access that window also using the icon from the 
Toolbox, or the keys <Ctrl-Shift-C>).

2 Within the Copy menu and from among the Transformation  possibilities, select Translation . The type of entity to 
receive the translation is a line, so from the Entities type menu, choose Points. 

3 We want to make a translation of 55 units in the x direction, so we should leave the coordinates of the First Point at 
(0,0,0), and set the coordinates of the Second point at (55,0,0) (the translation is defined with the relative vector 
from the first to the second point)

4 Do extrude: set to Lines
5 The following options of the window should be the same as the ones in the figure.
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Copy options to be used.

6 Click on Select and select the point to be copied (the upper-left point)
7 Press <Esc> to exit the selection mode.

You would get the model like the one showed in next figure.
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State of the model at this point.

With the copy tool wecan create the lines on the right with a copy by symmetry, around an axis on x=27.5.
Set Entities type to be selected as Lines, Transformation as Mirror
Check Two dimensions to define the symmetry only with two points on the axis (instead of the 3D case that require three 
points on the symmetry plane)
Set two axis points, like (27.5,0,0) and (27.5,1,0)
and select the lines in red to be copied.
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Copy lines by symmetry

Finally create another line to split the shape in two rectangles

1.2.3.5 Offset

The walls have a width of 2 meters, now we will build the inner perimeter using the Copy tool with 'Offset'

And now we will orient all curves of the upper rectangle coherently (e.g. all clockwise or all counter-clockwise), to be able 
to do a copy by offset.

use: Utilities->Swap normals->Lines->Select
And select all lines, then are drawn an arrow in cyan, representing the curve tangent, and a pink arrow representing the 
normal (defined for 2D planar curves only, rotating tangent 90 degrees to the left, around the z axis).
Click the lines to be swapped to point all pink arrows inside the upper rectangle
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The offset factor is positive pointing to the line normals direction, or negative in the opposite one. When selecting the lines 
to be copied we see its orientation. We can cancel the copy deselecting all before finish (can do it with "Clear selection" of 
the contextual menu)

Repeat the operation for the lower rectangle, obtaining this result
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Inner perimeter created by two offsets.

1.2.3.6 Intersection

To create the square of the pyramid we know the distances to the boundary, we can use the copy by translation to create 
some auxiliary lines, and then intersect them with
Geometry->Edit->Intersection->Lines

And then delete the unwanted lines.



33Intersection

Geometry->Delete->Lines
then in the contextual menu (right-mouse button) select Lower Entities
to delete also the points that become isolated after the deletion.

1.2.3.7 Finalize the lines creation

Now you should complete the remaining geometry until obtaining a figure similar to the one shown below. Use the 
explained geometrical operations to complete by you own the geometrical definition of it.

It may be useful for you to use some other geometrical operations, like the ones present in Geometry menu. They are easy 
to use, and its names are intended to be self-explicative, we encourage you to try some of them for the creation of the 
geometry (e.g. division, intersection of lines, deletion, collapse of points, etc.)

Current state of the model.

1.2.4 Surface creation

In the following points we are going to complete the geometrical model definition using different surface creation 
techniques.

1.2.4.1 Extrusion of walls

For creating the walls we will use the translation tool inside Copy window for the extrusion of the lateral surfaces, and then 
create the top surfaces.
First of all let's use the Rotate  function (Rotate->Trackball  from the mouse right button menu, or clicking the 
corresponding icon ) to see the lines of the model from a different point of view, which will help us to understand the 

model.

Ensure the active layer is the one named 'walls' and follow the next steps:

1 Open the Copy  window, which is located in Utilities->Copy (you can access that window also using the icon from 
the Toolbox).

2 We are going to apply a translation of 5 units in z direction to all the lines. For this purpose ensure all the options of 
the window are like the ones showed in the figure.
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Options to be applied

3 Select the lines of shown in next figure and click on Finish button. The result should be like showed in the other figure 
(with render flat)

Take care on the different visualization modes that can be used for visualizing the geometry. This options are Normal, 
Flat and Smooth, and can be selected from the Render option in the mouse right button menu.

Note: in Flat render mode surfaces are painted with the layer color. Don't worry if you are seeing different colors, layer 
colors could be changed.

1.2.4.2 Creation top of walls

Now we have created the lateral surfaces of the walls, and we must create the top surface.

We have all the contour lines of the surfaces to be created, so we have several options of creating them. The simplest one 
is to select Geometry->Create->NURBS surface->By contour (or clicking the corresponding icon), and select all the 
contour lines which define the contour of the surface. 
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We need to select as boundary all curves on z=5, an easy way to select them is to set an appropiated view, like 
Rotate->Plane XZ
then select with a box all upper lines, and unselect with another box the unwanted vertical curves.

The lines to select to create the top planar surface

1.2.4.3 Creation of the pyramid

We are going to create the pyramid in the layer named 'pyramid', so you have to set this layer as the one in use.

For creating the pyramid, first of all we need to create the vertex of it, and need to calculate its coordinates.
You know that the total height of the pyramid is 30 meters, but you don't know the x,y coordinates of the projection on the 
ground.
You can calculate it as the midpoint bethween two diagonal points.
Open the calculator with 
Utilities->Tools->Calculator...

Calculator window after select two diagonal corners.

Select the More...->Get point and click a corner of a 
diagonal
their coordinates will appear in the calculator
8.0,98.0,0.0
Repeat it and now get the opposite diagonal corner.
47.0,59.0,0.0
now to calculate the sum pressing button +
now to divide by 2 enter this number pressing the 
buttons 
2 Ent
and pres the button
/
the vector result is shown
27.5,78.5,0.0
to send this value to the GiD comand line press
More...>Write

1 Select Geometry->Create->Point and modify in the command line the coordinates changing z=0 to z=30
27.5,78.5,0.0 
and press enter to create the point with this coordinates

Note that the points can only be seen in Render Normal (not in Flat or Smooth mode).
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2 Then create one straight line from each vertex of the quadrilateral base of the pyramid to the vertex of the pyramid.

For creating the lateral surfaces of the pyramid:
3 Select Geometry->Create->NURBS surface->By contour (or click the corresponding icon), select the three lines of 

one face of the pyramid and press <Esc>.

Manual creation of a surface of the pyramid

For simple geometry configurations, GiD can detect the contour lines of a possible surface automatically. We will use this 
option.

Select again Geometry->Create->NURBS surface->By contour. 
But now click on the right mouse button and select Search in the Contextual menu.
Then click once for example the lines of the base of the pyramid (a line of the desired surface)
As you can see, each time you click a line, GiD find automatically the other lines which close a surface parting from the 
selected line.

1.2.4.4 Creation of ground surface

We should define the limits of the domain into where the simulation will be done. This limits should be far enough from the 
model to avoid the effect of the boundary conditions in the results.
We are going to create now the surface of the ground of 200x300 m. 

1 Set the 'ground_outer' layer as the one in use.
2 Create a rectangular surface: Geometry->Create->Object->Rectangle

with a corner at (-70,-100,0) and the opposite corner at relative coordinates (@200,300,0)
And we will add a hole to this surface
Geometry->Edit->Hole NURBS surface
then select the surface to be holed
and then select the trimming lines 
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The rectangle holed

Then Set the 'ground_inner' layer as the one in use and create the other missing surfaces of the ground.

Creation of the 'ground_inner' surfaces

1.2.4.5 Creation of control volume surfaces

For creating the outer surfaces of the control volume we will use again the Translation tool of the Copy window.

1 Set the 'air//surfaces' layer as the one in use.
2 Open the Copy   window, which is located in Utilities->Copy, and set all the values of the parameters as the ones 

showed in the figure. Note that the 'Maintain layers' checkbutton is unset, to create the new entities in the current 
layer to use instead of the layer of its source entity.
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Parameters to be used for the extrusion of 
the outer lines of ground surface.

3 Select the 4 outer lines of the ground surface and press Finish.
Now the lateral surfaces of the control volume have been created.

4 Create the top surface of the control volume by its boundary lines, and the model should be like the one showed in the 
figure.

State of the model creation at this point.

Note that you can apply transparency to one Layer by clicking in the icon placed on the right part of the corresponding 
layer in the Layer Window. 
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1.2.5 Volume creation

Due to the hierarchical definition of the geometry inside GiD, a volume require to have a closed path of surfaces closing it. 
For ensuring that a path of surfaces is water-tight (closed), GiD offers one graphical tool (Higher entities) which is very 
useful. 

1 Click on View->Higher entities->Lines. You should obtain the information of how many surfaces own each line. In 
this case all the values should be 2, like is shown in next figure.

Higher entities of the lines of the model.

Press <Esc> to return to the normal render mode.

The last step for the geometry creation of this model is create the volume:
2 Select Geometry->Create->Volume->By contour  and select all the surfaces of the model except the upper 

rectangle (simulating an user selection error).
Then a window like this is showed (the number of entities could be different depending on the way of create the geometry)

Lines of the surface missing to close a volume

The meaning of this 'ugly message' is that the volume is not closing topologically in the printed entities. You can use 
copy/paste of the last list of line ids "125 126 127 128" to set on its labels and identify visually the problem.
View->Label->Selected->Lines
125 126 127 128
and you will see that just are the lines of the missing surface.

3 Repeat the creation of the volume, but now seelction all surfaces, then press ESC, and the volume should be created. 
Note that the volume (using GiD Normal render mode) is represented by a light blue line following the contour lines.

Now the geometrical model is finished, and should look like the one presented in the figure.
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Geometrical model finished.

Save this gid project with Files->Save as.. with the name 'Pyramid_geometry'

It is recommended to try to generate a coarse mesh to be sure that all is ok and they are not geometric problems for a 
future simulation.
E.g. use Mesh->Generate mesh...  with a general meshing size=20 m, you must obtain a mesh with only tetrahedra 
elements.
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1.3 Meshing basic features

This course is focused in the basic meshing features of GiD. 

To follow this course, the model gid_model_basic_meshing_course.gid  must be loaded from the folder where the 
courses material is.

View of the model used for this course.

1.3.1 Default settings

First of all we should reset all the meshing preferences in order to ensure the meshing options got from GiD are the same 
as the ones needed to reproduce exactly this course. For this purpose:

 Open the preferences window (Utilities->Preferences)
 Set the 'Meshing' branch.
 Shift+select last child of the branch: "Other".
 After selecting all meshing childs right click and select "Default values on selection"
 You will need to Apply changes by clicking on "Apply" button
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If user does not assign any meshing property to the model, GiD assigns an automatic mesh size based on the size of the 
model. Elements by default are triangles (for surfaces) and tetrahedra (for volumes) and the mesh is unstructured. Let's 
have a look at this first automatic mesh.

 Select the option 'Generate mesh...' from the 'Mesh' menu.
 A window will appear asking for the mesh size to be used. For this model, the value proposed by GiD by default is 1. 
In this window also appears the option 'Get meshing parameters from model'. If this option is set, GiD load the 
meshing parameters used the last time the model was meshed. Now unset this option, and click OK.
 A window will pop up giving the basic information of the result mesh (number of nodes and elements, memory 
consumed, etc.). Click on 'View mesh' and the following mesh should be shown:
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Mesh got using the default options of GiD

1.3.2 Quadratic type

User can choose between different quadratic element types by selecting the 'Quadratic type' option in the 'Mesh' menu. 

 'Normal' option corresponds to the linear elements.
 'Quadratic' option corresponds to the linear element with quadratic nodes in the middle of its edges.
 'Quadratic9' option is like the Quadratic one, but with quadratic nodes also in the center of the faces of the element, 
and the center of the element. This quadratic type is only applied to quadrilateral or hexahedra.

Let's make a quadratic mesh of the model.

 Select 'Quadratic' as the quadratic type in the mesh menu. 
 Then generate the mesh again. The resultant mesh should look like the previous one, but if we zoom in at some area 
and we label all the nodes we should see that the elements are quadratic:
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Detail of the mesh of a surface of the model, where all the nodes are labeled, so the quadratic nodes can be seen.

1.3.3 Types of meshes

Different kinds of meshes can be generated using GiD, depending on the topology required: Cartesian, structured, 
semi-strucrtured and unstructured. 
Set as 'Normal' the Quadratic type of the mesh (from Mesh mesnu) in order to reach the same meshes as the shown in this 
chapter.

1.3.3.1 Unstructured mesh

1.3.3.1.1 Assign sizes

As said in previous steps, the default mesh generated by GiD is a unstructured mesh, and a general size is set to the whole 
model. However, it is possible to refine specific regions of the model by assigning different sizes to the geometrical entities. 
Let's see it in an example where the entities labeled in the following figure will have different size assigned.
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Entities to be selected in the following steps to assign mesh size.

 Select the 'Unstructured->Assign sizes on surfaces' in the 'Mesh' menu, and set 0.2 in the appearing window.
 Click on Assign and assign the surface number 10. Then press ESCAPE to finish the selection, and close the size 
window.
 Select the 'Unstructured->Assign sizes on points' in the 'Mesh' menu and set 0.05 to the point number 22. Then press 
ESCAPE to finish the selection, and close the size window.
 Generate the mesh again (Mesh->Generate mesh), and the following mesh should appear.



46Assign sizes

Result mesh of the model once some specific sizes have been assigned.

1.3.3.1.2 Size transition factor

When different unstructured mesh sizes are present in the model, a transition between them is applied in the unstructured 
mesh. User can control whether this transition is smoother or sharper by the 'Unstructured size transitions factor' present 
in the 'Meshing' branch of 'Preferences' window (Utilities->Preferences).

 Open the preferences window (in the 'Utilities' menu) and set the 'Unstructured size transitions factor' to 0.2. Click 
'Apply' and close the preferences window. Then generate the mesh again (Mesh->Generate mesh).
 Repeat the operation setting the 'Unstructured size transitions factor' to 0.9 to see the difference between the 
resultant meshes. Those meshes are shown in the next figure.

Mesh using 0.2 as unstructured size transition factor.

Mesh using 0.9 as unstructured size transition factor.

1.3.3.1.3 Surface meshers

This is a very simple geometrical model, but user may see the difference between the two main unstructured surface 
meshers available in GiD: RFast and RSurf.
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RFast mesher generates the mesh of the surface in the 2D iso-parametric space of the surface, and RSurf generates it 
directly in the 3D space. This characteristics gives to that meshers two basic properties: 

 RFast mesher is faster, but in some cases it may give worse quality elements.
 RSurf mesher is slower, but in general gives a better quality elements, in special in case of curved surfaces.

In this model the only curved surfaces are the ones of the sphere, and it is hard to see the difference of quality between 
both meshers. However we can see a slight difference between them. 

 Open the 'Preferences' window (from the 'Utilities' menu) and set the RFast mesher in the Meshing branch. Set the 
'Unstructured size transitions' factor to 0.6.
 Apply changes and generate the mesh.
 Repeat this process setting RSurf as surface unstructured mesher.

In the following figure the results meshes of the sphere are shown using RFast an RSurf meshers:

Mesh of the sphere of the model using RFast mesher. Mesh of the sphere of the model using RSurf mesher.

In complex geometrical models in which the surfaces curvatures are important it is strongly recommended to use RSurf 
mesher in order to get a high-quality final mesh.

1.3.3.1.4 Volume meshers

GiD has three unstructured volume meshers (all of them generating tetrahedra): Advancing front, Tetgen and Octree.
The main characteristics of them are the following ones:

Advancing front: it is based on advancing front technique. It may be slow, but it typically generates better quality of 
elements.
Tetgen: it is based on Delaunay method, and it is faster than the previous one. In some cases it may lead to poor 
quality elements near the boundaries of the volumes.
Octree: it is an octree-based mesher, which is very fast and robust. This mesher can skip lines which are part of the 
contours of the volume, if they have no specific property assigned.

First of all, reset the meshing data (Mesh->Reset mesh data).

We will focus on the sphere volume (volume number 3). For this purpose we will not mesh the rest of the entities. So, set 
'Mesh->Mesh criteria->No mesh' and select the other volumes of the model, as well as the isolated surface (surface 
number 18).

In order to appreciate better the difference between the difference volumes meshers, let's unset the 'Automatic correct 
sizes' in the Mesh branch of the Preferences window (set it to None). Set also as unstructured surface mesher the RSurf 
one.

 Generate the mesh of the model with a size of 0.2 setting the three types of unstructured volume mesher (one mesh 
for each mesher). The results of the mesh are shown in the following figure:
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Mesh generated with Advancing front 
mesher Mesh generated with Tetgen mesher

Mesh generated with Octree mesher

One can appreciate that the different meshers generate different number of elements, and they are not equally fast.

Looking at these three meshes, the external view of the ones generated by Advancing front and Tetgen is the same, as 
they are constrained meshers and they use the same surface mesh as an input. This is not the case of the Octree mesh, 
where the regular grid of the octree structure can be appreciated in the nodes distribution.

It can be also seen that the lines of the volume surfaces are not represented in the mesh comming from the octree 
mesher.

1.3.3.2 Structured mesh

Structured meshes can also be generated in GiD. Structured meshes are the ones got from a predefined pattern, and they 
are restrictive in the topology of the geometrical entities they are applied in.

 Structured surfaces must be '4-sided' surfaces; this means that they must have four lines, or four clear angles close to 
90 degrees, so as the mesher could make a topological correspondance between the contour of the surface and a 
square.
 Structured volumes must have 6 contour surfaces (the mesher will make a topological correspondance between the 
volume and a cube).

Let's see an example of how to assign this meshing property, but first of all it is better to unassign the previously assigned 
meshing properties to focus just in this structured part.

 In order to unassign the mesh properties assigned to the model click on the 'Reset mesh data' option in the 'Mesh' 
menu.

Lets assign structured meshing type to the volume number 5 and surface number 10 (shown in the following figure).
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Entities to be set as structured.

In order to set a structured mesh onto a geometrical entity, the number of divisions (or the size) in its contour lines must 
be set.

 Select 'Mesh->Structured->Surfaces->Assign number of cells' and select the surface number 10. Then press ESCAPE 
to leave the selection mode.
 Set the number of divisions to 3 and select all its contour lines.
 Select 'Mesh->Structured->Volumes->Assign size' and select the volume number 5. Then press ESCAPE to leave the 
selection mode.
 Set a size of 0.5 and select the contour lines of the volume.
 Now generate the mesh again, and the result mesh should be like the one showed in the following figure:
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View of the structured mesh of some entities of the model

The structured pattern of elements is clearly recognized in the entities we have selected.

Different number of divisions can be set to the different structured directions of the entities. You can try to set different 
numbers and see how the final mesh changes.

In case of triangles and tetrahedra, the structured mesh comes from an internal splitting of an intermediate mesh made of 
quadrilateral or hexahedra. The way these elements are splitted can be symmetrical or not, depending on the 'Symmetrical 
structured' variable of the Meshing branch of Preferences window.
Setting the tetrahedra to be symmetric, for example, would give a mesh like the shown in hereafter:
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View of the structured mesh of some entities of the model, seting as 'Symmetric structured' the tetrahedra.

1.3.3.3 Semi-structured mesh

Semi-structured meshes can be applied to volumes. This kind of meshes follows a prismatic topology, so these volumes 
must be prismatic: two tops can be identified, as well as a number of lateral surfaces (which must be able to be meshed as 
structured). 

In the model of this course, the volumes number 1, 4 and 5 are prismatic, so they can be meshed with semi-structured 
volume.

 Again, reset the mesh data previously assigned (Mesh->Reset mesh data).

Let's make semi-structured the volumes 1 and 4.

 Select Mesh->SemiStructured volumes and set as 4 the number of divisions to be assigned.
 Then select volumes number 1 and 4 and press ESCAPE to leave the selection mode.
 Generate the mesh. The result should be as the one showed in the following figure:
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Detail of the semi-structured mesh of the volumes 1 and 4.

1.3.3.3.1 Change structured direction

Volume number 1 is topologically prismatic only in one direction, but volume number 4 is prismatic in its 3 directions (as is 
has 6 boundary surfaces). The structured direction of volume 4 has been set automatically by GiD, but user may want to 
set another one.

 Select Mesh->SemiStructured->Set->Structured direction. Then select line 25 (the line labeled in the next figure).

Line 25, to be set as structured direction.

 Generate the mesh again. The resulting mesh should be as this one:
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Semi-structured mesh when structured direction of volume 4 is the one defined by line 25.

GiD offers two options to force the structured direction of a semi-structured volume: set the structured direction via a line 
following that direction (the option just done before), or set one of the tops of the prism 
('Mesh->SemiStructured->Set->Master surface').

1.3.4 Element types

The different element types GiD can generate are the following ones:

 Surface: triangle, quadrilateral, circle
 Volume: tetrahedra, hexahedra (only structured or semi-structured mesh), prism (only structured or semi-structured 
mesh), spheres and points.

Apart from the specific requirements in terms of kind of mesh for the hexahedra and prism elements for volumes, selecting 
an element type is as easy as going to the 'Mesh' menu, setting the 'Element type' and select the desired entities.

In order to see different types of elements on this model follow this steps:

 Reset previous mesh data (Mesh->Reset mesh data).
 Set as structured volume number 4, with 5 divisions in its contour lines.
 Set as semi-structured volume number 5 with 5 structured divisions.
 Set Hexahedra as element type for volume number 4.
 Set 'Sphere' as element type of the spherical volume (volume number 3).
 Set 'Quadrilateral' as element type of surface number 18.

To check the element types (or other meshing properties) assigned to the model graphically, the 'Draw' option in the 
'Mesh' menu is really useful.

 Select Draw->Element type->Volumes in order to check the element types assigned. The result image should be like 
the following one:
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Different element types assigned to the model volumes shown using the Mesh->Draw option.

 Generate the mesh. The resulting mesh should be like the one showed in the following figure:

View of the mesh generated with the different element types assigned.

Note that the element type of volume 5 is prism, but the user has not set it. Just before mesh generation, GiD makes 
compatible the element types of the geometrical entities in order to fit the user requirements.
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1.4 Run a CFD simulation

The model to be calculated is the flow of the air around a pyramid building.
Files->Open...
and select the pyramid_geometry model.
Then it is time to load the CFD calculation problem type and assign the material properties and the conditions to the 
geometry, so as the simulation could be run.

We won't focus this course in the simulation itself or the parameters needed for it, but only in the way of assigning 
properties and how to run a simulation within GiD.

The boundary conditions and physical properties to use in this simulation are:
Fluid physical properties: air at 25ºC.
Density: 1.17 Kg/m3

Dynamic viscosity = 1.8e-5 Kg/m·s

1.4.1 Load problem type

For loading the problem type you should go to the Data->Problem types menu and select CompassFEM

The start data window of the problem type appears. We are going to run a simulation of a 3D fluid flow, so we must 
uncheck Flow in Solids option, which is in the Selected Problem part (right side of the window). The window should look 
like the showed in the figure, and you can click OK.

Options to be set when loading the CompassFEM module.
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You can see that a new icons bar appear in the left side of the window. This is the problemtype toolbar.

1.4.2 Create groups

The boundary conditions and materials are assigned to different selection of entities, called groups.
A group is basically a collection of geometry/mesh entities with a name

Is is possible to create 'a priori' the groups or create them 'atomatically' during a selection that apply a boundary condition 
(an automatic name is provided, but could be changed when validating the selection)

It could seem easier the 'automatic way', specially for few conditions and a small model, but in general is more 
recommendable the 'a priori' creation of groups, setting them appropiated names.

The groups window of CompassFEM is opened by the icon  or the menu Data->Groups

Create the following group names

The groups to be created

and assign them the geometrical entities suggested by its name

e.g. select the 'Air_volume' group, press the icon and select 'Volumes' in its menu and click the volume (clicking its 
'cyan representation') and press Finish (or <Esc>) to end the selection

Set the appropiated geometry entities for all groups. 
We want as inlet surface the one with minimum Y coordinate of this model.
It is possible to have a feedback selecting group names, and pressing to be drawn by colors, like the image of the 

surfaces of three of the groups.
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Drawing groups by colors

1.4.3 Fluid material

Materials and properties->Fluid
For applying the fluid material properties click on the  icon of the problem type toolbar.

You can see that a window (like the one showed in the figure) is opened with a data tree containing all the information 
required for the simulation.

Tdyn data window.

Click twice onto Fluid  material, and you will see in the lower part of the window a field where to put the material. Select 
Air_25oC and select in the combo box the group named 'Air_volume', then press Ok to accept the changes.
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Note: If the group was not created is possible to create it with the groups window, as explained before, or to clicking 
Select and selecting the volume and press Finish to end the selection, then the automatic name of the group created could 
be changed and pressing Ok to accept it.

The properties of the fluid corresponding to Air_25oC could be seen and edited (if needed) by clicking on the Physical 
properties branch of the data tree.

1.4.4 Fluid boundary

Conditions and initial data->Fluid flow
Click on icon for applying the Fluid Boundary properties. 

First of all we are going to force the fluid to have null velocity in the 'solid' surfaces of the model, which are the ones of the 
building and the ground.

Click on Wall/Bodies and a window will appear in the lower part with some data. 
In Wall thype Select V FixWall in the Boundary type field.
Set as Group 'Ground_surfaces' and click OK to accept it.
Repeat the same to set as V FixWall also the group 'Building_surfaces'

Now we are going to set the conditions for the outlet surface (the face of the control volume with maximum Y coordinate).

Select the Outlet option (click twice) in Fluid flow branch.
Ensure the options set are

Outlet of: Fluid
Bound. Type: OutletPres
Press Field: 0.0 Pa

Set the 'Outlet_surfaces' group and click Ok.

1.4.5 Initial data

Conditions and initial data->Initial and conditional data->Initial and field data
An initial uniform velocity with Y axis direction must be set as initial data (time=0).

Click twice onto the Initial and Field data option of Conditions and initial data->Initial and conditional 
data branch of the data tree. 
Set to 1 m/s the y component of the initial velocity field on the whole domain.

Ensure the options are the same as the ones showed in the figure and click OK.

Initial data to be set for the simulation.

1.4.6 Boundary conditions

Conditions and initial data->Fluid flow

The velocity field must be fixed on lateral and top surfaces of the control volume to have a flux parallel to these surfaces, 
'far enougth' of the building. For this purpose:
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Click on Velocity field option (inside Conditions and initial data->Fluid flow options in the data tree).
Set the Fix field X option
Click on surfaces type (this indicates the type of geometrical entities to be selected).
Set the group 'Lateral_surfaces' and click OK.

This set the x component of the velocity by default to 0

Repeat the same but now setting Fix field Z for the group 'Top_surfaces'

We should now fix the velocity field in the inlet surface. We want to maintain its three components equal to the initial one 
(1m/s in +Y direction). For this purpose:

Click on Velocity field and set as fixed the Field in X, Y and Z direction.
Click on surfaces and select the 'Inlet_surfaces' group and click OK.

Now the velocity field is fixed, but as default it is fixed to 0. We want to set the Y component equal to 1 m/s in the inlet 
surface

Click on Fix velocity component and set the Y Axis to 1 m/s.
Click on surfaces and select the 'Inlet_surfaces' group and click OK.

1.4.7 General data

Fluid dynamics data->Analysis
Now it is time to set the general data for the solver, like solver parameters, etc.

The default values in Fluid dynamics data->Analysis data section of the data tree should be correct. We are going to 
modify some. For this purpose click on Analysis part and fill the values like the ones showed in the figure.

Values for the Analysis data.

This mean that we are going to simulate 200*0.1=20 seconds of the CFD analysis.

1.4.8 Check properties assigned

Clicking on the tree with the right-mouse button, user can check the information assigned to the model, drawing with 
colors the different conditions, materials, etc... (contextual menu: Draw->Draw groups...)

Tree items with data applied to groups are highlighted in bold characters

Note that Tdyn includes its own help menu, where there can be found the meaning of the fields of the conditions, 
materials, theory, etc., as well as some tutorials that can be interesting to learn to use it.
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1.4.9 Calculation

For CFD simulations usually is important to avoid tetrahedra that have all its nodes in boundary parts set to have for 
example velocity=0, because in this case the value in the whole tetrahedron become=0 and it is like the element doesn't 
exists and provide numerical problems.
It is then interesting to set in Utilities->Preferences a meshing option that try to avoid this case in the mesh to be 
generated:

Meshing preference to avoid elements with all nodes in the boundary

It is necessary to generate a FEM mesh for the analysis, to do it press the icon and accept the default values.

The mesh will inherit the groups assigned to its source geometrical entities.

A coarse mesh will be created with these values. Tdyn allow to do this calculation with a small mesh without require any 
licence (else the program must be licenced)

Set Fluid dynamics data->Results Results file: Ascii, in order to be able to see the results with any text editor, and to be 
read by 'traditional posprocess'

Before beginning the calculation it is needed to save the model (Files->Save as...).
and save it as 'pyramid_tdyn' (to allow the solver write its results in this location)

Then go to the menu Calculate->Calculate, and the calculation process will begin. User can check the status of the 
calculation by selecting Calculate->View process info.

Once the calculation is finished, a window appears.

Tdyn has its own postprocess tools or it can use the 'Traditional post' (GiD standard postprocess) that will be explained in 
next tutorials.
Use Postprocess->Start traditional post to switch to GiD postprocess to visualize the results.
Don't worry about the quality of the results of this example, because it has been calculated with a too coarse mesh and 
with a big time step to be run fast.
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1.5 Results visualization

1.5.1 Description

The objective of this course is to do a postprocess analysis 
of an already calculated fluid simulation. The simulation is 
the one run at the basic preprocess course, but we are 
going to open another model, which is already meshed (and 
the constraints are assigned) and also the results have been 
calculated. The reason for useing this other model is to 
ensure all the participants have the same results, which will 
make more easier to follow the course.

In this course, the project pyramid.gid will be used. The 
solver used to do this simulations is Tdyn3D, particularly the 
Ransol model. Tdyn3D is a fluid dynamic (CFD) simulation 
environment based on the stabilized Finite Element Method.

Steps followed in this course:
Loading the model
Changing mesh styles
Visualization of results
Creating images

1.5.2 Loading the model

In this course we will use the pyramid project, so the steps to follow are:
1 . Start GiD
2 . Open the pyramid.gid project with: Files->Open, Ctrl-o or clicking on

3 . Switch to postprocess mode: or Files->Postprocess

4 . Select Utilities->Preferences
5 . In General branch choose Normal in the Popup messages option to avoid some popups messages

1.5.3 Changing mesh styles

Menu
Window->View style...

Description
1 . Select Window->View style... using the menu bar or clicking on 
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Our model is composed by 4 layers. In order to get a better visualization we will disable the volume layer.
2 . Select the Layer0 layer and switch it off
3 . Select the Layer8 layer and switch it on
4 . Click on the icon in the Tr column or click on the . Click on Close button

Play a little with the options of these windows, but to continue the tutorial, let a Body Bound style selected for all meshes

1.5.4 Viewing the results

Menu
View Results
Window->View Results...
Utilities->Preferences->Postprocess branch

Description
Several results had been calculated for several time steps. You can check these results through the View Results menu or 
opening the View Results window.
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The options related with the results visualization can be changed through the Prefereces  window, in the Postprocess 
branch. When you change an option this one turns to red before apply. To apply the changes click on Apply button. 
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1.5.4.1 Iso surfaces and animations

Model used
The model pyramid.gid used in this example can be found at Material location.

Menu
View results->Iso Surfaces

Description
With this result's visualization a surface, or line, is drawn passing through all the points which have the same result's value 
inside a volume mesh, or surface mesh. To create isosurfaces there are several options.

1 . From preprocess mode open the model
2 . Switch to postprocess mode
3 . Turn off the Layer0 and Layer8 in order to get a better view
4 . Set as Body Bound the layers style
5 . Select the 12.5 step through View results->Default Analysis/Step->RANSOL->12.5 or clicking on 

6 . Select View results->Iso Surfaces->Automatic Width->Pressure(Pa) through the menu bar or clicking on 

After choosing the result, you are asked for a width. This width is used to create as many isosurfaces as are needed 
between the Minimum and Maximum defined values (these are included). 

7 . Select the default value 0.182341

Several configuration options can be set via the Options menu.

Menu
Utilities->Preferences->Postprocess->Iso surfaces
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In order to see the inner zones we will set the transparency on the iso surfaces. 
1 . For Transparency option select Transparent
2 . Move the model to see the inner zones
3 . For Transparency option select Opaque
4 . In order to improve the visualization and to get a more realistic view select View->Render->Smooth

Other interesting options are:
Geometry->Convert to sets->Iso surfaces which consolidates the isosurface as mesh which can be exported to a 
file.
Utilities->Preferences->Postprocess->Iso surfaces->Color mode->Contour fill color  allows to draw the 
contour fill of any result over the isosurface. Select this option and then do a contour fill of any result.
Utilities->Preferences->Postprocess->Iso surfaces->Show isolines  this options allows the user to switch 
isolines of surafaces on or off.

Menu 
Window->Animate

Description
This window allows the user to animate the current visualized results.
If only one step is present, then the Static analysis animation profile  button is enabled so that a custom animation 
profile can be step to animate that one step.
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If one result has several steps you can visualize them in an animation. In this case we will use the iso surfaces result.
1 . Select Window->Animate... to open the animation window

Please notice that we have from step 1 to 9. We will do the animation only of some of these steps.
2 . Check the From step option and set 3 to step 9
3 . Select the Delay between steps option and set it to 650 ms. The animation should take around 4 seconds
4 . Try it clicking on the play icon

We will record a video during the animation.
5 . Once the animation is finished check the Save option

You can choose from several video formats.
6 . Select AVI/mjpeg
7 . Please select a folder where the video will be saved clicking on the folder icon or writing the path
8 . Please click on the play button and the recording will begin. This step could take a little bit long. Wait until the red 

circle turns to green
9 . Close the Animate window

Now we will visualize another result but before we will clear all the results. 
10 . Select View results->No results through the menu bar or using the icon 
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1.5.4.2 Result surface

Model used
The model pyramid.gid used in this example can be found at Material location.

Menu 
View results->Result Surface

Description
This option uses a result component, or a scalar value, and draws a 3D surface above the mesh following the normals of 
this mesh.

1 . From preprocess mode open the model
2 . Switch to postprocess mode
3 . In order to get a better view turn off the Layer0 and Layer8 layers
4 . Select View->Render->Smooth 
5 . Select View results->Result surface-> Pressure (Pa). A surface will be drawn which results from moving the 

nodes along its smoothed normal according to the results value for this node
6 . Enter 20 as factor in the command line
7 . Due we have positive and negative values please set as Boundaries the layers style. Now all the result surface can 

be seen easily
8 . You can change several options in the Preferences window
9 . Select Utilities->Preferences->Postprocess->Result surface->Show elevations->None

10 . Select Utilities->Preferences->Postprocess->Result surface->Draw contour fill.  With this last option the 
surface is colored according to the pressure value

11 . Click on Apply button
12 . Play with the other options as you will
13 . Click on Close button
14 . Select View results->No results through the menu bar or using the icon 

1.5.4.3 Contour fill, cuts and limits

Model used
The model pyramid.gid used in this example can be found at Material location.

Contour fill

Menu
View results->Contour Fill

Description
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This option allows the visualization of coloured zones, in which a scalar variable or a component of a vector varies between 
two defined values. 

1 . From preprocess mode open the model
2 . Switch to postprocess mode
3 . In order to get a better view turn off the Layer0 and Layer8 layers
4 . Set as Body Bound the layers style
5 . Select View->Render->Normal
6 . Please select View results->Contour Fill->Pressure (Pa) through the menu bar, or clicking on or using the 

Window->View results... window
GiD can use as many colours as permitted by the graphical capabilities of the computer. The number of colours can be set 
through Utilities->Preferences->Postprocess->Contour fill and lines->Number of Colors. A menu of the variables 
to be represented will be shown, and the one that is chosen will be displayed using the default analysis and step selected.
In the model the pressure has been calculated. We can visualize the result for each step in a contour fill. 

You can choose the step that you want to view through the View results window or clicking on 

7 . Select the step 12.5

Several configuration options can be set via the Options menu.

NOTE: Another similar result visualization is Contour Lines but in this case the isolines of a certain nodal variable are 
drawn. In this case, each color ties several points with the same value of the variable chosen.
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Menu
Utilities->Preferences->Postprocess->Contour fill and lines 

You can change the color scale in other to get a more comfortable view. You can select several predefined color scales. The 
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default scale is standard, starting from blue (minimum) through yellow and green, to red (maximum).
1 . For Color map option select Terrain

You can also set your own scale.
2 . For Color map option select User defined
3 . Select the button More Color options to open a window.In this window you can change the number of different 

colors used in the scale. If you need more accuracy you can increase this number, or decrease it for a higher contrast.
4 . Change the number of colors to 20
5 . Click on Apply button
6 . Click on Close button

Cuts

Menu 
Geometry

In order to view the inner zone we will do several cuts along the model. 

We want to cut the inner volume in order to see the pressure in the air. 
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First of all we have to make visible the volume.
1 . Select Window->View style...
2 . Select Layer0 and make it visible clicking on the  icon
3 . Select Geometry->Cut plane->Succesion through the menu bar or clicking on  and then 

With the succession option you specify a line which will be used as axis to create cut planes orthogonal to this axis. 

NOTE: after clicking the first point, you can press the Alt key to snap the dynamic line to the screen horizontal, vertical or 
45º diagonals.

The number of planes is also asked for.
4 . The axis is defined by two points, please write the first one in the command line 30 200 0
5 . You are asked for the second point, introduce 30 -100 0
6 . Choose 4 cuts. You should obtain 4 parallel planes to Y axis.
7 . Select Window->View style... You can see that several layers had appeared a prefix like CutX. These names can 

always be changed through this window
8 . Set off the Layer0 again through the View style  window. You can rotate the model in order to see the contour fill 

result on the cut planes.
9 . In the same window select all the CutX and click on Delete button in order to delete all the cuts.

10 . Select Yes
11 . Select Options->Contour->Reset All in order to set all the defaults options.

Define limits
You can set the limit values for the contour fill. In our case we only want to see the positive values. In order to do this we 
will set the minimum value to 0.

1 . Select Utilities->Set contour limits->Define Limits... through the menu bar or clicking on 

Choosing the first option the Contour Limits window appears. With this window you can set the minimum/maximum value 
that Contour Fill should use.

2 . Check the Min checkbox
3 . Change the value to 0
4 . Click on the Apply button
5 . Click on the Close button

Outliers will be drawn in the colour defined in the Out Min Colour option. In order to view it better we will change this color 
to transparent.

6 . Select Utilities->Preferences->Postprocess->Contour fill and lines->Out minimum color->Transparent

7 . Select Utilities->Set contour limits->Define Limits... and press the button "o"
8 . Select View results->No Results
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1.5.4.4 Combined results

Model used
The model pyramid.gid used in this example can be found at Material location.

Menu
Window->Several results...

Description
Through this window you can select several results in order to visualize them at the same time. From this window you can 
also delete the undesired results visualizations.

1 . From preprocess mode open the model
2 . Switch to postprocess mode
3 . In order to get a better view turn on all the layers except Layer8
4 . Set as Body Bound the layers style

In order to see the inner vectors first we will do a cut through the volume. We want a cut parallel to the XY plane and near 
to the pyramid base.

5 . Select View->Rotate->Plane YZ to get a proper view to make de cut
6 . Select Geometry->Cut plane->2 points
7 . Select 2 points by your own near the pyramid base
8 . Press ESC to leave the cut function
9 . Turn off the Layer0

10 . Change the cut layers style to Boundaries
11 . Select Window->Several results...
12 . In this window select one over another. With this option GiD is told to visualize one result over another
13 . Select View Results->Default Analysis/Step->Ransol->12.5
14 . Select View Results->Contour Fill->Pressure
15 . Select View results->Display Vectors->Velocity (m/s)->|V|
16 . Select Utilities->Preferences->Postprocess->Vectors->Color Mode and select By modules
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17 . Select View results->No Results

18 . From preprocess mode open the model
19 . Switch to postprocess mode
20 . In order to get a better view turn off the Layer0 and Layer8 layers
21 . Set as Body Bound the layers style
22 . Select Window->Several results...
23 . In this window select one over another. With this option GiD is told to visualize one result over another
24 . Select View Results->Default Analysis/Step->Ransol->12.5
25 . Select View Results->Iso surfaces->Exact->Pressure through the menu bar or clicking on the 

26 . In the following questions: How many isosurfaces? Enter 1 and click Ok
27 . Enter the 1 value ...? Enter -0.2 and click Ok
28 . Select View Results->Contour Fill->Pressure
29 . Select Utilities->Set contour limits->Define Limits... through the menu bar or clicking on 

Choosing the first option the Contour Limits window appears. With this window you can set the minimum/maximum value 
that Contour Fill should use.
30 . Check the Min checkbox
31 . Change the value to 0
32 . Click on the Apply button
33 . Click on the Close button
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34 . Select Utilities->Preferences->Postprocess->Contour fill and lines->Out mininum color->Transparent
35 . Close the Several Results window
36 . Select Utilities->Set contour limits->Define Limits... and press the button "o"
37 . Select View results->No Results

1.5.4.5 Show min max

Model used
The model pyramid.gid used in this example can be found at Material location.

Menu
View results->Show Min Max

Description
With this option you can see the minimum and maximum value of the chosen result in the chosen analysis step. In our 
case we will choose the Vy component of velocity result for the first analysis step.

1 . From preprocess mode open the model
2 . Switch to postprocess mode
3 . Turn off the Layer0 and Layer8 in order to get a better view
4 . Change the style to Boundaries for all the layers
5 . Select View results->Default Analysis/Step->RANSOL->15 throught the menu bar or clicking on 

6 . Select View results->Show Min Max->Show both->Pressure (Pa)  throught the menu bar or clicking on . 

The label shows the node number and the value of the result
7 . Select View results->No Results
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1.5.4.6 Display Vectors

Model used
The model pyramid.gid used in this example can be found at Material location.

Menu
View results->Display Vectors

Description
With this display option the nodal vectors of the chosen result are shown.

We want to display the vectors of velocity in a cut. 
1 . From preprocess mode open the model
2 . Switch to postprocess mode
3 . Turn on all the layers except Layer8
4 . Select View results->Default Analysis/Step->RANSOL->20 throught the menu bar or clicking on 

In order to see the inner vectors first we will do a cut through the volume. We want a cut parallel to the YZ plane and near 
to the pyramid center

5 . Select View->Rotate->Plane XY (Original) to get a proper view to make de cut
6 . Select Do cuts->Cut Plane->2 points
7 . Select 2 points by your own or enter the following coordinates in the command line. 30 200 and 30 -100
8 . Press ESC to leave the cut function
9 . Turn off all the layers except the ones with name CCutSetX in order to only see the cut

10 . For all the cut layers change the style to Boundaries
11 . Select View results->Display Vectors->Velocity (m/s)->|V|

Menu
Utilities->Preferences->Postprocess->Vectors
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1 . For Color Mode option select By Modules in order to see the vectors by colors depending on their value
2 . The option Number of colors turns on. Enter 50 and click Apply to get more accuracy
3 . For Filter factor option, enter 5 and click Apply. This option changes the number of displayed vectors
4 . Click on Close button
5 . Delete the layers with name CutX
6 . Select View results->No Results

1.5.4.7 Stream lines

Model used
The model pyramid.gid used in this example can be found at Material location.

Menu
View results->Stream Lines

Description
With this option you can display a stream line, or in fluid dynamics, a particle tracing, in a vector field.
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1 . From preprocess mode open the model
2 . Switch to postprocess mode
3 . Turn on all the layers except Layer8
4 . Set as Body Bound the layers style

We want to create some stream lines near the pyramid center in order to plot the velocity result near it. So we will make a 
cut near the center and we will select there the points where we want to plot the stream lines. We want a cut parallel to 
the XZ plane and near to the pyramid center.

5 . Select View->Rotate->Plane XY (Original) to get a proper view to make de cut
6 . Select Geometry->Cut Plane->2 points
7 . Select 2 points by your own or enter the following coordinates in the command line. -70 78 and 130 78
8 . Press ESC to leave the cut function
9 . For each cut created change the style to Body Lines

10 . To get a better view set off all the layers except the ones with name CutX 
11 .Select View->Rotate->Plane XZ

12 . Select View results->Stream Lines->In a quad->Velocity (m/s) throught the menu bar 
With this option you can define a quadrilateral area which will be used to create a N x M matrix of points. These points will 
be the start for the stream lines. 
We want to create several stream lines around the pyramid.

Note: This action could also be done clicking on in the icon bar. In this case we have to select the way to define the 

start point through the mouse menu. In this case select Contextual->In A Quad.

13 . From the mouse menu (right button click) select Contextual->Join Ctrl-a
14 . Define a quadrilateral area near the pyramid shape clicking on 4 mesh points 
15 . You are asked for the number of points in the quad. Enter 5,5 and click Ok
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The stream lines are created.
16 . Click the middle mouse button or press the ESC key in order to finish the operation
17 . Turn off the cuts layers and set on the layers Layer4 and Layer9

Menu
Utilities->Preferences->Postprocess->Stream lines 
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1 . Select Utilities->Preferences->Postprocess->Stream lines
2 . Check Use triangles of size in order to draw the stream lines with triangles. Left the size by default
3 . Select Color mode->Stream contour filled option

The stream lines will be drawn with the colors used in the velocity contour fill.
4 . In Detail level select ribbons. With this option the streams show the swirl of the velocity field
5 . Click Apply



80Stream lines

6 . Change the Detail level to 4 sided prism again
7 . Check the Show arrows option
8 . Set 20 for the Size option
9 . Set 20 for the Spacing option

10 . Clilck Apply
11 . Click on Close button
12 . Select View results->Delete->Stream lines->All

1.5.4.8 Graphs

Model used
The model pyramid.gid used in this example can be found at Material location.

Menu
View results->Graphs

Description
From this menu several graphs types can be created, we will try some of them. Graphs are supported for results defined 
over nodes.
Graphs are organized into graph sets in order to ease the management. Each set shares the same units for each axis. 
When a graph is created is placed in the current graphset if the units are the same, otherwise a new graphset is created. 
In order to work with graphs we will use the 'graphs window'.

1 . From preprocess mode open the model
2 . Switch to postprocess mode
3 . Turn on all the layers except the Layer8 through the View style window
4 . Change the mesh style to boundaries for all the layers

The Point evolution  graph displays a graph of the evolution of the selected result along all the steps, of the default 
analysis, for the selected nodes.

5 . Select View results->Graphs->Point evolution->Pressure (Pa)
6 . Write 30 65 15 in the command line in order to specify the point
7 . Affter pressing the Escape key, or the middle mouse button, the graph will be shown in a separate window:
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The graph is created in the graphset-1. We will create another graph in the same graph set.

The Line graph displays a graph defined by the line connecting two selected nodes of surfaces or volumes, or any 
arbitrary points on any projectable surface and in any position.

8 . Select View results->Default Analysis/Step->RANSOL->0
9 . Select View results->Graphs->Line graph->Pressure(Pa)

10 . Write 30 -100 0 in the command line in order to specify the initial point
11 . Write 30 200 0 in the command line in order to specify the final point

Now both graphs are showed in the same graph set:
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We will rename the graph set.
12 . In the top part of the window click the  icon

13 . A window will appear asking for a new name. Enter 'Pressure', for example

We will create a new graph set.
14 . In the top part of the window click the  icon

A new graph set is created with default name 'graphset-1'. When a new graph set is created becomes the current one. We 
can see that there are no graphs on this new graph set.
It's also possible to create graphs from the graph window.
15 . Go to Create tab and select Point evolution int View option
16 . In Y Axis list double click Velocity (m/s)->|V|
17 . Write 30 65 15 in the command line in order to specify the point
18 . Press Escape to finish the graph.

We can manage graphs and graphs sets in the Options panel. Depending if we are selecting a graph set or a graph in the 
tree we will see different options in the tab.
19 . Go to the Options panel, select the 'Pressure (Pa) evolution at (30, 65, 15)' graph and delete it pressing the button 

with the red cross.
20 . A confirmation window appears. Click Yes.

Please notice that the current graph set have been changed to 'Pressure'. Now the Plot graph panel will show only two 
graphs:

The graph size is re-adapted. We will change several style options of a graph.

21 . Double click in any point of one graph and we will access to the Options tab
22 . Choose Line in the Style option
23 . Set to red the Color option. You can do it writing #ff0000 or selecting the red clicking on the right color window
24 . Set to 4.0 the Line width
25 . Click on Apply button

Graph sets options can be managed selecting the set in the tree.
26 . Select 'Pressure' branch. The options will change.
27 . For instance mark 'Logarithmic scale' option in X axis.
28 . Click on Apply button
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We can export the graph information in order to open it later with GiD.
29 . Select Files->Export->Graph->All graphsets. You are asked for the location where to save the .grf file
30 . Choose the location
Now you can import the graphs selecting Files->Import->Graph

If we select Options->Graphs->Clear graphs we will delete all graphs in current graph set. We can also delete them 
through the graphs window selecting the graph set in the tree and clicking the red cross button.
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